Results 1 to 9 of 9

Thread: HOW TO "do nothing when the lid shuts" ???

  1. #1
    Join Date
    May 2021
    Posts
    6

    Default HOW TO "do nothing when the lid shuts" ???

    How the heck can you do this in Linux? In windows its easy there is an option to "do nothing when the lid shuts" but in Linux I cant find it anywhere. When i remote in using another screen i want to close my laptop lid so i can us emy main monitor but every time I close the lid on the laptop it disconnects my rdp session

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,270
    Blog Entries
    15

    Default Re: HOW TO "do nothing when the lid shuts" ???

    Quote Originally Posted by vc View Post
    How the heck can you do this in Linux? In windows its easy there is an option to "do nothing when the lid shuts" but in Linux I cant find it anywhere. When i remote in using another screen i want to close my laptop lid so i can us emy main monitor but every time I close the lid on the laptop it disconnects my rdp session
    Hi
    Edit the file /etc/systemd/logind.conf and change the line;

    Code:
    #HandleLidSwitch=suspend
    
    to
    
    HandleLidSwitch=ignore
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    May 2021
    Posts
    6

    Default Re: HOW TO "do nothing when the lid shuts" ???

    Unfortunately that didnt work?

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,270
    Blog Entries
    15

    Default Re: HOW TO "do nothing when the lid shuts" ???

    Quote Originally Posted by vc View Post
    Unfortunately that didnt work?
    Hi
    What desktop environment? Some desktops have their own quirks and need to look at the other logind conf settings or desktop settings to override.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: HOW TO "do nothing when the lid shuts" ???

    Don't you need to logout and back in for that change to take effect? Also, in MATE you change it in System > Preferences > Hardware > Power Management.

    Gene

  6. #6
    Join Date
    May 2021
    Posts
    6

    Default Re: HOW TO "do nothing when the lid shuts" ???

    ok got it working thanks

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,270
    Blog Entries
    15

    Default Re: HOW TO "do nothing when the lid shuts" ???

    Quote Originally Posted by vc View Post
    ok got it working thanks
    Hi
    So what did you have to change, be a pointer to other Forum users
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8
    Join Date
    May 2021
    Posts
    6

    Default Re: HOW TO "do nothing when the lid shuts" ???

    what Malcom Lewis wrote above

  9. #9

    Default Re: HOW TO "do nothing when the lid shuts" ???

    I made the same and rebooted but it doesn't works

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •