Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Unresolved upgrade problems

  1. #1

    Default Unresolved upgrade problems

    I started using OpenSuse back in the v11 days and have been very pleased. A while back, I upgraded from Leap 15.1 to Leap 15.2. Took the usual brief look at upgrade notes and upgraded 15.1 to 15.2, or at least tried to. I now know that there were problems with the repositories...but I didn't at the time. So, my upgrade has problems running my important applications like kmail and KMyMoney, Symptoms: No output, and programs terminate. Since I use these all the time, I've been working around the problems, but now that 15.3 is almost here, I'd like to get things fixed so that I don't carry the problems forward. Is there a clear, straightforward set of steps on how to get my system properly upgraded to 15.2? I think that my location may matter (at least when I last looked location and which servers to choose was an issue, I don't know if it still is, but my location is in New Jersey, USA. I have no idea if this will be helpful, but a couple of KDE games do run, and the "ABOUT" dialog tells me that I"m using: KDE Frameworks 5.71.0 , Qt 5.12.7 (built against 5.12.7) , xcb windowing system.

    Thank you for any help...
    Mark

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    28,718

    Default Re: Unresolved upgrade problems

    First thing we (and you) have to look at is of course your repos:
    Code:
    zypper lr -d
    Henk van Velden

  3. #3

    Default Re: Unresolved upgrade problems

    Code:
    #  | Alias                     | Name                               | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                      | Service
    ---+---------------------------+------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------+--------
     1 | openSUSE-Leap-15.2-1      | openSUSE-Leap-15.2-1               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | cd:/?devices=/dev/disk/by-id/ata-ATAPI_iHAS124_B_3524215_3E8112503929    | 
     2 | repo-debug                | Debug Repository                   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.2/repo/oss/      | 
     3 | repo-debug-non-oss        | Debug Repository (Non-OSS)         | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.2/repo/non-oss/  | 
     4 | repo-debug-update         | Update Repository (Debug)          | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.2/oss/                 | 
     5 | repo-debug-update-non-oss | Update Repository (Debug, Non-OSS) | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.2/non-oss/             | 
     6 | repo-non-oss              | Non-OSS Repository                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/non-oss/        | 
     7 | repo-oss                  | Main Repository                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/oss/            | 
     8 | repo-source               | Source Repository                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.2/repo/oss/     | 
     9 | repo-source-non-oss       | Source Repository (Non-OSS)        | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.2/repo/non-oss/ | 
    10 | repo-update               | Main Update Repository             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.2/oss                        | 
    11 | repo-update-non-oss       | Update Repository (Non-Oss)        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.2/non-oss/

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    28,718

    Default Re: Unresolved upgrade problems

    That looks fine. The only thing is that you could Disable the first one. It is the installation medium (CD or USB memory stick) and you do not need that again.

    For upgrading, did you do a zypper dup?
    And did you do zypper up (or a YaST equivalent) at a regular base, or at least recenty?

    And then about the problems you seem to have. Did you report them here and asking for help? Remember that "working around problems" can only be a temporary by-pass and the time bought with it should be used to resolve the real problem. IMHO you must first get rid of the present problems before you go to the next openSUSE Leap version.
    Henk van Velden

  5. #5

    Default Re: Unresolved upgrade problems

    Thank you so much for your quick response. You made 3 points, so I will respond to each.

    1. Easy to disable the install repo.
    2. I used a DVD for the upgrade.
    3. Yes I reported here, and I could not figure out how to do what was suggested. The replies had something to do with repos.

    Before I do anything, please confirm that you are suggesting that I do a '#zypper up' at this time.

    I am 100% with you that I need to get my system in order before doing anything else.

    Much appreciated,
    Mark

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    28,718

    Default Re: Unresolved upgrade problems

    When you didn't update recently, a zyyper up is certainly something that should be done.
    Henk van Velden

  7. #7

    Default Re: Unresolved upgrade problems

    ...moving right along....
    OK. I ran the steps and found the following: (I'm hand keying this in...didn't save it at firstl

    Processes that use deleted files
    Xorg
    Kded5
    Kwin11
    plasmashell
    Kleopatra
    Konsole (3 times)
    akonadi_control
    Kgpg
    latte-dock
    konsole
    akonadi_akonotes_resource
    akonadi_birthdays_resource
    akonadi_contracts_resource
    akonadi_followupreminder_agent
    akonadi_ical_resource
    akonadi_indexing_agent
    akonadi_maildir_resource
    akonadi_maildispatcher_agent
    akonadi_newmailnotifier_agent
    notes_agent
    akonadi_pop3_resource

    Reboot probably not necessary

    ***************************
    Well, I said to myself, a reboot can't harm anything,
    so I shutdown and then rebooted...and the original problems are not resolved.

    Thanks,
    Mark

  8. #8
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    471

    Default Re: Unresolved upgrade problems

    Quote Originally Posted by MarkNeido View Post
    kmail and KMyMoney, Symptoms: No output, and programs terminate.
    Can you try to start these programs running from the command prompt and report what the output is.
    You can start a command window by stating Konsole.

    For kmail, you can issue "kmail" and for KMyMoney likely kmymoney, but I am not sure of that as I do not have it installed.

  9. #9

    Default Re: Unresolved upgrade problems

    kmail: error while loading shared libraries: libwebp.so.6: cannot open shared object file: No such file or directory

  10. #10

    Default Re: Unresolved upgrade problems

    mark:~ # find / -iname libwebp.so.6
    find: ‘/run/user/1000/gvfs’: Permission denied
    /snap/spotify/45/usr/lib/x86_64-linux-gnu/libwebp.so.6
    /snap/spotify/46/usr/lib/x86_64-linux-gnu/libwebp.so.6
    /usr/lib/libwebp.so.6

    mark:~ # ls -l /usr/lib/libwebp.so.6
    lrwxrwxrwx 1 root root 16 Dec 17 2018 /usr/lib/libwebp.so.6 -> libwebp.so.6.0.0

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •