Page 5 of 5 FirstFirst ... 345
Results 41 to 47 of 47

Thread: AMDGPU errors and occasional crashes/hangs

  1. #41

    Default Re: AMDGPU errors and occasional crashes/hangs

    Quote Originally Posted by pinguin74 View Post
    (...)
    What I did, I fetched the Linux firmware from their git repo at
    (....)
    Oh NO ! That problem still is there, just had a freeze under KDE, new firmware did not help.
    Maybe there is some amdgpu kernel option that work around it?

  2. #42
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,298
    Blog Entries
    15

    Default Re: AMDGPU errors and occasional crashes/hangs

    Hi
    Try adding the kernel boot option in grub amdgpu.dc=0 and see if that helps.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #43
    Join Date
    Jan 2016
    Location
    UK
    Posts
    756

    Default Re: AMDGPU errors and occasional crashes/hangs

    Quote Originally Posted by broadstairs View Post
    My bug is still open and now I have passed the bug on to freedesktop now and you can view it at https://gitlab.freedesktop.org/drm/amd/-/issues/1609, as you can see someone else has been able to confirm it.

    Stuart

  4. #44
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,173

    Default Re: AMDGPU errors and occasional crashes/hangs

    I've noted that FF does not like to use swap. When I had 4 gig and ran a small VM(1Gig) running FF also crashed system with 8 gig all is well. That was a while back but worth noting

  5. #45

    Default Re: AMDGPU errors and occasional crashes/hangs

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Try adding the kernel boot option in grub amdgpu.dc=0 and see if that helps.
    I´m running a mobile Ryzen APU, this requires the DC to work at all, without it, it probably would not boot at all....

  6. #46

    Default Re: AMDGPU errors and occasional crashes/hangs

    After playing with dozens of amdgpu options, I just found out something today.

    When enabling vertical sync in Xorg, KDE immediately freezes after login.

    I have now disabled vertical sync for Xorg globally in

    /etc/X11/xorg.conf.d/50-device.conf


    which now looks like this:

    Code:
    $ cat /etc/X11/xorg.conf.d/50-device.conf 
    
    Section "Device"
      Identifier "Card0"
      Driver  "amdgpu"
      Option  "TearFree" "false"
    
    EndSection
    Additionally II changed /etc/profile.d/kwin_env.sh which reads now like so:

    Code:
    $ cat /etc/profile.d/kwin_env.sh 
    
    #!/bin/sh
    export KWIN_EXPLICIT_SYNC=0

    I have not yet done day or hours long of testing, but I have no freezes currently doing some low "stress testing" with VLC and Firefox.

    Of course the first setting applies only to Xorg and maybe not to Wayland and the second is KDE specific.

  7. #47

    Default Re: AMDGPU errors and occasional crashes/hangs

    Maybe solution is in kernel update: https://forums.opensuse.org/showthre...95#post3035895

Page 5 of 5 FirstFirst ... 345

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •