Results 1 to 3 of 3

Thread: Cannot use PostGIS raster

  1. #1

    Question Cannot use PostGIS raster

    Code:
    zypper ar https://download.opensuse.org/repositories/Application:/Geo/openSUSE_Leap_15.2/
    zypper refresh
    zypper install postgresql12-postgis postgresql12-contrib
    # Configure access and so on, optionally create a DB to test this on, then …
    psql -U postgres -c "CREATE EXTENSION postgis; CREATE EXTENSION postgis_raster;"
    Code:
    ERROR:  could not load library "/usr/lib/postgresql12/lib64/postgis_raster-3.so": /usr/lib64/libgdal.so.28: undefined symbol: opj_encoder_set_extra_options

  2. #2
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    472

    Default Re: Cannot use PostGIS raster

    Can you check if you have the openjpeg2 package installed? The symbol opj_encoder_set_extra_options is defined in that I think.

  3. #3
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    472

    Default Re: Cannot use PostGIS raster

    For reference: Just tried on Tumbleweed and for me postgresql13 can run "CREATE EXTENSION postgis_raster;" without problems.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •