Results 1 to 7 of 7

Thread: Auto login not working in Plasma

  1. #1

    Default Auto login not working in Plasma

    Hi there,

    I have activated the auto log in option in: System Settings>Account Details>User Manager but it does not work, and I still have to enter my password at boot.
    Is there any other switch I have missed?


    Thanks in advance

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,128

    Question Re: Auto login not working in Plasma

    Quote Originally Posted by MadSplinter View Post
    I have activated the auto log in option in: System Settings>Account Details>User Manager
    Did you check the User Account Management in YaST?

    Please, also check the directory “/etc/sddm.conf.d/” for a configuration file containing a section named “[Autologin]” – there should be an entry “User=«the user to be automatically logged in»” …

    Please, take note that, the file “/etc/sddm.conf” should be empty «despite advice to the contrary where ever … » – all changes to the system default SDDM settings held in the files located in the system directory “/usr/lib/sddm/sddm.conf.d/” shall be made by machine specific (administrator) configuration files located in “/etc/sddm.conf.d/” …

    The “sddm.conf” man (5) page –
    Code:
           /etc/sddm.conf
                  Local configuration file for compatibility

  3. #3

    Default Re: Auto login not working in Plasma

    Thanks for the suggestion, it was sufficient to activate it from YaST --> User and Group Administration with Expert Options --> Login Settings.

    I guess it is a bit confusing, as the manual specifically mentions GNOME, and it turns out that the switch in Plasma is useless

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    28,680

    Default Re: Auto login not working in Plasma

    As this is of course something that must be organized on the system level (what a mess would it be if every user could decide for him/herself that (s)he must be the one to log in automatically!), my first choice to find a setting would be YaST. And even if KDE Settings would provide a setting, then that should ask for the root password.
    Henk van Velden

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,128

    Default Re: Auto login not working in Plasma

    Quote Originally Posted by MadSplinter View Post
    it turns out that the switch in Plasma is useless
    Yes, I know – it seems to be something to do with the KDE Plasma System Settings related to the Users, not being able to setup the SDDM configuration but,
    • If you look at the System Settings for “Startup and Shutdown” and the “Advanced Settings” tab of the “Login Screen (SDDM)” setup, you'll also find some auto-login information …

    But, this information points to ‘/etc/sysconfig/displaymanager’ and the parameter “DISPLAYMANAGER_AUTOLOGIN” – which is possibly OK for other Display Manages but, possibly, not SDDM …

  6. #6
    Join Date
    Sep 2012
    Posts
    6,483

    Default Re: Auto login not working in Plasma

    Quote Originally Posted by dcurtisfra View Post
    But, this information points to ‘/etc/sysconfig/displaymanager’ and the parameter “DISPLAYMANAGER_AUTOLOGIN” – which is possibly OK for other Display Manages but, possibly, not SDDM …
    https://build.opensuse.org/package/v...patch?expand=1

    If it does not work, report a bug.

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,128

    Default Re: Auto login not working in Plasma

    Quote Originally Posted by arvidjaar View Post
    If it does not work, report a bug.
    Looks as if it should be OK – despite the lack of documentation …

    Code is fact.
    • Documentation is fiction …

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •