openSUSE Security Update: Security update for postsrsd______________________________________________________________________________Announcement ID: openSUSE-SU-2021:0646-1Rating: moderateReferences: #1180251 Cross-References: CVE-2020-35573Affected Products: openSUSE Leap 15.2______________________________________________________________________________ An update that fixes one vulnerability is now available.Description: This update for postsrsd fixes the following issues: Update to release 1.11 [boo#1180251] * Drop group privileges as well as user privileges * Fixed: The subprocess that talks to Postfix could be caused to hang with a very long email address. [CVE-2020-35573] Update to release 1.6 * Fix endianness issue with SHA-1 implementation * Add dual stack support * Make SRS separator configurablePatch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.2: zypper in -t patch openSUSE-2021-646=1Package List: - openSUSE Leap 15.2 (x86_64): postsrsd-1.11-lp152.4.3.1 postsrsd-debuginfo-1.11-lp152.4.3.1 postsrsd-debugsource-1.11-lp152.4.3.1References: https://www.suse.com/security/cve/CVE-2020-35573.html https://bugzilla.suse.com/1180251

More...