Results 1 to 9 of 9

Thread: GlobalProtect "Cannot connect to local gpd service."

  1. #1

    Default GlobalProtect "Cannot connect to local gpd service."

    Hello everyone!

    I need to connect to my universitys vpn server via the GlobalProtect protocol. The IT services provides a rpm packages which I installed with Yast.

    This is the terminal output:

    Code:
    user@computer:~> globalprotect 
    Cannot connect to local gpd service. 
    user@computer:~> systemctl status gpd 
    Unit gpd.service could not be found.
    I don't know how to solve this issue. Can anyone help?
    Re-installing the packages does not solve the problem.

    Thanks in advance!

  2. #2
    Join Date
    Apr 2016
    Location
    Cambridge, UK
    Posts
    244

    Default Re: GlobalProtect "Cannot connect to local gpd service."

    Quote Originally Posted by witziege View Post
    Hello everyone!

    I need to connect to my universitys vpn server via the GlobalProtect protocol. The IT services provides a rpm packages which I installed with Yast.

    This is the terminal output:

    Code:
    user@computer:~> globalprotect 
    Cannot connect to local gpd service. 
    user@computer:~> systemctl status gpd 
    Unit gpd.service could not be found.
    I don't know how to solve this issue. Can anyone help?
    Re-installing the packages does not solve the problem.

    Thanks in advance!

    I know nothing about GlobalProtect but I am sure you will need to provide a destination either in the command line or a config file.

    I am sure the IT services department can help you (maybe ) but I also found this link that may help:

    https://docs.paloaltonetworks.com/gl...for-linux.html

  3. #3

    Default Re: GlobalProtect "Cannot connect to local gpd service."

    Thanks for the link. Unfortunately adding the server address is not changing the output.

    And sadly my universitys IT service takes multiple months (no joke) to respond.
    Last edited by witziege; 29-Apr-2021 at 04:37. Reason: spelling

  4. #4
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    650

    Default Re: GlobalProtect "Cannot connect to local gpd service."

    My employer is using GlobalProtect but my work-laptop is Win10 although it's primary use is VNC to Linux machines and email/browser.

    What you can try for Linux is to use Openconnect

    Code:
    > sudo openconnect --help 
    Usage:  openconnect [options] <server> 
    Open client for multiple VPN protocols, version v8.10 
    
    Using GnuTLS 3.7.1. Features present: PKCS#11, RSA software token, HOTP software token, TOTP software token, Yubikey OATH, System keys, DTLS, ESP 
          --config=CONFIGFILE         Read options from config file 
      -V, --version                   Report version number 
      -h, --help                      Display help text 
    
    Set VPN protocol: 
          --protocol=anyconnect       Compatible with Cisco AnyConnect SSL VPN, as well as ocserv (default) 
          --protocol=nc               Compatible with Juniper Network Connect 
          --protocol=gp               Compatible with Palo Alto Networks (PAN) GlobalProtect SSL VPN 
          --protocol=pulse            Compatible with Pulse Connect Secure SSL VPN 
    
    Authentication: 
      -u, --user=NAME                 Set login username 
          --no-passwd                 Disable password/SecurID authentication 
          --non-inter                 Do not expect user input; exit if it is required 
          --passwd-on-stdin           Read password from standard input 
          --authgroup=GROUP           Choose authentication login selection
    
    ...
    So --protocol=gp and some more arguments.

  5. #5
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    650

    Default Re: GlobalProtect "Cannot connect to local gpd service."

    Before trying Openconnect it is likely good to check the GlobalProtect version as I see in the the Openconnect changelog:

    Emulated a newer version of GlobalProtect official clients, 5.1.5-8; was 4.0.2-19
    And that is not yet in the v8.10 on Tumbleweed. I do not know which version Leap has but it will not be newer.

  6. #6

    Default Re: GlobalProtect "Cannot connect to local gpd service."

    I have checked the openconnect version which I installed and noticed that 7.08 was still installed. I added the network repo and and upgraded openconnect to version 8.10.
    But I still can not choose PAN in the Gnome networkmanager. How do I add a new protocol to the menu?

  7. #7
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    650

    Default Re: GlobalProtect "Cannot connect to local gpd service."

    Good you upgraded openconnect to version 8.10.

    Before worrying about adding it to the NetWorkManager, are things working from the command prompt?
    If that is not the case, the NetworkManager comes later.

  8. #8

    Default Re: GlobalProtect "Cannot connect to local gpd service."

    Quote Originally Posted by marel View Post
    are things working from the command prompt?
    Yes, openconnect works fine inside the command prompt.

  9. #9
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    650

    Default Re: GlobalProtect "Cannot connect to local gpd service."

    Okay, if openconnect works from the command prompt you can try nmcli or the OpenConnect GUI.

    For issues with the NetworkManager, see https://gitlab.freedesktop.org/Netwo...nager/-/issues

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •