Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Failed to Boot to Graphics

Hybrid View

  1. #1

    Default Failed to Boot to Graphics

    I upgraded from 15.1 to 15.2 using the network method. There was one checksum error with libswscale4, but I typed in the first four characters of the checksum to let it continue. I figured it would be replaced by a more up-to-date package from packman instead of the main update repo anyway.

    No problems with grub2. Once a kernel is selected, no problem with seeing the updating three dots, nor switching to see loading logs.

    % more /var/log/Xorg.0.log

    "Failed to initialize the NVIDIA kernel module. Please see the system's kernel log for additional error messages..."
    ...
    "No devices detected."
    ...
    "no screens found(EE)"

    % lsmod | grep nvidia

    returned nothing, which probably means the kernel module didn't load.

    % uname -r

    5.3.18-lp152.72-preempt

    I'm using an older Nvidia GT240 card, which only has the nvidia-gfxG03-kmp-default module, not a -preempt version, like for G04 and G05. Using "zypper se nvidia-*G03*" does list the packages installed (i+).

    By default, it appears that 15.2 sets grub2 to use the -preempt kernels, so my suspicion is that I need to switch grub2 to use the -default kernel.

    I backed up /boot/grub2/grub.cfg and modified it to load -default instead of -preempt, which worked, but the nvidia kernel module still doesn't load. lsmod still doesn't have nvidia listed.

    Oh, startx says "/usr/bin/Xorg is not setuid, maybe that's the reason?"

    -----

    1. How do I properly configure grub2 to list the three -default kernels instead of the -preempt ones? grub2 currently only lists three choices, though I do see the -default ones as menuentry's in the cfg file. I think I'll need the -default kernels, as Nvidia doesn't provide for -preempt for G03 era cards.

    2. Why isn't the nvidia kernel module being loaded? nouveau is blacklisted in /etc/modprobe.d/nvidia.conf and nvidia-default.conf. Usually a conflict there causes the nvidia drivers not to load?

    3. What other checks can I do to get the GUI up?

    Thanks for the help!

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,189
    Blog Entries
    3

    Default Re: Failed to Boot to Graphics

    Quote Originally Posted by linuxvinh View Post
    There was one checksum error with libswscale4, but I typed in the first four characters of the checksum to let it continue.
    I never do that. On the rare occasions where I get a checksum error, I cancel and then try again a few hours later.

    In your case, it looks as if the real problem is with the Nvidia drivers. Do you use "secure-boot". If you do, then try turning that off and see if the graphics comes up that way.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    851

    Default Re: Failed to Boot to Graphics

    What's the version of your Nvidia driver?
    Code:
    rpm -qa |grep nvidia
    the latest driver from cuda repository 465.* does not come with proper MOK keys and will fail to load unless if you disable secure boot as nrickert said.

    To answer 1. just delete the preempt
    2. try looking at the kernel log as it says
    Code:
    dmesg |grep -i nvidia
    3. Try starting x and look at the error codes.
    Code:
    startx

  4. #4

    Default Re: Failed to Boot to Graphics

    Quote Originally Posted by SJLPHI View Post
    What's the version of your Nvidia driver?
    Code:
    rpm -qa |grep nvidia
    the latest driver from cuda repository 465.* does not come with proper MOK keys and will fail to load unless if you disable secure boot as nrickert said.

    To answer 1. just delete the preempt
    2. try looking at the kernel log as it says
    Code:
    dmesg |grep -i nvidia
    3. Try starting x and look at the error codes.
    Code:
    startx
    I guess this is pretty glaring that I don't have 15.2 drivers...

    % rpm -qa | grep nvidia

    nvidia-glG03-340.108-lp151.26.1.x86_64
    nvidia-gfxG03-kmp-default-340.108_k4.12.14_lp151.27-lp151.26.1.x86_64
    x11-video-nvidiaG03-340.108-lp151.26.1.x86_64
    nvidia-uvm-gfxG03-kmp-default-340.108_k4.12.14_lp151.27.26.1.x86_64
    nvidia-computeG03-340.108-lp151.26.1.x86_64

    1. Delete, as in uninstall the preempt kernel packages? Would that also properly trigger a grub.cfg rebuild?
    2. Sorry I can't copy/paste verbatim, as I'm typing this on another computer and the above was already difficult to check to accuracy...

    input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00:06.0/0000:0a:00.1/sound/card1/input24
    [four lines similar with different pcm and input numbers]
    audit: type=1400 audit(1619133343.982:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe" pid=936 comm="apparmor_parser"
    [another line similar, but name="nvidia_modprobe//kmod"]

    3. startx errors...

    modprobe: ERROR: could not find module by name='nvidia'
    modprobe: ERROR: could not insert 'nvidia': Unknown symbol in module, or unknown parameter (see dmesg)
    [two times the two above lines]
    (EE) Fatal server error: (EE) no screens found(EE)
    (EE) Please consult The X.Org Foundation support at http://wiki.x.org for help.
    (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    (EE) VGA Arbitration: Cannot restore default device.
    (EE) Server terminated with error (1). Closing log file.
    xinit: giving up
    xinit: unable to connect to X server: Cannot assign requested address
    xinit: server error
    xinit failed. /usr/bin/Xorg is not setuid, maybe that's the reason?
    If so either use a display manager (strongly recommended) or adjust /etc/permissions.local and run "chkstat --system --set" afterwards

    So we can pretty much conclude that I don't have the 15.2 drivers. I do have the Nvidia repo enabled, but I guess the pre-built drivers are not being provided by Nvidia anymore? Would it be possible for me to install the Nvidia driver the "hard way"?

  5. #5

    Default Re: Failed to Boot to Graphics

    Quote Originally Posted by nrickert View Post
    I never do that. On the rare occasions where I get a checksum error, I cancel and then try again a few hours later.

    In your case, it looks as if the real problem is with the Nvidia drivers. Do you use "secure-boot". If you do, then try turning that off and see if the graphics comes up that way.
    I've never encountered that before and the install was right in the middle of downloading, and since I opted for "update in heaps", instead of "download all first", I thought I might mess things up if I didn't continue. (Quickly looking up the package said it had to do with ffmpeg and I knew I would add packman later, which typically has more up-to-date packages with ffmpeg, so I wasn't concerned.) I wasn't watching the update the whole time, as there were something like 3400 packages, so didn't know if some packages had been installed or not. 15.0 to 15.1 went super smooth so I guess I was lulled into thinking 15.2 wasn't going to be an issue with graphics cards.

    I know I didn't active secure-boot, so unless it's something new by default, it's not on.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,189
    Blog Entries
    3

    Default Re: Failed to Boot to Graphics

    Quote Originally Posted by linuxvinh View Post
    I know I didn't active secure-boot, so unless it's something new by default, it's not on.
    I asked, because Leap 15.2 is checking driver signatures. Earlier Leap versions didn't do that.

    From earlier comments in this thread, it looks as if you have an older driver installed, which is not compatible with this kernel. I'll leave it to people more experienced with Nvidia drivers to try to help you.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  7. #7

    Default Re: Failed to Boot to Graphics

    Quote Originally Posted by nrickert View Post
    I asked, because Leap 15.2 is checking driver signatures. Earlier Leap versions didn't do that.

    From earlier comments in this thread, it looks as if you have an older driver installed, which is not compatible with this kernel. I'll leave it to people more experienced with Nvidia drivers to try to help you.
    Thank you for your time and response. I made the mistake of starting the update late at night, thinking it would go smoothly while I binged on The Mandalorian. I stressed over it not going to graphics mode and stayed up way late to debug. I wanted to write a somewhat informed post and hope that answers would percolate a bit while I slept for a few hours.

  8. #8

    Default Re: Failed to Boot to Graphics

    Progress... or lack of...

    I uninstalled the pre-built version of the Nvidia drivers so I could install 340.108 the "hard way". 340.108 is the last version that supports the GT240. (Nvidia's installer recognized the card and said 340.x was the last release that supports it.) NVidia's installer also created files to disable nouveau.

    After going through the install, still no graphics.

    I decided to take the advice of installing a newer graphics card, an AMD/ATI Radeon R9 290. This turned out to be a little tricky for my system, as the power supply I have only has two PCI-e power connectors, a 6 pin and an 8 pin. The 6 pin was already connected to the motherboard, which happened to be for a graphics card. The 290 needs both a 6 pin and 8 pin to power it. I only need to power one graphics card, so the 6 pin was disconnected from the motherboard and connected to the 290, along with the 8 pin.

    Code:
    % lspci | grep VGA
    
    0a:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/390]
    Code:
    % lsmod | grep radeon
    
    radeon 1630208 1
    ttm 122880 2 amdgpu,radeon
    drm_kms_helpler 229376 2 amdgpu,radeon
    drm 544768 6 gpu_sched,drm_kms_helper,amdgpu,radeon,ttm
    i2c_algo_bit 16384 2 amdgpu,radeon
    I'm back to the preempt kernel in grub2.

    Booting still doesn't go to graphics.

    I tried moving /etc/X11/xorg.conf to xorg.conf.bc since it still had nvidia as a Device. This was recommended on a page I found. No luck.

    I tried Xorg -configure to generate a new file, but the new /root/xorg.conf.new contained no references to radeon in the Device section.

    Code:
    % startx
    
    xauth: file/root/.serverauth.3428 does not exist
    
    (==) Using config directory: "/etc/X11/xorg.conf.d"
    (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    tion: Cannot restore default device.(EE) Server terminated with error (1). Closing log file.on support at http://wiki.x.org for help. (EE) Please also check the log file at "/var/log/Xorg.0.og" for additional information.(EE) VGA Arbitra
    xinit: giving up
    xinit: unable to connect to X server: Cannot assign requested address
    xinit: server error
    ------
    xinit failed. /usr/bin/Xorg is not setuid, maybe that's the reason?
    If so either use a display manager (strongly recommended) or adjust /etc/permissions.local and run "chkstat ---system --set" afterward
    It's making me wonder if the "hard way" Nvidia driver would have worked and there's something else wrong, as the Radeon should have "just" worked?

    Any things to try?

    Thanks.

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,862

    Default AW: Failed to Boot to Graphics

    Once more :
    The 340 driver is only supported by Leap 15.2 if you patch it before:
    https://forums.opensuse.org/showthre...er-not-working

    But it does not work on Leap 15.3 anymore, so maybe its better to use the nouveau driver.

    Also:
    please use Code-Tags:
    https://forums.opensuse.org/showthre...und-Your-Paste

  10. #10

    Default Re: Failed to Boot to Graphics

    Thank you Sauerland for continuing to help me!

    So, from what you've said, if I want to continue with the GT240 into the future, my best bet is with the nouveau driver, as even if I patch 340.x today, it's a short-term solution that may not work into 15.3?

    -----

    I've finally had success!

    I had put this in /etc/X11/xorg.conf.d/90-my_nvidia_hacks.conf:

    Code:
    Section "Device"
        Identifier "Device0"
        Driver "nvidia"
        VendorName "NVIDIA Corporation"
        BoardName "GeForce GT 240"
        Option "UseHotplugEvents" "false"
    EndSection
    to prevent my dual monitor configuration from switching to one screen when I switch the second monitor to another computer. (This is annoying to me as the desktop squishes and all the contents spread over two screens is put on one screen. I prefer the wide desktop to be there when I switch back from the other computer.)

    I removed the file and I have graphics mode! All good... except switching the second monitor to the other computer is back to paying attention of hotplug events. How do I tell the system to not use hotplug events with the radeon, like with nvidia?

    Thanks!

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •