Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Failed to Boot to Graphics

  1. #11

    Default Re: Failed to Boot to Graphics

    Quote Originally Posted by nrickert View Post
    I asked, because Leap 15.2 is checking driver signatures. Earlier Leap versions didn't do that.

    From earlier comments in this thread, it looks as if you have an older driver installed, which is not compatible with this kernel. I'll leave it to people more experienced with Nvidia drivers to try to help you.
    Thank you for your time and response. I made the mistake of starting the update late at night, thinking it would go smoothly while I binged on The Mandalorian. I stressed over it not going to graphics mode and stayed up way late to debug. I wanted to write a somewhat informed post and hope that answers would percolate a bit while I slept for a few hours.

  2. #12
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,871

    Default AW: Failed to Boot to Graphics

    Leap 15.2 does not support the Nvidia-G03-driver per Repo!

    I would do:
    Unistall all Nvidia Repo related Nvidia drivers:
    nvidia-glG03-340.108-lp151.26.1.x86_64
    nvidia-gfxG03-kmp-default-340.108_k4.12.14_lp151.27-lp151.26.1.x86_64
    x11-video-nvidiaG03-340.108-lp151.26.1.x86_64
    nvidia-uvm-gfxG03-kmp-default-340.108_k4.12.14_lp151.27.26.1.x86_64
    nvidia-computeG03-340.108-lp151.26.1.x86_64
    As you can see, this drivers are build for Leap 15.1 (kernel 4.12) not for Leap 15.2 (kernel 5.3)

    After this, searching for a nouveau blacklist file:
    Code:
    grep -i 'blacklist nouveau' /etc/modprobe.d/*
    There should be no output, if you get something like:
    Code:
    grep -i 'blacklist nouveau' /etc/modprobe.d/*
    /etc/modprobe.d/nvidia-installer-disable-nouveau.conf:blacklist nouveau
    this means, there is a blacklist file /etc/modprobe.d/nvidia-installer-disable-nouveau.
    You have to delete it by hand.

    Also searching for nomodeset:
    Code:
    cat /proc/cmdline
    If there is such entry, you can delete the entry in Yast----System----Bootloader


    Please:
    If you post something here, please use Code-Tags:
    https://forums.opensuse.org/showthre...und-Your-Paste

    Makes life easier.
    Last edited by Sauerland; 23-Apr-2021 at 00:14.

  3. #13

    Default Re: Failed to Boot to Graphics

    Progress... or lack of...

    I uninstalled the pre-built version of the Nvidia drivers so I could install 340.108 the "hard way". 340.108 is the last version that supports the GT240. (Nvidia's installer recognized the card and said 340.x was the last release that supports it.) NVidia's installer also created files to disable nouveau.

    After going through the install, still no graphics.

    I decided to take the advice of installing a newer graphics card, an AMD/ATI Radeon R9 290. This turned out to be a little tricky for my system, as the power supply I have only has two PCI-e power connectors, a 6 pin and an 8 pin. The 6 pin was already connected to the motherboard, which happened to be for a graphics card. The 290 needs both a 6 pin and 8 pin to power it. I only need to power one graphics card, so the 6 pin was disconnected from the motherboard and connected to the 290, along with the 8 pin.

    Code:
    % lspci | grep VGA
    
    0a:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/390]
    Code:
    % lsmod | grep radeon
    
    radeon 1630208 1
    ttm 122880 2 amdgpu,radeon
    drm_kms_helpler 229376 2 amdgpu,radeon
    drm 544768 6 gpu_sched,drm_kms_helper,amdgpu,radeon,ttm
    i2c_algo_bit 16384 2 amdgpu,radeon
    I'm back to the preempt kernel in grub2.

    Booting still doesn't go to graphics.

    I tried moving /etc/X11/xorg.conf to xorg.conf.bc since it still had nvidia as a Device. This was recommended on a page I found. No luck.

    I tried Xorg -configure to generate a new file, but the new /root/xorg.conf.new contained no references to radeon in the Device section.

    Code:
    % startx
    
    xauth: file/root/.serverauth.3428 does not exist
    
    (==) Using config directory: "/etc/X11/xorg.conf.d"
    (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    tion: Cannot restore default device.(EE) Server terminated with error (1). Closing log file.on support at http://wiki.x.org for help. (EE) Please also check the log file at "/var/log/Xorg.0.og" for additional information.(EE) VGA Arbitra
    xinit: giving up
    xinit: unable to connect to X server: Cannot assign requested address
    xinit: server error
    ------
    xinit failed. /usr/bin/Xorg is not setuid, maybe that's the reason?
    If so either use a display manager (strongly recommended) or adjust /etc/permissions.local and run "chkstat ---system --set" afterward
    It's making me wonder if the "hard way" Nvidia driver would have worked and there's something else wrong, as the Radeon should have "just" worked?

    Any things to try?

    Thanks.

  4. #14
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,871

    Default AW: Failed to Boot to Graphics

    Once more :
    The 340 driver is only supported by Leap 15.2 if you patch it before:
    https://forums.opensuse.org/showthre...er-not-working

    But it does not work on Leap 15.3 anymore, so maybe its better to use the nouveau driver.

    Also:
    please use Code-Tags:
    https://forums.opensuse.org/showthre...und-Your-Paste

  5. #15

    Default Re: Failed to Boot to Graphics

    Thank you Sauerland for continuing to help me!

    So, from what you've said, if I want to continue with the GT240 into the future, my best bet is with the nouveau driver, as even if I patch 340.x today, it's a short-term solution that may not work into 15.3?

    -----

    I've finally had success!

    I had put this in /etc/X11/xorg.conf.d/90-my_nvidia_hacks.conf:

    Code:
    Section "Device"
        Identifier "Device0"
        Driver "nvidia"
        VendorName "NVIDIA Corporation"
        BoardName "GeForce GT 240"
        Option "UseHotplugEvents" "false"
    EndSection
    to prevent my dual monitor configuration from switching to one screen when I switch the second monitor to another computer. (This is annoying to me as the desktop squishes and all the contents spread over two screens is put on one screen. I prefer the wide desktop to be there when I switch back from the other computer.)

    I removed the file and I have graphics mode! All good... except switching the second monitor to the other computer is back to paying attention of hotplug events. How do I tell the system to not use hotplug events with the radeon, like with nvidia?

    Thanks!

  6. #16

    Default Re: Failed to Boot to Graphics

    I found my old thread on switching off UseHotplugEvents...

    Settings->Configure Desktop->Startup and Shutdown->Background Services->Startup Services->KScreen 2 toggle to OFF

    It affects all graphics cards, not just targeting a specific card, like what I was doing before.

  7. #17

    Default Re: Failed to Boot to Graphics

    I had one final thing that wasn't working... GL for 3D, and it turns out, Zoom and KDE apps, like apps in the System Settings, crashed without GL working.

    The solution was force installing xorg-x11-server again and accepting the dependency redirects to new sources.

  8. #18
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,906
    Blog Entries
    1

    Default Re: Failed to Boot to Graphics

    FWIW, these are the NVidia cards I have in current use for Leap and Tumbleweed, all running competently on the FOSS default DIX driver, modesetting:
    1. NVIDIA C61 [GeForce 6150SE nForce 430]
    2. NVIDIA G84 [GeForce 8600 GT]
    3. NVIDIA G98 [GeForce 8400 GS Rev. 2]
    4. NVIDIA GF108 [GeForce GT 630]
    5. NVIDIA GF119 [NVS 310]
    6. NVIDIA GT218 [GeForce 210]

    Only the C61 is never used with dual displays. Usually the GT218 isn't either.

    A list of AMD and Intel APUs/GPUs/IGPs I have running for Leap and Tumbleweed on the modesetting DIX would be considerably longer. The modesetting is newer technology than the DDXes, enabling most physical devices however branded to utilize just the one driver for X.

    Both the nouveau DDX and the modesetting DIX require use of the nouveau kernel driver for KMS. KMS is disabled when nomodeset or nouveau.modeset=0 appear on the kernel command line.

    NVidia's drivers cause the single biggest exception to the absence of need for /etc/X11/xorg.conf and /etc/X11/xorg.conf.d/*conf files directed to X graphics. When removing an NVidia proprietary driver, these files virtually always must be removed to enable competent FOSS X driver operation.

    For reliable, trouble-free online distribution upgrading, removing NVidia's proprietary drivers first is a must.

    Only once in my life have I installed an NVidia proprietary driver. It was much too long ago to remember much more than it wasn't on a PC I owned.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.2, +TW, 15.1, 15.0 & 13.1 on Haswell
    Secondary: eComStation (OS/2) &15.1 on i965P w/ Radeon
    Tertiary: Mageia,Fedora,Debian,more on Kaby Lake,iQ45,iQ43,iG41,iG3X,i965G,AMD,NVidia&&&&&

  9. #19

    Default Re: Failed to Boot to Graphics

    Quote Originally Posted by mrmazda View Post
    FWIW, these are the NVidia cards I have in current use for Leap and Tumbleweed, all running competently on the FOSS default DIX driver, modesetting:
    1. NVIDIA C61 [GeForce 6150SE nForce 430]
    2. NVIDIA G84 [GeForce 8600 GT]
    3. NVIDIA G98 [GeForce 8400 GS Rev. 2]
    4. NVIDIA GF108 [GeForce GT 630]
    5. NVIDIA GF119 [NVS 310]
    6. NVIDIA GT218 [GeForce 210]

    Only the C61 is never used with dual displays. Usually the GT218 isn't either.

    A list of AMD and Intel APUs/GPUs/IGPs I have running for Leap and Tumbleweed on the modesetting DIX would be considerably longer. The modesetting is newer technology than the DDXes, enabling most physical devices however branded to utilize just the one driver for X.

    Both the nouveau DDX and the modesetting DIX require use of the nouveau kernel driver for KMS. KMS is disabled when nomodeset or nouveau.modeset=0 appear on the kernel command line.

    NVidia's drivers cause the single biggest exception to the absence of need for /etc/X11/xorg.conf and /etc/X11/xorg.conf.d/*conf files directed to X graphics. When removing an NVidia proprietary driver, these files virtually always must be removed to enable competent FOSS X driver operation.

    For reliable, trouble-free online distribution upgrading, removing NVidia's proprietary drivers first is a must.

    Only once in my life have I installed an NVidia proprietary driver. It was much too long ago to remember much more than it wasn't on a PC I owned.
    Would there be any issue with using FOSS X drivers when an application requests that proprietary drivers be installed? As that's what the software package has been tested against? The software package I have in mind is Side Effect's Houdini. Would FOSS X support all the 3D demands?

  10. #20
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,906
    Blog Entries
    1

    Default Re: Failed to Boot to Graphics

    Quote Originally Posted by linuxvinh View Post
    Would there be any issue with using FOSS X drivers when an application requests that proprietary drivers be installed? As that's what the software package has been tested against?
    Such a request could be a tradition based on a history of inadequate support from the reverse-engineered Nouveau DDX. The Modesetting DIX is newer technology, one X driver supporting any GPU supported by any manufacturer-specific kernel driver that provides KMS.

    The software package I have in mind is Side Effect's Houdini. Would FOSS X support all the 3D demands?
    I have no basis on which to suggest a definitive answer. I can only surmise that if that software works with FOSS drivers on AMD and/or Intel GPUs, then FOSS drivers for NVidia GPUs should be good enough as well. There are no proprietary drivers for Intel's IGPs. Intel is a major contributor to the Modesetting DIX. Likewise, AMD itself is a contributor ensuring FOSS AMD drivers are fully competent for the majority of use cases.

    Assuming NVidia's drivers have not already been installed, I can't imagine any significant pain from trying FOSS if it turns out it isn't good enough for your software choice. If it doesn't, simply follow the instructions for installing NVidia's own proprietaryware. OTOH, trouble removing NVidia's drivers is a common topic on forums and mailing lists. If they are already installed and working satisfactorily, maintain the status quo..
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.2, +TW, 15.1, 15.0 & 13.1 on Haswell
    Secondary: eComStation (OS/2) &15.1 on i965P w/ Radeon
    Tertiary: Mageia,Fedora,Debian,more on Kaby Lake,iQ45,iQ43,iG41,iG3X,i965G,AMD,NVidia&&&&&

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •