Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Intermittent wifi connectivity problem

  1. #1

    Default Intermittent wifi connectivity problem

    Every now and then, I'd estimate once every 10 boots or so, my laptop will be unable to establish a wifi connection to the router. I'm using KDE plasma. The NM applet will just sit forever on "connecting" but will fail to establish a connection. There are no errors in the logs, just messages about trying to negotiate a connection. If I manually unload and reload the kernel modules for the wifi driver, then restart the network service, it will connect. So, there is some sort of problem with loading the modules that only occurs intermittently. Anyone have some troubleshooting advice to help narrow this down? Restarting network, or networkmanager alone, does not fix the problem. The modules must be reloaded. Thanks.

  2. #2

    Default Re: Intermittent wifi connectivity problem

    Please specify your hardware.

  3. #3

    Default Re: Intermittent wifi connectivity problem

    Quote Originally Posted by Svyatko View Post
    Please specify your hardware.

    Code:
    70: None 00.0: 1070a WLAN 
      [Created at net.126] 
      Unique ID: AYEt.QXn1l67RSa1 
      Parent ID: y9sn.D6QMyC7dbb5 
      SysFS ID: /class/net/wlan0 
      SysFS Device Link: /devices/pci0000:00/0000:00:1c.6/0000:6d:00.0 
      Hardware Class: network interface 
      Model: "WLAN network interface" 
      Driver: "ath10k_pci" 
      Driver Modules: "ath10k_pci" 
      Device File: wlan0 
      HW Address: (removed) 
      Permanent HW Address: (removed) 
      Link detected: yes 
      Config Status: cfg=no, avail=yes, need=no, active=unknown 
      Attached to: #30 (WLAN controller)
    

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,107
    Blog Entries
    1

    Default Re: Intermittent wifi connectivity problem

    Quote Originally Posted by z2 View Post
    Code:
    70: None 00.0: 1070a WLAN 
      [Created at net.126] 
      Unique ID: AYEt.QXn1l67RSa1 
      Parent ID: y9sn.D6QMyC7dbb5 
      SysFS ID: /class/net/wlan0 
      SysFS Device Link: /devices/pci0000:00/0000:00:1c.6/0000:6d:00.0 
      Hardware Class: network interface 
      Model: "WLAN network interface" 
      Driver: "ath10k_pci" 
      Driver Modules: "ath10k_pci" 
      Device File: wlan0 
      HW Address: (removed) 
      Permanent HW Address: (removed) 
      Link detected: yes 
      Config Status: cfg=no, avail=yes, need=no, active=unknown 
      Attached to: #30 (WLAN controller)
    
    Some devices using that driver are notorious for wifi instability. Can you share the chipset details please?
    Code:
    /sbin/lspci -nnk | grep -iA3 net
    Any interesting kernel messages?
    Code:
    dmesg | grep ath
    openSUSE Leap 15.2; KDE Plasma 5

  5. #5

    Default Re: Intermittent wifi connectivity problem

    chipset:
    Code:
    6d:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32) 
            Subsystem: Dell Device [1028:0310] 
            Kernel driver in use: ath10k_pci 
            Kernel modules: ath10k_pci
    
    I will reboot a few times and see if I can get the issue to present itself again and post the kernel messages here afterward.

  6. #6

    Default Re: Intermittent wifi connectivity problem

    Alright, I rebooted 4 or 5 times and the wifi connection failed to load. This was a bit different than it just being stuck on the negotiation stage, but still a failure:

    dmesg:
    Code:
    [    7.141043] ath10k_pci 0000:6d:00.0: enabling device (0000 -> 0002)
    [    7.141694] ath10k_pci 0000:6d:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
    [    7.415355] ath10k_pci 0000:6d:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 1028:0310
    [    7.415357] ath10k_pci 0000:6d:00.0: kconfig debug 0 debugfs 0 tracing 0 dfs 0 testmode 0
    [    7.415735] ath10k_pci 0000:6d:00.0: firmware ver WLAN.RM.4.4.1-00157-QCARMSWPZ-1 api 6 features wowlan,ignore-otp,mfp crc32 90eebefb
    [    7.490017] ath10k_pci 0000:6d:00.0: board_file api 2 bmi_id N/A crc32 318825bf
    [   12.565363] ath10k_pci 0000:6d:00.0: wmi service ready event not received
    [   12.654204] ath10k_pci 0000:6d:00.0: could not init core (-110)
    [   12.654242] ath10k_pci 0000:6d:00.0: could not probe fw (-110)

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,121

    Default AW: Intermittent wifi connectivity problem

    Plese post:
    Code:
    zypper se -si firmware

  8. #8

    Default Re: Intermittent wifi connectivity problem

    Installed firmware:

    Code:
    i+ | kernel-firmware | package | 20210208-35.1 | noarch | kernel_stable
    
    from the kernel-stable repo. Currently running kernel
    Code:
    5.10.16-1.g11381f3-default
    
    I switched to the newest kernel to see if it would resolve the problem. Both this, and another issue with the bios. Same results with this and the leap kernel.

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,121

    Default AW: Intermittent wifi connectivity problem

    You can try the oldest firmware from the OSS Repo.

    Do you restart your Router?

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,107
    Blog Entries
    1

    Default Re: Intermittent wifi connectivity problem

    Quote Originally Posted by z2 View Post
    Alright, I rebooted 4 or 5 times and the wifi connection failed to load. This was a bit different than it just being stuck on the negotiation stage, but still a failure:

    dmesg:
    Code:
    [    7.141043] ath10k_pci 0000:6d:00.0: enabling device (0000 -> 0002)
    [    7.141694] ath10k_pci 0000:6d:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
    [    7.415355] ath10k_pci 0000:6d:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 1028:0310
    [    7.415357] ath10k_pci 0000:6d:00.0: kconfig debug 0 debugfs 0 tracing 0 dfs 0 testmode 0
    [    7.415735] ath10k_pci 0000:6d:00.0: firmware ver WLAN.RM.4.4.1-00157-QCARMSWPZ-1 api 6 features wowlan,ignore-otp,mfp crc32 90eebefb
    [    7.490017] ath10k_pci 0000:6d:00.0: board_file api 2 bmi_id N/A crc32 318825bf
    [   12.565363] ath10k_pci 0000:6d:00.0: wmi service ready event not received
    [   12.654204] ath10k_pci 0000:6d:00.0: could not init core (-110)
    [   12.654242] ath10k_pci 0000:6d:00.0: could not probe fw (-110)
    As suspected it does look like a firmware issue. Further investigation needed.
    openSUSE Leap 15.2; KDE Plasma 5

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •