Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Dependency problem

  1. #1

    Default Dependency problem

    I tried upgrading my system today, but there is a dependency issue.

    Repositories I have enabled now: system, packman, repo-debug, repo-non-oss, repo-oss and repo-update.

    (I did install some multimedia codecs when the install was brand new, and then removed the repositories.)

    Any advice?

    Code:
    Warning: You are in the process of upgrading the distribution with all active package wells. Make sure they are all compatible before proceeding. Run "man zypper" for more information about this command. Calculates distribution upgrade… 12 problems: Problem: problem with the installed package libavcodec58_91-4.3.2-4.3.x86_64 Problem: problem with the installed package libavdevice58_10-4.3.2-4.3.x86_64 Problem: problem with the installed package libavfilter7_85-4.3.2-4.3.x86_64 Problem: problem with the installed package libavformat58_45-4.3.2-4.3.x86_64 Problem: problem with the installed package libavutil56_51-4.3.2-4.3.x86_64 Problem: problem with the installed package libpostproc55_7-4.3.2-4.3.x86_64 Problem: problem with the installed package libswresample3_7-4.3.2-4.3.x86_64 Problem: problem with the installed package libswscale5_7-4.3.2-4.3.x86_64 Problem: libavfilter7_85-4.3.2-4.3.x86_64 requires libavresample4_0 = 4.3.2-4.3, but this required file does not exist Problem: libavfilter7_85-4.3.2-1.1.x86_64 requires libavresample.so.4.0 () (64bit), but this required file does not exist Problem: libavfilter7_110-4.4-4.1.x86_64 requires libavresample.so.4.0 () (64bit), but this required file does not exist Problem: libavfilter7_110-4.4-4.1.x86_64 requires libavresample.so.4.0 () (64bit), but this required file does not exist  Problem: problem with the installed package libavcodec58_91-4.3.2-4.3.x86_64  Solution 1: Install libavcodec58_91-4.3.2-1.1.x86_64 (with manufacturer change)   http://packman.links2linux.de -> openSUSE  Solution 2: Keep the obsolete package libavcodec58_91-4.3.2-4.3.x86_64  Well from the solutions above with numbers, or skip, repeat or cancel [1/2 / s / r / c / d /?] (C):

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    28,428

    Default Re: Dependency problem

    Quote Originally Posted by Kaare View Post
    I tried upgrading my system today, but there is a dependency issue.

    Repositories I have enabled now: system, packman, repo-debug, repo-non-oss, repo-oss and repo-update.

    (I did install some multimedia codecs when the install was brand new, and then removed the repositories.)

    Any advice?

    Code:
    Warning: You are in the process of upgrading the distribution with all active package wells. Make sure they are all compatible before proceeding. Run "man zypper" for more information about this command. Calculates distribution upgrade… 12 problems: Problem: problem with the installed package libavcodec58_91-4.3.2-4.3.x86_64 Problem: problem with the installed package libavdevice58_10-4.3.2-4.3.x86_64 Problem: problem with the installed package libavfilter7_85-4.3.2-4.3.x86_64 Problem: problem with the installed package libavformat58_45-4.3.2-4.3.x86_64 Problem: problem with the installed package libavutil56_51-4.3.2-4.3.x86_64 Problem: problem with the installed package libpostproc55_7-4.3.2-4.3.x86_64 Problem: problem with the installed package libswresample3_7-4.3.2-4.3.x86_64 Problem: problem with the installed package libswscale5_7-4.3.2-4.3.x86_64 Problem: libavfilter7_85-4.3.2-4.3.x86_64 requires libavresample4_0 = 4.3.2-4.3, but this required file does not exist Problem: libavfilter7_85-4.3.2-1.1.x86_64 requires libavresample.so.4.0 () (64bit), but this required file does not exist Problem: libavfilter7_110-4.4-4.1.x86_64 requires libavresample.so.4.0 () (64bit), but this required file does not exist Problem: libavfilter7_110-4.4-4.1.x86_64 requires libavresample.so.4.0 () (64bit), but this required file does not exist  Problem: problem with the installed package libavcodec58_91-4.3.2-4.3.x86_64  Solution 1: Install libavcodec58_91-4.3.2-1.1.x86_64 (with manufacturer change)   http://packman.links2linux.de -> openSUSE  Solution 2: Keep the obsolete package libavcodec58_91-4.3.2-4.3.x86_64  Well from the solutions above with numbers, or skip, repeat or cancel [1/2 / s / r / c / d /?] (C):
    You mean you installed (codecs) packages from other repos then OSS and Packman and then disabled them? Looks like the root cause here.
    Henk van Velden

  3. #3
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    2,114

    Default Re: Dependency problem

    Today's update of ffmpeg-4-4.4-4.1 on Packman and related packages caused a bit of a mess.
    I accepted option 1, ending up with both libavcodec58_134 (from Packman) and libavcodec58_91 (from openSUSE OSS), and similarly for related packages.
    Everything seems to work well, at least so far.
    Hopefully the situation will be cleaned up with the next few snapshots...
    See also https://forums.opensuse.org/showthre...se-is-obsolete
    Tumbleweed Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.3

  4. #4

    Default Re: Dependency problem

    Quote Originally Posted by Kaare View Post
    I tried upgrading my system today, but there is a dependency issue.

    Repositories I have enabled now: system, packman, repo-debug, repo-non-oss, repo-oss and repo-update.

    (I did install some multimedia codecs when the install was brand new, and then removed the repositories.)

    Any advice?

    Code:
    Warning: You are in the process of upgrading the distribution with all active package wells. Make sure they are all compatible before proceeding. Run "man zypper" for more information about this command. Calculates distribution upgrade… 12 problems: Problem: problem with the installed package libavcodec58_91-4.3.2-4.3.x86_64 Problem: problem with the installed package libavdevice58_10-4.3.2-4.3.x86_64 Problem: problem with the installed package libavfilter7_85-4.3.2-4.3.x86_64 Problem: problem with the installed package libavformat58_45-4.3.2-4.3.x86_64 Problem: problem with the installed package libavutil56_51-4.3.2-4.3.x86_64 Problem: problem with the installed package libpostproc55_7-4.3.2-4.3.x86_64 Problem: problem with the installed package libswresample3_7-4.3.2-4.3.x86_64 Problem: problem with the installed package libswscale5_7-4.3.2-4.3.x86_64 Problem: libavfilter7_85-4.3.2-4.3.x86_64 requires libavresample4_0 = 4.3.2-4.3, but this required file does not exist Problem: libavfilter7_85-4.3.2-1.1.x86_64 requires libavresample.so.4.0 () (64bit), but this required file does not exist Problem: libavfilter7_110-4.4-4.1.x86_64 requires libavresample.so.4.0 () (64bit), but this required file does not exist Problem: libavfilter7_110-4.4-4.1.x86_64 requires libavresample.so.4.0 () (64bit), but this required file does not exist  Problem: problem with the installed package libavcodec58_91-4.3.2-4.3.x86_64  Solution 1: Install libavcodec58_91-4.3.2-1.1.x86_64 (with manufacturer change)   http://packman.links2linux.de -> openSUSE  Solution 2: Keep the obsolete package libavcodec58_91-4.3.2-4.3.x86_64  Well from the solutions above with numbers, or skip, repeat or cancel [1/2 / s / r / c / d /?] (C):
    @et al:

    Have this same issue this morning in TW . . . ran a zypper, shows "534 packages to upgrade" and then "11 questions to answer on choice of dependencies" . . . looks like the same questions given to the OP of this thread.

    I then tried to run it through package updater and it errored out . . . showing the 11 dependency issues--seems like a lot of questions . . . .

  5. #5
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    2,493
    Blog Entries
    1

    Default Re: Dependency problem

    Quote Originally Posted by Kaare View Post
    I tried upgrading my system today, but there is a dependency issue.

    Repositories I have enabled now: system, packman, repo-debug, repo-non-oss, repo-oss and repo-update.

    (I did install some multimedia codecs when the install was brand new, and then removed the repositories.)

    Any advice?
    You may run ' zypper dup --no-allow-vendor-change' and select option 'keep obsolete ...'. This will update sucessfully packages in the main repositories and postpone update of those depending on packman.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  6. #6

    Default Re: Dependency problem

    Thanks a lot. I selected hold obsolete, and was able to install some 250 packages. When the installation finished, I still had the same dependency issue as below. Having searched some more, I stumbled across an official statement slandering the FSF as racist and sexist, and therefore discontinuing sponsorship.

    https://news.opensuse.org/2021/04/12...pensuse-board/

    I am appalled by this political attack on the FSF, and one can only wonder if there is some hidden agenda behind this divisive attack on the free software movement.

    Either way, I am voting with my feet and getting out of here for good. Nothing personal to you guys in the thread. Thanks again.

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,686

    Default AW: Dependency problem

    Problem is know by Packman.

    Having searched some more, I stumbled across an official statement slandering the FSF as racist and sexist, and therefore discontinuing sponsorship.

    https://news.opensuse.org/2021/04/12...pensuse-board/
    I am appalled by this political attack on the FSF, and one can only wonder if there is some hidden agenda behind this divisive attack on the free software movement.

    Either way, I am voting with my feet and getting out of here for good. Nothing personal to you guys in the thread. Thanks again.
    Does not belong to this thread, so please open a new one in subforum:
    https://forums.opensuse.org/forumdis...r-Than-Support
    or
    https://forums.opensuse.org/forumdis...munity-amp-Fun

  8. #8

    Default Re: Dependency problem

    Quote Originally Posted by karlmistelberger View Post
    You may run ' zypper dup --no-allow-vendor-change' and select option 'keep obsolete ...'. This will update sucessfully packages in the main repositories and postpone update of those depending on packman.
    @karlmistelberger, et al:

    I am still here . . . ran the "no-allow-vendor-change" flag and it seemed like the 534 packages went through, except for the 11 packages with dependency issues. The test kept getting more complex as it went on, the answers weren't always #2 . . . took a lot of concentration, focused concentration to complete the . . . I guess 11 questions is more like a "quiz" ?????

    My other question is, what does it take to get the focused attention of a global moderator??? I've had a few posts on the ubuntu forums flagged by the "minor observers" apparently because I used "sarcasm" . . . which I guess they figured could damage the psyche's of small dogs and children . . . had to argue my case in the "jail section" to get my "out of jail card after promising to never never use sarcasm . . . on the forum."

    So far here on the forum I haven't had any those kind of issues, but still, it would lighten my day if something of what I posted required **global moderation** . . . help me out guys, what's the technique???? Openly complain about having to deal with dependency issues for every upgrade in a rolling distro??? Why, why is that happening to us??

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,686

    Default AW: Dependency problem

    Let us help here to get problems solved without any personal "sarcasm" or asking how to save the world.
    Therefore are the subforums I mentioned above.

    Back to the problem
    This was today on the Packman mailinglist:

    It looks like there needs to be an A_Tumbleweed_ffmpeg-4 package.
    Since last week there has been a lot of activity in
    multimedia:libs/ffmpeg-4 and this has resulted in
    "zypper dup --no-allow-vendor-change" conflicts. The only way to avoid
    being forced to change vendor of ffmpeg-4 libs to openSUSE is to keep
    "obsolete package" which vlc and friends are built against, this
    wouldn't happen if the package was linked to Factory. Of course when
    ffmpeg-4 is finally accepted this problem will go away after all the
    affected packages rebuild.

  10. #10

    Default Re: AW: Dependency problem

    Quote Originally Posted by Sauerland View Post
    Let us help here to get problems solved without any personal "sarcasm" or asking how to save the world.
    Therefore are the subforums I mentioned above.

    Back to the problem
    This was today on the Packman mailinglist:
    @Sauerland:

    Indeed it does seem like sarcasm is underappreciated around the world of linux forums . . . and I would agree it is entirely a fruitless task to try to "save the world." I tried to delete the "humorous" aspects out of my post to streamline the flow of traffic, but it was after the 10 minutes . . . .

    But, my point about running into "dependency issues" with increasing frequency in OpenSUSE/TW is valid, and this is relatively "new" problem, IMHO based on a few years of playing around with SUSE flavors. Previously to let's say the last 6 months, running a zypper was relatively uncomplicated affair and didn't require a "quiz" the get the job done, etc.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •