Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: With kernel 5.3.18-lp152.72.1 kernel-syms requires kernel-preempt and kernel-preempt-devel

  1. #1

    Default With kernel 5.3.18-lp152.72.1 kernel-syms requires kernel-preempt and kernel-preempt-devel

    Before kernel 5.3.18-lp152.72.1, i.e. with 69 or 66, I had kernel-syms being istalled, without kernel-preempt kernel.
    I don't want to install kernel-preempt.

    This is a bug or a feature?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,084
    Blog Entries
    3

    Default Re: With kernel 5.3.18-lp152.72.1 kernel-syms requires kernel-preempt and kernel-preempt-devel

    Report as a bug, and see what response you get.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  3. #3

    Default Re: With kernel 5.3.18-lp152.72.1 kernel-syms requires kernel-preempt and kernel-preempt-devel

    Quote Originally Posted by nrickert View Post
    Report as a bug, and see what response you get.
    That is an excellent advice, because we are many that would like to get an explanation for this phenomenon of the kernel-preempt suddenly appearing and taking over the system.
    It first began a few months ago when virtualbox went to 6.14 and erroneously provoked the installation of that unwanted kernel.
    After that, we had to remove the kernel but what could not be removed because dkms needed it was the smaller kernel-preempt-devel - and as you know, without dkms you cannot have virtualbox running.

    A few months of peace followed ... until today, when a number of users suddenly saw that full kernel-preempt reappearing and taking over their systems again.
    Same with me today with the update. Suddenly kernel-preempt got installed, where until now only kernel-preempt-devel was there, required by dkms to make virtualbox run.
    I did sometimes try to do away with that kernel-preempt-devel, but yast warned me not to do that because dkms needed it.
    And now today, suddenly, the whole kernel-preempt reappeared and took over my system. Just for a few minutes, because I immediately took action.
    What I did is: UNINSTALL virtualbox-kmp-preempt AND kernel-preempt AND kernel-syms AND kernel-preempt-devel ; for the latter two, an older version remains installed.
    Trying to actualize kernel-syms does not work because in that case, yast wants me to reinstall the unwanted kernel-preempt ...
    I have no idea why this kernel-preempt resurfaced just today.

  4. #4
    Join Date
    Sep 2012
    Posts
    6,384

    Default Re: With kernel 5.3.18-lp152.72.1 kernel-syms requires kernel-preempt and kernel-preempt-devel

    Quote Originally Posted by PolderPenguin View Post
    I have no idea why this kernel-preempt resurfaced just today.
    https://forums.opensuse.org/showthre...11#post3022911

  5. #5
    Join Date
    Dec 2016
    Location
    Burlington - Canada
    Posts
    34

    Default Re: With kernel 5.3.18-lp152.72.1 kernel-syms requires kernel-preempt and kernel-preempt-devel

    I am running Leap 15.2 and I don't have VirtualBox installed.
    Code:
    Kernel: 5.3.18-lp152.69-default x86_64
    Distro: openSUSE Leap 15.2
    After doing
    Code:
    sudo zypper up
    I get this:
    Code:
    Loading repository data...
    Reading installed packages...
    
    The following package update will NOT be installed:
      gstreamer-plugins-bad-lang
    
    The following 7 NEW packages are going to be installed:
      kernel-default-5.3.18-lp152.72.1 kernel-default-devel-5.3.18-lp152.72.1 kernel-devel-5.3.18-lp152.72.1 kernel-preempt kernel-preempt-devel-5.3.18-lp152.72.1 kernel-source-5.3.18-lp152.72.1 kernel-syms-5.3.18-lp152.72.1
    
    The following 7 packages are going to be upgraded:
      kernel-macros libnuma1 numactl steam steam-devices tcsh tcsh-lang
    
    The following 2 packages require a system reboot:
      kernel-default-5.3.18-lp152.72.1 kernel-preempt
    
    7 packages to upgrade, 7 new.
    Overall download size: 299.4 MiB. Already cached: 0 B. After the operation, additional 1.6 GiB will be used.
    
        Note: System reboot required.
    Continue? [y/n/v/...? shows all options] (y): v
    I chose v to view all the options:
    Code:
    The following package update will NOT be installed:
      gstreamer-plugins-bad-lang  1.16.2-pm152.4.1
    
    The following 7 NEW packages are going to be installed:
      kernel-default        5.3.18-lp152.72.1
      kernel-default-devel  5.3.18-lp152.72.1
      kernel-devel          5.3.18-lp152.72.1
      kernel-preempt        5.3.18-lp152.72.1
      kernel-preempt-devel  5.3.18-lp152.72.1
      kernel-source         5.3.18-lp152.72.1
      kernel-syms           5.3.18-lp152.72.1
    
    The following 7 packages are going to be upgraded:
      kernel-macros  5.3.18-lp152.69.1 -> 5.3.18-lp152.72.1
      libnuma1       2.0.11-lp152.4.6 -> 2.0.14-lp152.5.3.1
      numactl        2.0.11-lp152.4.6 -> 2.0.14-lp152.5.3.1
      steam          1.0.0.69-lp152.2.18.1 -> 1.0.0.70-lp152.2.21.1
      steam-devices  1.0.0.69-lp152.2.18.1 -> 1.0.0.70-lp152.2.21.1
      tcsh           6.20.00-lp152.7.1 -> 6.20.00-lp152.8.3.1
      tcsh-lang      6.20.00-lp152.7.1 -> 6.20.00-lp152.8.3.1
    
    The following 2 packages require a system reboot:
      kernel-default  5.3.18-lp152.72.1
      kernel-preempt  5.3.18-lp152.72.1
    
    7 packages to upgrade, 7 new.
    Overall download size: 299.4 MiB. Already cached: 0 B. After the operation, additional 1.6 GiB will be used.
    
        Note: System reboot required.
    Continue? [y/n/v/...? shows all options] (y): n
    Code:
    sudo zypper lr -u
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    #  | Alias                       | Name                               | Enabled | GPG Check | Refresh | URI
    ---+-----------------------------+------------------------------------+---------+-----------+---------+---------------------------------------------------------------------------------------------
     1 | Packman Repository          | Packman Repository                 | Yes     | (r ) Yes  | Yes     | https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.2/
     2 | SoftMaker_Office_Repository | SoftMaker Office Repository        | Yes     | (r ) Yes  | Yes     | https://shop.softmaker.com/repo/rpm
     3 | openSUSE-Leap-15.2-1        | openSUSE-Leap-15.2-1               | No      | ----      | ----    | hd:/?device=/dev/disk/by-id/usb-Kingston_DataTraveler_3.0_60A44C413A8CB02119870117-0:0-part2
     4 | repo-debug                  | Debug Repository                   | No      | ----      | ----    | http://download.opensuse.org/debug/distribution/leap/15.2/repo/oss/
     5 | repo-debug-non-oss          | Debug Repository (Non-OSS)         | No      | ----      | ----    | http://download.opensuse.org/debug/distribution/leap/15.2/repo/non-oss/
     6 | repo-debug-update           | Update Repository (Debug)          | No      | ----      | ----    | http://download.opensuse.org/debug/update/leap/15.2/oss/
     7 | repo-debug-update-non-oss   | Update Repository (Debug, Non-OSS) | No      | ----      | ----    | http://download.opensuse.org/debug/update/leap/15.2/non-oss/
     8 | repo-non-oss                | Non-OSS Repository                 | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/distribution/leap/15.2/repo/non-oss/
     9 | repo-oss                    | Main Repository                    | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/distribution/leap/15.2/repo/oss/
    10 | repo-source                 | Source Repository                  | No      | ----      | ----    | http://download.opensuse.org/source/distribution/leap/15.2/repo/oss/
    11 | repo-source-non-oss         | Source Repository (Non-OSS)        | No      | ----      | ----    | http://download.opensuse.org/source/distribution/leap/15.2/repo/non-oss/
    12 | repo-update                 | Main Update Repository             | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/15.2/oss
    13 | repo-update-non-oss         | Update Repository (Non-Oss)        | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/15.2/non-oss/
    14 | snappy                      | snappy                             | Yes     | (r ) Yes  | Yes     | https://download.opensuse.org/repositories/system:/snappy/openSUSE_Leap_15.2
    How can I not let preempt to be installed? What should I do?

    Thank you in advance.

  6. #6
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    294

    Default Re: With kernel 5.3.18-lp152.72.1 kernel-syms requires kernel-preempt and kernel-preempt-devel

    Quote Originally Posted by simorgh View Post
    I am running Leap 15.2 and I don't have VirtualBox installed.
    Code:
    The following package update will NOT be installed:
      gstreamer-plugins-bad-lang  1.16.2-pm152.4.1
    
    The following 7 NEW packages are going to be installed:
      kernel-default        5.3.18-lp152.72.1
      kernel-default-devel  5.3.18-lp152.72.1
      kernel-devel          5.3.18-lp152.72.1
      kernel-preempt        5.3.18-lp152.72.1
      kernel-preempt-devel  5.3.18-lp152.72.1
      kernel-source         5.3.18-lp152.72.1
      kernel-syms           5.3.18-lp152.72.1
    How can I not let preempt to be installed? What should I do?
    Well, since kernel-syms is the OP's issue, you may choose to wait for the result of the bug report - if you need it. Or delete it, if you don't need it.

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,694

    Default AW: With kernel 5.3.18-lp152.72.1 kernel-syms requires kernel-preempt and kernel-preempt-devel

    kernel-syms needs kernel-default-devel and kernel-preempt-devel (and more).

    After Update to kernel version 5.3.18-lp152.72:
    kernel-default-devel needs kernel-default (and more).

    kernel-preempt-devel needs kernel-preempt (and more).

    So deleting all kernel-syms and all kernel-preempt(-devel) packages should be enough for the moment.
    Last edited by Sauerland; 20-Apr-2021 at 14:24.

  8. #8
    Join Date
    Dec 2016
    Location
    Burlington - Canada
    Posts
    34

    Default Re: With kernel 5.3.18-lp152.72.1 kernel-syms requires kernel-preempt and kernel-preempt-devel

    This is so confusing. Is this preempt thing something that causes problem? Why does it have to be so difficult.

  9. #9
    Join Date
    Dec 2016
    Location
    Burlington - Canada
    Posts
    34

    Default Re: AW: With kernel 5.3.18-lp152.72.1 kernel-syms requires kernel-preempt and kernel-preempt-devel

    Quote Originally Posted by Sauerland View Post
    kernel-syms needs kernel-default-devel and kernel-preempt-devel (and more).

    After Update to kernel version 5.3.18-lp152.72:
    kernel-default-devel needs kernel-default (and more).

    kernel-preempt-devel needs kernel-preempt (and more).

    So deleting all kernel-syms and all kernel-preempt(-devel) packages should be enough for the moment.
    Does anybody know why there are there to start with? Have I installed something that ended up installing kernel-syms and/or kernel-preempt(-devel) packages?
    Under the description for kernel-syms it says:
    kernel-sysms - Kernel Symbol Versions (modversions)
    Kernel symbols, such as functions and variables, have version information attached to them. This package contains the symbol versions for the standard kernels.
    This package is needed for compiling kernel module packages with proper package dependencies.
    Would deleting kernel-syms break anything?

  10. #10
    Join Date
    Dec 2016
    Location
    Burlington - Canada
    Posts
    34

    Default Re: With kernel 5.3.18-lp152.72.1 kernel-syms requires kernel-preempt and kernel-preempt-devel

    I ended up deleting kernel-syms and kernel-preempt-devel and then did a zypper up
    After the update, I rebooted the system.
    Now I get this:
    Code:
    uname -a
    Linux SimorghSUSE 5.3.18-lp152.69-default #1 SMP Tue Apr 6 11:41:13 UTC 2021 (d532e33) x86_64 x86_64 x86_64 GNU/Linux
    It did not update to 72-default? Even though it said it did before I rebooted.
    Any ideas?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •