Results 1 to 3 of 3

Thread: Anyway to use a newer cmake for appimages?

  1. #1

    Default Anyway to use a newer cmake for appimages?

    The game I'm trying to package requires cmake >= 3.13, the appimage repo on OBS provides 3.10.2. Is there a way to use a newer version of cmake?

    https://build.opensuse.org/package/l...ppImage/x86_64

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,875

    Default AW: Anyway to use a newer cmake for appimages?

    devel:tools:building has cmake 3.20, but that does not build for every distribution:
    https://build.opensuse.org/package/s...building/cmake

    openSUSE:factory has 3.19:
    https://build.opensuse.org/package/s...:Factory/cmake

    And so on......

    You must only branch it to your OBS project.

    PS:
    The underlying build system for this appimage is a openSUSE Leap 42.3.......
    Last edited by Sauerland; 27-Apr-2021 at 01:44.

  3. #3

    Default Re: Anyway to use a newer cmake for appimages?

    Thanks, I found a cmake that fit my needs (science:dlr/CMake), but due to other problems- I ended up switching the repo to "OBS:AppImage/AppImage.leap_15.2"

    builds fine & runs in my Ubunhtu 20.04 VM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •