Results 1 to 6 of 6

Thread: locale bzw. charmap

  1. #1

    Default locale bzw. charmap

    Ich habe ein Problem mit meinem locale. Das Problem besteht seit Langem (Jahre), aber ich möchte es endlich lösen. Es macht mir in der console und auch in anderen Anwendungen immer wieder Probleme. Ich habe in den letzten Jahren immer wieder Foren durchsucht, um dieses Problem zu lösen, und Vieles ausprobiert, aber bisher immer erfolglos.

    Resultat aus `locale`:
    Code:
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Kann LC_ALL nicht auf die Standard-Lokale einstellen: Datei oder Verzeichnis nicht gefunden
    LANG=de_CH.UTF-8
    LC_CTYPE=de_DE.UTF-8,LANG=de_DE.UTF-8
    LC_NUMERIC="de_CH.UTF-8"
    LC_TIME="de_CH.UTF-8"
    LC_COLLATE="de_CH.UTF-8"
    LC_MONETARY="de_CH.UTF-8"
    LC_MESSAGES="de_CH.UTF-8"
    LC_PAPER="de_CH.UTF-8"
    LC_NAME="de_CH.UTF-8"
    LC_ADDRESS="de_CH.UTF-8"
    LC_TELEPHONE="de_CH.UTF-8"
    LC_MEASUREMENT="de_CH.UTF-8"
    LC_IDENTIFICATION="de_CH.UTF-8"
    LC_ALL=
    In Yast habe ich als Primäre Sprache Deutsch ausgewählt, wenn ich in 'Details' als 'Detaillierte Locale-Einstellung' de_CH mit UTF-8 auswähle, kommt die Meldung: ' Sprache 'de_CH' wurde in der Liste der im Verzeichnis
    /usr/share/YaST2/data/languages verfügbaren unterstützten Sprachen nicht gefunden.'. In der Tat ist dort keine Datei language_de_CH.ycp vorhanden. Andere haben das so gelöst, dass sie die de_DE-Datei kopiert haben. Das löst das Problem aber nicht wirklich, deswegen ist in Yast jetzt de_DE.UTF-8 eingestellt.
    Da ich letzthin oft die Konsole verwende, ist ein anderes Problem mindestens ebenso gravierend: meine Shell (tcsh) lässt keine Umlaute zu. Sobald ich 'su' mache (sh) werden Umlaute aber problemlos angezeigt. Das gilt aber auch, wenn ich die sh verwende.
    Wenn ich 'locale -c charmap' eingebe, erscheint aber in jedem Fall (sowohl tcsh als auch sh):
    Code:
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Kann LC_ALL nicht auf die Standard-Lokale einstellen: Datei oder Verzeichnis nicht gefunden
    LC_CTYPE
    ANSI_X3.4-1968
    Ich bin also nicht ganz sicher, ob das ganze Problem aus den charmap-Einstellungen entsteht oder locale (oder ob es dasselbe Problem ist). k3b ist ebenfalls der Meinung: "System locale charset is ANSI_X3.4-1968".


    Ich bin ratlos, wo ich mit der Fehlersuche weiterfahren könnte. Ich verstehe nur schon nicht, warum LC_* (ausser LC_CTYPE) weiterhin de_CH.UTF-8 anzeigen, obwohl ich in Yast (zwangsläufig) de_DE habe. Ich finde auch nicht, wo die charmap eingestellt werden kann.

  2. #2

    Default AW: locale bzw. charmap

    Lösung+Notizen von SLED15SP2:

    - Finger weg von "# yast2 language"! => YAST2 unterstützt kein de_CH.UTF-8!

    - Danach händische Konfiguration mit:

    # localectl set-locale LANG=de_CH.UTF-8
    # more /etc/locale.conf
    LANG=de_CH.UTF-8

    # zypper addlocale de_CH
    # zypper addlocale de_DE
    # zypper locales
    de
    de_CH
    de_DE
    en

    # zypper locales -p
    => Alle erforderlichen RPM's installiert?

    Code:
    # locale 
    LANG=de_CH.UTF-8 
    LC_CTYPE="de_CH.UTF-8" 
    LC_NUMERIC=de_CH.UTF-8 
    LC_TIME=de_CH.UTF-8 
    LC_COLLATE="de_CH.UTF-8" 
    LC_MONETARY=de_CH.UTF-8 
    LC_MESSAGES="de_CH.UTF-8" 
    LC_PAPER=de_CH.UTF-8 
    LC_NAME="de_CH.UTF-8" 
    LC_ADDRESS="de_CH.UTF-8" 
    LC_TELEPHONE="de_CH.UTF-8" 
    LC_MEASUREMENT=de_CH.UTF-8 
    LC_IDENTIFICATION="de_CH.UTF-8" 
    LC_ALL=
    Code:
    # locale -c charmap 
    LC_CTYPE 
    UTF-8
    Code:
    # localectl status 
       System Locale: LANG=de_CH.UTF-8 
           VC Keymap: sg-latin1 
          X11 Layout: ch 
           X11 Model: pc105 
         X11 Variant: de_nodeadkeys 
         X11 Options: terminate:ctrl_alt_bksp
    Code:
    # localectl list-locales |grep -i de_CH 
    de_CH 
    de_CH.utf8
    Code:
    # localectl list-keymaps |grep -i sg-latin1 
    sg-latin1 
    sg-latin1-lk450
    Code:
    # more /etc/vconsole.conf  
    KEYMAP=sg-latin1 
    FONT=eurlatgr.psfu 
    FONT_MAP= 
    FONT_UNIMAP=

    RPM-Pakete kbd, kbd-legacy und libX11-data installiert?

  3. #3

  4. #4
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    2,686
    Blog Entries
    1

    Default Re: locale bzw. charmap

    Quote Originally Posted by aurelio View Post
    Ich habe ein Problem mit meinem locale. Das Problem besteht seit Langem (Jahre), aber ich möchte es endlich lösen. Es macht mir in der console und auch in anderen Anwendungen immer wieder Probleme. Ich habe in den letzten Jahren immer wieder Foren durchsucht, um dieses Problem zu lösen, und Vieles ausprobiert, aber bisher immer erfolglos.

    Resultat aus `locale`:
    Code:
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Kann LC_ALL nicht auf die Standard-Lokale einstellen: Datei oder Verzeichnis nicht gefunden
    LANG=de_CH.UTF-8
    LC_CTYPE=de_DE.UTF-8,LANG=de_DE.UTF-8
    LC_NUMERIC="de_CH.UTF-8"
    LC_TIME="de_CH.UTF-8"
    LC_COLLATE="de_CH.UTF-8"
    LC_MONETARY="de_CH.UTF-8"
    LC_MESSAGES="de_CH.UTF-8"
    LC_PAPER="de_CH.UTF-8"
    LC_NAME="de_CH.UTF-8"
    LC_ADDRESS="de_CH.UTF-8"
    LC_TELEPHONE="de_CH.UTF-8"
    LC_MEASUREMENT="de_CH.UTF-8"
    LC_IDENTIFICATION="de_CH.UTF-8"
    LC_ALL=
    In Yast habe ich als Primäre Sprache Deutsch ausgewählt, wenn ich in 'Details' als 'Detaillierte Locale-Einstellung' de_CH mit UTF-8 auswähle, kommt die Meldung: ' Sprache 'de_CH' wurde in der Liste der im Verzeichnis
    /usr/share/YaST2/data/languages verfügbaren unterstützten Sprachen nicht gefunden.'. In der Tat ist dort keine Datei language_de_CH.ycp vorhanden. Andere haben das so gelöst, dass sie die de_DE-Datei kopiert haben. Das löst das Problem aber nicht wirklich, deswegen ist in Yast jetzt de_DE.UTF-8 eingestellt.
    Da ich letzthin oft die Konsole verwende, ist ein anderes Problem mindestens ebenso gravierend: meine Shell (tcsh) lässt keine Umlaute zu. Sobald ich 'su' mache (sh) werden Umlaute aber problemlos angezeigt. Das gilt aber auch, wenn ich die sh verwende.
    Wenn ich 'locale -c charmap' eingebe, erscheint aber in jedem Fall (sowohl tcsh als auch sh):
    Code:
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Kann LC_ALL nicht auf die Standard-Lokale einstellen: Datei oder Verzeichnis nicht gefunden
    LC_CTYPE
    ANSI_X3.4-1968
    Ich bin also nicht ganz sicher, ob das ganze Problem aus den charmap-Einstellungen entsteht oder locale (oder ob es dasselbe Problem ist). k3b ist ebenfalls der Meinung: "System locale charset is ANSI_X3.4-1968".


    Ich bin ratlos, wo ich mit der Fehlersuche weiterfahren könnte. Ich verstehe nur schon nicht, warum LC_* (ausser LC_CTYPE) weiterhin de_CH.UTF-8 anzeigen, obwohl ich in Yast (zwangsläufig) de_DE habe. Ich finde auch nicht, wo die charmap eingestellt werden kann.
    Probleme mit locale habe ich schon einmal gehabt. Das Problem mit LANG=de_CH.UTF-8 ist bei mir noch nie aufgetreten. Es sind ja alle wesentlichen locales vorhanden:

    Code:
    3400G:~ # locale -a|grep CH 
    de_CH
    de_CH.utf8 
    fr_CH
    fr_CH.utf8 
    it_CH
    it_CH.utf8 
    wae_CH
    3400G:~ #
    Was zu tun ist um die Standardeinstellung zu ändern steht in der Datei .profile:

    Code:
    karl@3400G:~> cat /home/karl/.profile
    # Sample .profile for SuSE Linux
    # rewritten by Christian Steinruecken <cstein@suse.de>
    #
    # This file is read each time a login shell is started.
    # All other interactive shells will only read .bashrc; this is particularly
    # important for language settings, see below.
    
    test -z "$PROFILEREAD" && . /etc/profile || true
    
    # Most applications support several languages for their output.
    # To make use of this feature, simply uncomment one of the lines below or
    # add your own one (see /usr/share/locale/locale.alias for more codes)
    # This overwrites the system default set in /etc/sysconfig/language
    # in the variable RC_LANG.
    #
    #export LANG=de_DE.UTF-8        # uncomment this line for German output
    #export LANG=fr_FR.UTF-8        # uncomment this line for French output
    #export LANG=es_ES.UTF-8        # uncomment this line for Spanish output
    export LANG=de_CH.UTF-8        # Schwyzerdütsch
    # Some people don't like fortune. If you uncomment the following lines,
    # you will have a fortune each time you log in ;-)
    
    #if [ -x /usr/bin/fortune ] ; then
    #    echo
    #    /usr/bin/fortune
    #    echo
    #fi
    karl@3400G:~>
    Vielleicht funktioniert diese Lösung auch in der Schweiz.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  5. #5

    Default AW: locale bzw. charmap

    Wahrscheinlich fehlt ein RPM-Paket oder die Paketinstallationen sind fehlerhaft. Gemäss:
    https://forums.opensuse.org/showthre...09#post3022209
    kontrollieren.

    Zum Testen der Zeichendarstellung:
    https://fedoraproject.org/wiki/Chang...ultConsoleFont

    http://git.altlinux.org/people/legio...EADME.eurlatgr

  6. #6

    Default [SOLVED] Re: AW: locale bzw. charmap de_CH.UTF-8

    Vielen Dank für diese ausführliche Anleitung! Sie hat perfekt funktioniert, in ein paar Minuten konnte ich damit das Problem lösen, das mich so lange beschäftigte.
    Ich hatte mich zu stark auf "yast2 language" abgestützt und alles drum herum probiert, stattdessen war es selbst Teil des Problems.

    Quote Originally Posted by GrandDixence2 View Post
    Lösung+Notizen von SLED15SP2:

    - Finger weg von "# yast2 language"! => YAST2 unterstützt kein de_CH.UTF-8!
    [...]

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •