Results 1 to 7 of 7

Thread: Athlon TM+radeon9600 Firefox not working on KDE tested multi versions and GNOME not loading

  1. #1

    Default Athlon TM+radeon9600 Firefox not working on KDE tested multi versions and GNOME not loading

    Hello,
    I am trying to give breath to my old system.
    It is an Athlon TM in an asrock board with radeon9600 video card, 1G mem and 300G disk.

    I installed tumbleweed latest build (updated yesterday), which works well with KDE and was trying to run some browser to be connected to internet.
    Konqueror is working in some pages but breaking in many so I was trying to use a more advanced browser like firefox.
    I know about incompatibility of this rig with SSE2 browsers so I installed all bellow versions of firefox (i686 versions).

    firefox-24.8.1esr.tar.bz2 firefox-45.9.0esr.tar.bz2 firefox-52.0esr.tar.bz2
    firefox-38.8.0esr.tar.bz2 firefox-48.0b9.tar.bz2 firefox-52.9.0esr.tar.bz2

    None of those worked (some start and crashed, other crashed immediately) on KDE.
    Gnome on the other end, could not start Xserver environment properly. Stays stuck somewhere so I cannot test.

    Any hint on what to do?

    Thanks,
    Jorge

  2. #2
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    288

    Default Re: Athlon TM+radeon9600 Firefox not working on KDE tested multi versions and GNOME not loading

    Hi Jorge,

    Welcome to openSUSE and this board. I'm afraid 1G may not be enough to run such applications. If I get it right 1G seems to be mentioned as minimum requirement - but that should be the absolute minimum. 1.5G is required when using online repositories, 2G is recommended.
    https://en.opensuse.org/Hardware_requirements
    Just for comparison, I am currently using 1,69G with just KDE Plasma, ksysguard and firefox running:
    Code:
    pluto:~ # inxi -m 
    Memory:    RAM:total: 7.65 GiB used: 1.69 GiB (22.1%)  
               Array-1:capacity: 32 GiB slots: 2 EC: None  
               Device-1: ChannelA-DIMM0 size: 4 GiB speed: 2400 MT/s  
               Device-2: ChannelB-DIMM0 size: 4 GiB speed: 2400 MT/s
    
    Firefox alone is using 200M. I don't know if switching to some lightweight DE might help. More RAM would be better.

    Edit: Have a lot of fun! Whatsoever!

  3. #3
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,801
    Blog Entries
    1

    Default Re: Athlon TM+radeon9600 Firefox not working on KDE tested multi versions and GNOME not loading

    I gave up trying to run TW on any 32 bit Athlon or Sempron in 2019. I don't remember requirement of SSE2 exclusively to Firefox. I was thinking something(s) in basesystem also requires it. I have multiple 32 bit Pentium 4 PCs running it, one with Radeon 9000, others with Radeon 7500.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.2, +TW, 15.1, 15.0 & 13.1 on Haswell
    Secondary: eComStation (OS/2) &15.1 on i965P w/ Radeon
    Tertiary: Mageia,Fedora,Debian,more on Kaby Lake,iQ45,iQ43,iG41,iG3X,i965G,AMD,NVidia&&&&&

  4. #4

    Default Re: Athlon TM+radeon9600 Firefox not working on KDE tested multi versions and GNOME not loading

    Thank you both. 1G mem module arriving from aliexpress, will try that first. What would be the recommended version of Suse for these 32bit processors if I need to go down from TW? I opted for TW as I found it was supporting i686.

  5. #5
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,801
    Blog Entries
    1

    Default Re: Athlon TM+radeon9600 Firefox not working on KDE tested multi versions and GNOME not loading

    Quote Originally Posted by jorgemef View Post
    What would be the recommended version of Suse for these 32bit processors if I need to go down from TW? I opted for TW as I found it was supporting i686.
    My Athlons are using only Debian any more.

    IMO, https://en.opensuse.org/Hardware_requirements needs to be updated to say "qualified i686 support", as in processors than include SSE2 support. I'm not sure whether need for SSE2 was ever officially announced.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.2, +TW, 15.1, 15.0 & 13.1 on Haswell
    Secondary: eComStation (OS/2) &15.1 on i965P w/ Radeon
    Tertiary: Mageia,Fedora,Debian,more on Kaby Lake,iQ45,iQ43,iG41,iG3X,i965G,AMD,NVidia&&&&&

  6. #6

    Default Re: Athlon TM+radeon9600 Firefox not working on KDE tested multi versions and GNOME not loading

    Quote Originally Posted by mrmazda View Post
    IMO, https://en.opensuse.org/Hardware_requirements needs to be updated to say "qualified i686 support", as in processors than include SSE2 support. I'm not sure whether need for SSE2 was ever officially announced.
    Not officially: https://bugzilla.opensuse.org/show_bug.cgi?id=1102737
    I.e. i686 + SSE2. Pentium IV is famous for adding SSE2. AMD64 supports SSE2 by standard.

    To OP: https://en.wikipedia.org/wiki/Lightw...x_distribution
    Using Firefox and other browsers without SSE2: you need special builds for it.
    Forget about 32-bit, use 64-bit. Athlon 64 X2 + mobo + 4 GiB RAM costs ~$30 on a secondhand market.

  7. #7

    Lightbulb Re: Athlon TM+radeon9600 Firefox not working on KDE tested multi versions and GNOME not loading

    Bug filed: https://bugzilla.opensuse.org/show_bug.cgi?id=1185309
    Vote for it to get it solved.

    Quote Originally Posted by jorgemef View Post
    Thank you both. 1G mem module arriving from aliexpress, will try that first. What would be the recommended version of Suse for these 32bit processors if I need to go down from TW? I opted for TW as I found it was supporting i686.
    For openSUSE only TW supports i686 (SSE2 is needed).
    Leap requires x86-64 (AMD64). You will need a lot of recompiling work to get working system without SSE2 support in CPU. You may use Windows XP.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •