Results 1 to 5 of 5

Thread: intel_iommu=on fails after kernel upgrade?

  1. #1

    Post intel_iommu=on fails after kernel upgrade?

    Hi,

    I think I've stumbled on a possible bug.

    When booting with the kernel option "intel_iommu=on" then it works fine with kernel 5.3.18-lp152.66-default
    but fails with 5.3.18-lp152.69-default (se below)

    Removing the option is also a work around....

    Any hints?

    Code:
    [    1.290627] CR2: 0000000000000000 CR3: 000000037760a001 CR4: 00000000001606f0 
    [    1.298627] Call Trace: 
    [    1.298627]  intel_iommu_domain_alloc+0x4b/0xf0 
    [    1.298627]  request_default_domain_for_dev+0xbd/0x170 
    [    1.298627]  intel_iommu_add_device+0x107/0x180 
    [    1.298627]  iommu_probe_device+0x48/0xd0 
    [    1.306627]  ? iommu_probe_device+0xd0/0xd0 
    [    1.306627]  ? iommu_probe_device+0xd0/0xd0 
    [    1.306627]  add_iommu_group+0xa/0x20 
    [    1.306627]  bus_for_each_dev+0x76/0xc0 
    [    1.314627]  bus_set_iommu+0x85/0xc0 
    [    1.314627]  intel_iommu_init+0x507/0x7a1 
    [    1.314627]  ? e820__memblock_setup+0x60/0x60 
    [    1.314627]  ? set_debug_rodata+0x11/0x11 
    [    1.314627]  pci_iommu_init+0x16/0x3f 
    [    1.322627]  do_one_initcall+0x46/0x1f4 
    [    1.322627]  kernel_init_freeable+0x1ba/0x25f 
    [    1.322627]  ? rest_init+0xb0/0xb0 
    [    1.322627]  kernel_init+0xa/0x110 
    [    1.322627]  ret_from_fork+0x35/0x40 
    [    1.330627] Modules linked in: 
    [    1.333307] ---[ end trace 82bbf418f925c7f7 ]--- 
    [    1.335275] RIP: 0010:domain_update_iotlb+0x98/0xa0 
    [    1.337325] Code: 92 c0 48 85 c9 40 0f 95 c6 40 20 f0 74 06 80 79 44 00 78 b9 48 8b 42 10 49 39 c0 48 8d 50 f0 75 ca 31 c0 88 87 04 03 00 00 c3 <0f> 0b 66 0f 1f 44 00 00 0f 1f 44 00 00 8b 05 95 b3 e1 01 53 48 89 
    [    1.344544] RSP: 0000:ffffb4644001bd00 EFLAGS: 00010246 
    [    1.346697] RAX: 0000000000000000 RBX: 0000000000000003 RCX: 0000000000000000 
    [    1.349498] RDX: 0000000000000000 RSI: ffff8f1a47c69100 RDI: ffff8f1d356f0b00 
    [    1.352274] RBP: ffff8f1d356f0b00 R08: 0000080000000000 R09: 0000000000000000 
    [    1.355260] R10: ffffb4644001bab8 R11: 0000000002de9e49 R12: 0000000000000003 
    [    1.358067] R13: ffff8f1d37d6fa58 R14: ffffffffbbedcc60 R15: 0000000000000000 
    [    1.360798] FS:  0000000000000000(0000) GS:ffff8f1d3a800000(0000) knlGS:0000000000000000 
    [    1.364120] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033 
    [    1.366416] CR2: 0000000000000000 CR3: 000000037760a001 CR4: 00000000001606f0 
    [    1.369291] Kernel panic - not syncing: Attempted to kill init! exitcode=0x0000000b 
    [    1.372557] Rebooting in 90 seconds..

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,065
    Blog Entries
    15

    Default Re: intel_iommu=on fails after kernel upgrade?

    Hi
    So what are all your boot options?

    Code:
    cat /etc/default/grub | grep GRUB_CMDLINE_LINUX_DEFAULT
    It would need a bug report: openSUSE:Submitting bug reports - openSUSE
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    494

    Default Re: intel_iommu=on fails after kernel upgrade?

    Howard
    ThinkPads 310ED, 600E, T23, X41, X60, T61, X201, E550, X390

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,065
    Blog Entries
    15

    Default Re: intel_iommu=on fails after kernel upgrade?

    Hi
    I suspect an update will be available soon by the looks
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: intel_iommu=on fails after kernel upgrade?

    Quote Originally Posted by malcolmlewis View Post
    Hi
    I suspect an update will be available soon by the looks
    Yes, latest kernel (kernel-default-5.3.18-lp152.72.1.x86_64) solved the problem.
    So I guess we can close this thread

    Thanks for all help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •