Results 1 to 2 of 2

Thread: Keyboard not working after update 2021-04-12

  1. #1

    Default Keyboard not working after update 2021-04-12

    Using Tumbleweed, and performed the standard update when prompted...actually ran 'sudo zypper dup' from CLI, and update
    went fine.

    ...until I noticed that my keyboard wasn't working in some instances. Specifically, ANYTHING KDE related. GTK apps worked, xterm worked (but Konsole didn't), etc. Reboots, logout/in, power cycle....nothing. Looked around, and found a specific issue for Arch where this was mentioned, and tried the fix listed there:
    Code:
    ibus-daemon -d -n --desktop=KDE

    Which brought my keyboard back into a working state for KDE. Ideas?


  2. #2

    Default Re: Keyboard not working after update 2021-04-12

    Quote Originally Posted by PaulCee View Post
    Using Tumbleweed, and performed the standard update when prompted...actually ran 'sudo zypper dup' from CLI, and update
    went fine.

    ...until I noticed that my keyboard wasn't working in some instances. Specifically, ANYTHING KDE related. GTK apps worked, xterm worked (but Konsole didn't), etc. Reboots, logout/in, power cycle....nothing. Looked around, and found a specific issue for Arch where this was mentioned, and tried the fix listed there:
    Code:
    ibus-daemon -d -n --desktop=KDE
    Which brought my keyboard back into a working state for KDE. Ideas?
    Update: it appears as if the ibus-daemon isn't starting at all upon reboot.

    I can get to an xterm (thankfully, the Excalibur launcher works keyboard-wise at boot), and just run "ibus-daemon -n", and things work. I don't see ANYTHING in journalctl or any errors that would indicate why ibus isn't auto-starting. My

    Code:
    [Desktop Entry]
    Name=IBus
    GenericName=IBus Daemon
    Comment=Start IBus daemon
    Exec=ibus-autostart
    Icon=ibus-setup
    Terminal=false
    Type=Application
    StartupNotify=false
    NoDisplay=true
    X-GNOME-Autostart-Phase=Applications
    X-GNOME-AutoRestart=false
    X-GNOME-Autostart-Notify=false
    X-KDE-autostart-after=panel
    X-KDE-StartupNotify=false
    ...which hasn't changed since March 26, same date as my ibus-autostart in /usr/bin:
    Code:
    #!/bin/sh
    
    
    test x"$INPUT_METHOD" = x"ibus" || exit 0
    
    
    # GNOME starts ibus by itself
    case "$WINDOWMANAGER" in
        *gnome*)
            exit 0;;
    esac
    
    
    # sleep for a little while to avoid duplicate startup
    # sleep 2
    
    
    ibus-daemon --xim -d
    exit 0
    Still stumped.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •