Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: New kernel will not boot.

  1. #21
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,695

    Default AW: New kernel will not boot.

    Does it works with:
    Code:
    intel_iommu=off
    See the bugreport:
    https://bugzilla.opensuse.org/show_bug.cgi?id=1184575

  2. #22

    Default Re: New kernel will not boot.

    Quote Originally Posted by nrickert View Post
    Okay. So you are using traditional MBR booting.

    The most likely problem, is that the partition where the grub bootloader code went, is not where your BIOS is currently looking for booting your system. You can perhaps use

    Yast --> System --> Boot loader

    to change that. But you might also have to look at BIOS settings.
    I appreciate your help. I just found the most likely cause of my problem. I bought a 4 Tib usb drive yesterday to install 15.2. I've come to find out that the bios on my system does not support that hardware. It can only support a 2 Tib drive. Anyhow I was successful in upgrading to 15,2 from 15.1 on another 2 Tib drive I have. I did try changing my bios settings to use UEFI. And changed the boot drive to EFI. Still didn't work. I did notice that my efi boot partition was at the back of the disk so I tried to reinstall with custom partitions which put the boot partition at the front but that didn't work either I guess the bios on my laptop will not support a 4 Tib disk. Thanks for responding.

  3. #23
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    296

    Default Re: New kernel will not boot.

    Just so everybody is aware, there are two bugs out there that produce very similar behavior as reported in this thread:

    Bug 1184575
    Bug 1184585

    If adding the boot option "intel_iomm=off" fixes the failure to boot problem then your problem is bug 1184585. Otherwise, the problem is most probably bug 1184575.

    My laptop booted successfully after adding the boot option "intel_iomm=off". So, my problem is bug 1184585.

    FYI,

    Gordon
    Laptop #1: OpenSUSE Leap 15.2 (x86_64) | HP ZBook Fury 17 G7 (17")
    Laptop #2: OpenSUSE Leap 15.2 (x86_64) | System76 Darter (14")

  4. #24

    Default Re: New kernel will not boot.

    Quote Originally Posted by cartrite View Post
    I appreciate your help. I just found the most likely cause of my problem. I bought a 4 Tib usb drive yesterday to install 15.2. I've come to find out that the bios on my system does not support that hardware. It can only support a 2 Tib drive. Anyhow I was successful in upgrading to 15,2 from 15.1 on another 2 Tib drive I have. I did try changing my bios settings to use UEFI. And changed the boot drive to EFI. Still didn't work. I did notice that my efi boot partition was at the back of the disk so I tried to reinstall with custom partitions which put the boot partition at the front but that didn't work either I guess the bios on my laptop will not support a 4 Tib disk. Thanks for responding.
    Disk controller is in due, not BIOS.
    Use GPT for big disks.

  5. #25

    Post Re: New kernel will not boot.

    Quote Originally Posted by gldickens3 View Post
    Just so everybody is aware, there are two bugs out there that produce very similar behavior as reported in this thread:

    Bug 1184575
    Bug 1184585

    If adding the boot option "intel_iomm=off" fixes the failure to boot problem then your problem is bug 1184585. Otherwise, the problem is most probably bug 1184575.

    My laptop booted successfully after adding the boot option "intel_iomm=off". So, my problem is bug 1184585.

    FYI,

    Gordon
    If adding the boot option “dis_ucode_ldr” works, then add it permanently in Yast - bootloader options; your bug is 1179284.

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •