Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Need Update for gscan2pdf from 2.8.1 to 2.8.2

  1. #1

    Default Need Update for gscan2pdf from 2.8.1 to 2.8.2

    Reason is, that one can't save scans as .pdf with the current 2.8.1 version -- this is a known issue, resolved in 2.8.2. Where would I ask the maintainers of tumbleweed to update gscan2pdf? Thanks for any directions :-).

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,682

    Default AW: Need Update for gscan2pdf from 2.8.1 to 2.8.2

    Get the one from Publishing Repo:
    https://build.opensuse.org/package/s...hing/gscan2pdf

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,068
    Blog Entries
    15

    Default Re: AW: Need Update for gscan2pdf from 2.8.1 to 2.8.2

    Quote Originally Posted by Sauerland View Post
    Hi
    Hold off, I have SR's pending then will push the 2.11.n version to Tumbleweed, it should be fine to use it now as was waiting for perl-PDF-Builder to arrive in Tumbleweed.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4

    Default Re: Need Update for gscan2pdf from 2.8.1 to 2.8.2

    Thanks to both of you. I'll hold off then but how long will that be? What are SRs? I have a little leeway but in a few weeks I need to submit invoices as scanned pdfs, so a hint about the schedule would be nice.

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,068
    Blog Entries
    15

    Default Re: Need Update for gscan2pdf from 2.8.1 to 2.8.2

    Quote Originally Posted by wodenhof View Post
    Thanks to both of you. I'll hold off then but how long will that be? What are SRs? I have a little leeway but in a few weeks I need to submit invoices as scanned pdfs, so a hint about the schedule would be nice.
    Hi
    Submit Requests: https://build.opensuse.org/request/show/882461

    Grab the 2.11.0 version, when the 2.11.2 update hits Tumbleweed you will need to switch from graphics to Tumbleweed.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: Need Update for gscan2pdf from 2.8.1 to 2.8.2

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Submit Requests: https://build.opensuse.org/request/show/882461

    Grab the 2.11.0 version, when the 2.11.2 update hits Tumbleweed you will need to switch from graphics to Tumbleweed.
    Sorry, I don't understand what you mean "switch from graphics to Tumbleweed". I'm already using tumbleweed?!?

    I was a little in a hurry so I followed Sauerland's suggestion. I clicked on 1-click install and now gscan2pdf doesn't start at all. I tried it from a console and got
    Code:
    Can't locate Locale/Language.pm in @INC (you may need to install the Locale::Language module) (@INC contains: /usr/lib/perl5/site_perl/5.32.1/x86_64-l
    inux-thread-multi /usr/lib/perl5/site_perl/5.32.1 /usr/lib/perl5/vendor_perl/5.32.1/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.32.1 /usr/l
    ib/perl5/5.32.1/x86_64-linux-thread-multi /usr/lib/perl5/5.32.1 /usr/lib/perl5/vendor_perl/5.32.0/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl
    /5.32.0 /usr/lib/perl5/site_perl) at /usr/lib/perl5/vendor_perl/5.32.1/Gscan2pdf/Tesseract.pm line 14. 
    BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.32.1/Gscan2pdf/Tesseract.pm line 14. 
    Compilation failed in require at /usr/lib/perl5/vendor_perl/5.32.1/Gscan2pdf/Document.pm line 14. 
    BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.32.1/Gscan2pdf/Document.pm line 14. 
    Compilation failed in require at /usr/lib/perl5/vendor_perl/5.32.1/Gscan2pdf/Dialog/Renumber.pm line 7. 
    BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.32.1/Gscan2pdf/Dialog/Renumber.pm line 7. 
    Compilation failed in require at /usr/bin/gscan2pdf line 62. 
    BEGIN failed--compilation aborted at /usr/bin/gscan2pdf line 62.
    
    I googled for this not really userfriendly error and found that this means some perl modules are missing. Thus I ran "sudo zypper in perl-Locale*" which installed 11 packages:
    Code:
    Die folgenden 11 NEUEN Pakete werden installiert:
      perl-AppConfig perl-Data-Section-Simple perl-Lingua-EN-Sentence perl-Locale-Maketext-Gettext perl-Locale-Maketext-Lexicon perl-Locale-Msgfmt 
      perl-Locale-US perl-PPI perl-Task-Weaken perl-Template-Toolkit perl-YAML
    


    gscan2pdf still throws the same error. What did I
    miss?

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,068
    Blog Entries
    15

    Default Re: Need Update for gscan2pdf from 2.8.1 to 2.8.2

    Hi
    If you use the version from the Graphics Tumbleweed repo, it switches vendor (graphics), when the newer release is accepted into Tumbleweed you will need to switch vendor again graphics -> openSUSE.

    Not sure as I never used (or submitted 2.11.0) I have 2.11.2 installed here.

    Grab this version (this is the current submitted package):

    Code:
    zypper in https://download.opensuse.org/repositories/home:/malcolmlewis:/branches:/Publishing/openSUSE_Tumbleweed/noarch/gscan2pdf-2.11.2-23.1.noarch.rpm
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8

    Default Re: Need Update for gscan2pdf from 2.8.1 to 2.8.2

    Quote Originally Posted by malcolmlewis View Post
    Hi
    If you use the version from the Graphics Tumbleweed repo, it switches vendor (graphics), when the newer release is accepted into Tumbleweed you will need to switch vendor again graphics -> openSUSE.

    Not sure as I never used (or submitted 2.11.0) I have 2.11.2 installed here.

    Grab this version (this is the current submitted package):

    Code:
    zypper in https://download.opensuse.org/repositories/home:/malcolmlewis:/branches:/Publishing/openSUSE_Tumbleweed/noarch/gscan2pdf-2.11.2-23.1.noarch.rpm
    The one-click-install had several popups warning that four (I think?) new repositories would be added permanently. That hasn't happened, there are only the repositories I had up to now.

    I then installed from your source -- same error as before...

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,068
    Blog Entries
    15

    Default Re: Need Update for gscan2pdf from 2.8.1 to 2.8.2

    Hi
    Is perl-Encode-Locale installed?

    No issues here;

    Miniatures attachées Miniatures attachées Click image for larger version. 

Name:	Screenshot from 2021-04-08 11-49-50.png 
Views:	40 
Size:	43.9 KB 
ID:	1007  
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #10

    Default Re: Need Update for gscan2pdf from 2.8.1 to 2.8.2

    Yes, "perl-Encode-Locale-1.05-1.15.noarch" is installed.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •