Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 44

Thread: Unable to boot after setting up 2 monitors

  1. #31

    Default Re: Unable to boot after setting up 2 monitors

    Hi,

    I tried the below:
    1)
    Code:
    sudo journalctl -b | susepaste

    https://susepaste.org/53247430

    2) The timestamps for the Xorg files
    Code:
    by79@linux-3ztp:/> ls -l ~/.local/share/xorg/
    total 156
    -rw-r--r-- 1 by79 users 25455 Oct 14  2020 Xorg.0.log
    -rw-r--r-- 1 by79 users 27592 Oct 13  2020 Xorg.0.log.old
    -rw-r--r-- 1 by79 users 55793 Apr 17 14:35 Xorg.1.log
    -rw-r--r-- 1 by79 users 44149 Apr 12 21:45 Xorg.1.log.old
    3) The xsession-errors-:0 under root is even older..
    Code:
    -rw------- 1 root root 100391 Oct 30  2018 .xsession-errors-:0

    4) Nvidia drivers?
    Code:
    linux-3ztp:~ # zypper se -s -i nvidia
    Loading repository data...
    Reading installed packages...
    
    S  | Name                      | Type    | Version                            | Arch   | Repository
    ---+---------------------------+---------+------------------------------------+--------+------------------
    i+ | nvidia-computeG04         | package | 390.141-lp152.8.1                  | x86_64 | (System Packages)
    i+ | nvidia-gfxG04-kmp-default | package | 390.141_k5.3.18_lp152.19-lp152.8.1 | x86_64 | (System Packages)
    i+ | nvidia-glG04              | package | 390.141-lp152.8.1                  | x86_64 | (System Packages)
    i+ | x11-video-nvidiaG04       | package | 390.141-lp152.8.1                  | x86_64 | (System Packages)
    
    
    For an extended search including not yet activated remote resources you may run 'zypper
    search-packages' at any time.
    Do you want to run 'zypper search-packages' now? [yes/no/always/never] (no): y
    
    Could not parse the options: ambiguous option: -s
    Could not search for the package: SUSE::Connect::UnsupportedOperation: Package search is not supported by the registration proxy: Alternatively, use the web version at https://scc.suse.com/packages/
    Could not search for the package: SUSE::Connect::UnsupportedOperation: Package search is not supported by the registration proxy: Alternatively, use the web version at https://scc.suse.com/packages/
    Could not search for the package: SUSE::Connect::UnsupportedOperation: Package search is not supported by the registration proxy: Alternatively, use the web version at https://scc.suse.com/packages/
    No package found
    Right now, I have two screens working...to the best of what you can see, can I shut down and restart and expect to see 2 screens? Is there anything that needs to be checked? Responsibility is mine....just hoping to minimize the chances of losing the GUI ...

    Thanks!

  2. #32
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,696

    Default AW: Re: Unable to boot after setting up 2 monitors

    Quote Originally Posted by mrmazda View Post
    Again I boobooed. 'zypper se -si nvidia' should have been 'zypper se -s -i nvidia'.

    The output did include what I was looking for. It told me that besides using Gnome, you're using NVidia's drivers. I never use either Gnome or NVidia's drivers, so my ability to help in this thread is very limited. Dual displays in 15.2 on NVidia GPUs is no problem for me without them. I'm perfectly content with the (default) modesetting DIX driver provided by the server rpm package.

    All that said, I was thinking current NVidia driver version to be well past 390 for a 1050. If I'm right, it should be a simple matter of replacing 390 with the most current version to fix this.

    BTW, based on post #4 it looks like you used startx somewhere along the way, which would be why Xorg.1.log and Xorg.1.log.old appeared. It's best not to try to use startx when any DM is or is trying to run. It complicates troubleshooting.
    zypper se -si is the same as zypper se -s -i so its equal.......

  3. #33
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,696

    Default AW: Unable to boot after setting up 2 monitors

    Please post:
    Code:
    zypper se -si | grep -Ei 'systemp|system_p|system-p|system p'
    and
    Code:
    ls -al /etc | grep -i suse
    Last edited by Sauerland; 17-Apr-2021 at 01:48.

  4. #34

    Default Re: Unable to boot after setting up 2 monitors

    Hi,

    Code:
     zypper se -si | grep -Ei 'systemp|system_p|system-p|system p'
    i+ | R-KernSmooth                                 | package | 2.23.17-lp152.141.1                       | x86_64 | (System Packages)
    i+ | R-MASS                                       | package | 7.3.51.6-lp152.141.1                      | x86_64 | (System Packages)
    i+ | R-Matrix                                     | package | 1.2.18-lp152.141.1                        | x86_64 | (System Packages)
    i+ | R-Matrix-devel                               | package | 1.2.18-lp152.141.1                        | x86_64 | (System Packages)
    i+ | R-RCurl                                      | package | 1.95_4.11-lp152.6.9                       | x86_64 | (System Packages)
    i+ | R-base                                       | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-base-devel                                 | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-bitops                                     | package | 1.0_6-lp152.7.6                           | x86_64 | (System Packages)
    i+ | R-boot                                       | package | 1.3.25-lp152.141.1                        | x86_64 | (System Packages)
    i+ | R-class                                      | package | 7.3.17-lp152.141.1                        | x86_64 | (System Packages)
    i+ | R-cluster                                    | package | 2.1.0-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-codetools                                  | package | 0.2.16-lp152.141.1                        | x86_64 | (System Packages)
    i+ | R-compiler                                   | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-core                                       | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-core-devel                                 | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-core-doc                                   | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-core-libs                                  | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-core-packages                              | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-datasets                                   | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-foreign                                    | package | 0.8.80-lp152.141.1                        | x86_64 | (System Packages)
    i+ | R-grDevices                                  | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-graphics                                   | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-grid                                       | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-jsonlite                                   | package | 1.6.1-lp152.1.5                           | x86_64 | (System Packages)
    i+ | R-lattice                                    | package | 0.20.41-lp152.141.1                       | x86_64 | (System Packages)
    i+ | R-methods                                    | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-mgcv                                       | package | 1.8.31-lp152.141.1                        | x86_64 | (System Packages)
    i+ | R-nlme                                       | package | 3.1.148-lp152.141.1                       | x86_64 | (System Packages)
    i+ | R-nnet                                       | package | 7.3.14-lp152.141.1                        | x86_64 | (System Packages)
    i+ | R-openssl                                    | package | 1.1-lp152.4.10                            | x86_64 | (System Packages)
    i+ | R-packrat                                    | package | 0.5.0-lp152.4.8                           | x86_64 | (System Packages)
    i+ | R-parallel                                   | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-rJava                                      | package | 0.9.12-lp152.2.6                          | x86_64 | (System Packages)
    i+ | R-recommended-packages                       | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-rpart                                      | package | 4.1.15-lp152.141.1                        | x86_64 | (System Packages)
    i+ | R-rsconnect                                  | package | 0.8.12-lp152.4.8                          | x86_64 | (System Packages)
    i+ | R-rstudioapi                                 | package | 0.11-lp152.1.5                            | x86_64 | (System Packages)
    i+ | R-spatial                                    | package | 7.3.12-lp152.141.1                        | x86_64 | (System Packages)
    i+ | R-splines                                    | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-stats                                      | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-stats4                                     | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-survival                                   | package | 3.1.12-lp152.141.1                        | x86_64 | (System Packages)
    i+ | R-tcltk                                      | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-tools                                      | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-utils                                      | package | 4.0.4-lp152.141.1                         | x86_64 | (System Packages)
    i+ | R-yaml                                       | package | 2.2.0-lp152.6.10                          | x86_64 | (System Packages)
    i+ | broadcom-wl-kmp-default                      | package | 6.30.223.271_k5.3.18_lp152.60-pm152.14.14 | x86_64 | (System Packages)
    i+ | broadcom-wl-kmp-default                      | package | 6.30.223.271_k5.3.18_lp152.57-pm152.14.7  | x86_64 | (System Packages)
    i+ | broadcom-wl-kmp-default                      | package | 6.30.223.271_k5.3.18_lp152.50-pm152.13.23 | x86_64 | (System Packages)
    i+ | broadcom-wl-kmp-default                      | package | 6.30.223.271_k5.3.18_lp152.47-pm152.13.18 | x86_64 | (System Packages)
    i+ | broadcom-wl-kmp-default                      | package | 6.30.223.271_k5.3.18_lp152.44-pm152.13.12 | x86_64 | (System Packages)
    i+ | google-chrome-stable                         | package | 88.0.4324.182-1                           | x86_64 | (System Packages)
    i+ | google-earth-pro-stable                      | package | 7.3.3.7699-0                              | x86_64 | (System Packages)
    i+ | libQtWebKit4                                 | package | 4.8.7+2.3.4-pm152.6.55                    | x86_64 | (System Packages)
    i+ | libavcodec58                                 | package | 4.2.1-pm152.3.17                          | x86_64 | (System Packages)
    i+ | libavfilter7                                 | package | 4.2.1-pm152.3.17                          | x86_64 | (System Packages)
    i+ | libavformat58                                | package | 4.2.1-pm152.3.17                          | x86_64 | (System Packages)
    i+ | libavresample4                               | package | 4.2.1-pm152.3.17                          | x86_64 | (System Packages)
    i+ | libavutil56                                  | package | 4.2.1-pm152.3.17                          | x86_64 | (System Packages)
    i+ | libfdk-aac1                                  | package | 0.1.6-lp150.2.6                           | x86_64 | (System Packages)
    i+ | libpostproc55                                | package | 4.2.1-pm152.3.17                          | x86_64 | (System Packages)
    i+ | libswresample3                               | package | 4.2.1-pm152.3.17                          | x86_64 | (System Packages)
    i+ | libswscale5                                  | package | 4.2.1-pm152.3.17                          | x86_64 | (System Packages)
    i+ | libx264-152                                  | package | 0.152svn20180305-5.3                      | x86_64 | (System Packages)
    i+ | libx264-155                                  | package | 0.155svn20190201-pm151.3.1                | x86_64 | (System Packages)
    i+ | libx264-160                                  | package | 0.160+git20200702.cde9a933-pm152.1.2      | x86_64 | (System Packages)
    i+ | libx265-151                                  | package | 2.7-3.4                                   | x86_64 | (System Packages)
    i+ | libx265-165                                  | package | 2.9-1.4                                   | x86_64 | (System Packages)
    i+ | libx265-169                                  | package | 3.0-lp150.1.5                             | x86_64 | (System Packages)
    i+ | libx265-179                                  | package | 3.2-lp150.1.3                             | x86_64 | (System Packages)
    i+ | libx265-188                                  | package | 3.3-pm151.1.1                             | x86_64 | (System Packages)
    i+ | nvidia-computeG04                            | package | 390.141-lp152.8.1                         | x86_64 | (System Packages)
    i+ | nvidia-gfxG04-kmp-default                    | package | 390.141_k5.3.18_lp152.19-lp152.8.1        | x86_64 | (System Packages)
    i+ | nvidia-glG04                                 | package | 390.141-lp152.8.1                         | x86_64 | (System Packages)
    i+ | openSUSE-release-dvd                         | package | 42.3-1.202                                | x86_64 | (System Packages)
    i+ | x11-video-nvidiaG04                          | package | 390.141-lp152.8.1                         | x86_64 | (System Packages)
    Code:
    by79@linux-3ztp:/> ls -al /etc | grep -i suse
    drwxr-xr-x 1 root   root      454 Jan 26 07:25 ImageMagick-7-SUSE
    -rw-r--r-- 1 root   root       24 Jun  5  2020 SUSE-brand
    -rw-r--r-- 1 root   root      394 Jan 13 06:55 SUSEConnect.example
    Thank you!

  5. #35
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,696

    Default AW: Unable to boot after setting up 2 monitors

    Can you update:
    as root
    Code:
    zypper up
    PS
    Can you use as root:
    Code:
    nvidia-settings

  6. #36

    Default Re: Unable to boot after setting up 2 monitors

    Hi,

    I tried this

    Code:
    zypper up
    so it updated.

    May I know what is the use of the below please?
    Code:
    nvidia-settings
    I think when I first attempted using 2 monitors, nvidia-settings is what I got into...during that session, it worked. But when I tried to restart, that is when the GUI failed...

    Just now, after I run zypper up, I restarted 2 times, both times it worked! Pls don't get me wrong, I am open to going to nvidia-settings to make sure things are properly set up.

    Appreciate your advice and thanks again.

  7. #37
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,818
    Blog Entries
    1

    Default Re: Unable to boot after setting up 2 monitors

    Quote Originally Posted by by79 View Post
    Code:
     zypper se -si | grep -Ei 'systemp|system_p|system-p|system p'
    ...
    i+ | nvidia-computeG04         | package | 390.141-lp152.8.1                  | x86_64 | (System Packages)
    i+ | nvidia-gfxG04-kmp-default | package | 390.141_k5.3.18_lp152.19-lp152.8.1 | x86_64 | (System Packages)
    i+ | nvidia-glG04              | package | 390.141-lp152.8.1                  | x86_64 | (System Packages)
    i+ | openSUSE-release-dvd      | package | 42.3-1.202                         | x86_64 | (System Packages)
    i+ | x11-video-nvidiaG04       | package | 390.141-lp152.8.1                  | x86_64 | (System Packages)
    As one little schooled in NVidia's drivers, I would expect a 1050 to prefer G05 drivers, which is where I got the idea about a newer than 390 version. Once all the "System Packages" packages have been properly removed or updated, I'd expect the chrome coredump problem to go away, and possibly all problems. My search for old packages is a bit different from Sauerland's:
    Code:
    # cat /usr/local/bin/zypseo
    #!/bin/sh
    zypper --no-refresh se -si | grep 'tem Pac' | grep -v plication
    Do any "System Packages" now remain? If none, there may be nothing more to do but to happily use a nicely working 15.2.

    Running nvidia-settings again might now be pointless, but an upgrade to G05, should it be a better way forward, might include it, or make it desirable.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.2, +TW, 15.1, 15.0 & 13.1 on Haswell
    Secondary: eComStation (OS/2) &15.1 on i965P w/ Radeon
    Tertiary: Mageia,Fedora,Debian,more on Kaby Lake,iQ45,iQ43,iG41,iG3X,i965G,AMD,NVidia&&&&&

  8. #38

    Default Re: Unable to boot after setting up 2 monitors

    Hi,

    Not too sure if I am running the first 2 commands correctly but anyway,
    1)
    Code:
    by79@linux-3ztp:~> cat /usr/local/bin/zypseo
    cat: /usr/local/bin/zypseo: No such file or directory
    2)
    Code:
    by79@linux-3ztp:~> !/bin/sh
    bash: !/bin/sh: event not found
    3)
    Code:
    by79@linux-3ztp:~> zypper --no-refresh se -si | grep 'tem Pac' | grep -v plication
    i+ | broadcom-wl-kmp-default                      | package | 6.30.223.271_k5.3.18_lp152.60-pm152.14.14 | x86_64 | (System Packages)
    i+ | broadcom-wl-kmp-default                      | package | 6.30.223.271_k5.3.18_lp152.57-pm152.14.7  | x86_64 | (System Packages)
    i+ | broadcom-wl-kmp-default                      | package | 6.30.223.271_k5.3.18_lp152.50-pm152.13.23 | x86_64 | (System Packages)
    i+ | broadcom-wl-kmp-default                      | package | 6.30.223.271_k5.3.18_lp152.47-pm152.13.18 | x86_64 | (System Packages)
    i+ | broadcom-wl-kmp-default                      | package | 6.30.223.271_k5.3.18_lp152.44-pm152.13.12 | x86_64 | (System Packages)
    i+ | google-earth-pro-stable                      | package | 7.3.3.7699-0                              | x86_64 | (System Packages)
    i+ | libQtWebKit4                                 | package | 4.8.7+2.3.4-pm152.6.55                    | x86_64 | (System Packages)
    i+ | libavcodec58                                 | package | 4.2.1-pm152.3.17                          | x86_64 | (System Packages)
    i+ | libavfilter7                                 | package | 4.2.1-pm152.3.17                          | x86_64 | (System Packages)
    i+ | libavformat58                                | package | 4.2.1-pm152.3.17                          | x86_64 | (System Packages)
    i+ | libavresample4                               | package | 4.2.1-pm152.3.17                          | x86_64 | (System Packages)
    i+ | libavutil56                                  | package | 4.2.1-pm152.3.17                          | x86_64 | (System Packages)
    i+ | libfdk-aac1                                  | package | 0.1.6-lp150.2.6                           | x86_64 | (System Packages)
    i+ | libpostproc55                                | package | 4.2.1-pm152.3.17                          | x86_64 | (System Packages)
    i+ | libswresample3                               | package | 4.2.1-pm152.3.17                          | x86_64 | (System Packages)
    i+ | libswscale5                                  | package | 4.2.1-pm152.3.17                          | x86_64 | (System Packages)
    i+ | libx264-152                                  | package | 0.152svn20180305-5.3                      | x86_64 | (System Packages)
    i+ | libx264-155                                  | package | 0.155svn20190201-pm151.3.1                | x86_64 | (System Packages)
    i+ | libx264-160                                  | package | 0.160+git20200702.cde9a933-pm152.1.2      | x86_64 | (System Packages)
    i+ | libx265-151                                  | package | 2.7-3.4                                   | x86_64 | (System Packages)
    i+ | libx265-165                                  | package | 2.9-1.4                                   | x86_64 | (System Packages)
    i+ | libx265-169                                  | package | 3.0-lp150.1.5                             | x86_64 | (System Packages)
    i+ | libx265-179                                  | package | 3.2-lp150.1.3                             | x86_64 | (System Packages)
    i+ | libx265-188                                  | package | 3.3-pm151.1.1                             | x86_64 | (System Packages)
    i+ | openSUSE-release-dvd                         | package | 42.3-1.202                                | x86_64 | (System Packages)

    I guess that means no relevant "System Packages"?

    an upgrade to G05, should it be a better way forward, might include it, or make it desirable.
    Firstly, is there still a need to do so based on the above?

    If so, sorry, a dumb question, does installing a driver means the same thing as upgrading a driver?

    I was going through this thread:

    https://forums.opensuse.org/showthread.php/541951-Leap-15-2-NVIDIA-driver-does-not-work


    and felt a bit overwhelmed...

    Do I follow the below?


    https://en.opensuse.org/SDB:NVIDIA_drivers

    https://en.opensuse.org/SDB:NVIDIA_the_hard_way

    Thank you!

  9. #39
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,818
    Blog Entries
    1

    Default Re: Unable to boot after setting up 2 monitors

    Quote Originally Posted by mrmazda View Post
    My search for old packages is a bit different from Sauerland's:
    Code:
    # cat /usr/local/bin/zypseo
    #!/bin/sh
    zypper --no-refresh se -si | grep 'tem Pac' | grep -v plication
    What I actually do is simply:
    Code:
    zypseo
    Cat shows you the long version of what I actually do, because zypseo is in $PATH, allowing me to just type zypseo when I want an old packages listing. The next two lines show you what I do does. Zypseo is a one line script. I don't want to have to remember what to type when I want a list of old packages, so I put it in an easy to remember script. I didn't intend for you to run three commands, just the last one; or, create and use the same script.

    Regarding your NVidia driver question(s), someone else will have to provide a definitive answer. Since it seems your video problems are gone, I don't think anything needs doing.

    NAICT, most apps in that list are from Packman, from which often packages get orphaned rather than replaced when a new version is available. I would definitely remove openSUSE-release-dvd. If google-earth-pro-stable still works, it may be because of one or more of those other Packman packages. Most, maybe all, of the libx26* packages, are obsolete, superceded by newer versions. The kmps are for kernels you probably don't have installed any more. I suggest using YaST2 software management to handle determination and removal of those you don't need.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.2, +TW, 15.1, 15.0 & 13.1 on Haswell
    Secondary: eComStation (OS/2) &15.1 on i965P w/ Radeon
    Tertiary: Mageia,Fedora,Debian,more on Kaby Lake,iQ45,iQ43,iG41,iG3X,i965G,AMD,NVidia&&&&&

  10. #40

    Default Re: Unable to boot after setting up 2 monitors

    Noted!

    Thank you so much, mrmazda!
    Also thank you, Sauerland!

Page 4 of 5 FirstFirst ... 2345 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •