Results 1 to 4 of 4

Thread: Zypper - openSUSE-Tumbleweed-Non-Oss (20210215) repo not found

  1. #1
    Join Date
    Jul 2014
    Location
    Cluj-Napoca, RO
    Posts
    37

    Default Zypper - openSUSE-Tumbleweed-Non-Oss (20210215) repo not found

    Hi all,

    Seems like I have the 20210215 snapshot installed
    Code:
    tumbleweed status 
    latest   : 20210321 
    target   : 20210215 
    installed: 20210215
    


    but when I do
    Code:
    sudo zypper refresh
    or
    Code:
    sudo zypper dup
    I get an error that 'openSUSE-Tumbleweed-Non-Oss (20210215)' is invalid
    Code:
    Obțin metadatele sursei de instalare 'openSUSE-Tumbleweed-Non-Oss (20210215)' ......................................................................................................................................... 
    Sursa de instalare 'openSUSE-Tumbleweed-Non-Oss (20210215)' este invalidă.
    [repo-non-oss|http://download.opensuse.org/history/20210215/tumbleweed/repo/non-oss/] Valid metadata not found at specified URL
    Istoric:
     - [repo-non-oss|http://download.opensuse.org/history/20210215/tumbleweed/repo/non-oss/] Repository type can't be determined.
    
    Verificați dacă URI-urile definite pentru această sursă de instalare indică o sursă de instalare validă. 
    Omit sursa de instalare 'openSUSE-Tumbleweed-Non-Oss (20210215)' datorită erorii de mai sus.
    Obțin metadatele sursei de instalare 'openSUSE-Tumbleweed-Oss (20210215)' ............................................................................................................................................. 
    Sursa de instalare 'openSUSE-Tumbleweed-Oss (20210215)' este invalidă.
    [repo-oss|http://download.opensuse.org/history/20210215/tumbleweed/repo/oss/] Valid metadata not found at specified URL
    Istoric:
     - [repo-oss|http://download.opensuse.org/history/20210215/tumbleweed/repo/oss/] Repository type can't be determined.
    
    How can I get rid of it and update my Tumbleweed to latest and greatest?

    Thank you.
    Joy, frustration, excitement, madness, aha's, headaches ... codito ergo sum!
    My software never has bugs. It just develops random features.

  2. #2
    Join Date
    Sep 2012
    Posts
    6,489

    Default Re: Zypper - openSUSE-Tumbleweed-Non-Oss (20210215) repo not found

    Quote Originally Posted by savornicesei View Post
    I get an error that 'openSUSE-Tumbleweed-Non-Oss (20210215)' is invalid
    There is limited number of previous versions, so looks like yours was already removed.
    How can I get rid of it and update my Tumbleweed to latest and greatest?
    You froze your system on specific snapshot. There won't be any update to this snapshot. To update to latest and greatest you need to use tumbleweed repository, not specific historical snapshot repository.

    Or switch to newer snapshot using whatever tool you used to freeze your system. But then you will stay on this snapshot until you switch again.

  3. #3
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    730

    Default Re: Zypper - openSUSE-Tumbleweed-Non-Oss (20210215) repo not found

    Quote Originally Posted by savornicesei View Post
    ... but when I do
    Code:
    sudo zypper refresh
    Please use
    Code:
    # LANG=C COMMAND
    so that the output which you want to show here is in English.


    Quote Originally Posted by savornicesei View Post
    ...
    Code:
    sudo zypper dup
    I get an error that 'openSUSE-Tumbleweed-Non-Oss (20210215)' is invalid
    Code:
    Obțin metadatele sursei de instalare 'openSUSE-Tumbleweed-Non-Oss (20210215)' ......................................................................................................................................... 
    Sursa de instalare 'openSUSE-Tumbleweed-Non-Oss (20210215)' este invalidă.
    [repo-non-oss|http://download.opensuse.org/history/20210215/tumbleweed/repo/non-oss/] Valid metadata not found at specified URL
    Istoric:
     - [repo-non-oss|http://download.opensuse.org/history/20210215/tumbleweed/repo/non-oss/] Repository type can't be determined.
    
    Verificați dacă URI-urile definite pentru această sursă de instalare indică o sursă de instalare validă. 
    Omit sursa de instalare 'openSUSE-Tumbleweed-Non-Oss (20210215)' datorită erorii de mai sus.
    Obțin metadatele sursei de instalare 'openSUSE-Tumbleweed-Oss (20210215)' ............................................................................................................................................. 
    Sursa de instalare 'openSUSE-Tumbleweed-Oss (20210215)' este invalidă.
    [repo-oss|http://download.opensuse.org/history/20210215/tumbleweed/repo/oss/] Valid metadata not found at specified URL
    Istoric:
     - [repo-oss|http://download.opensuse.org/history/20210215/tumbleweed/repo/oss/] Repository type can't be determined.
    
    Although i do not understand much of what you show here i think you should use http://download.opensuse.org/tumbleweed/repo/oss/ instead of http://download.opensuse.org/history...weed/repo/oss/. and http://download.opensuse.org/tumbleweed/repo/non-oss/ instead of http://download.opensuse.org/history.../repo/non-oss/

    Regards

    susejunky

  4. #4
    Join Date
    Jul 2014
    Location
    Cluj-Napoca, RO
    Posts
    37

    Default Re: Zypper - openSUSE-Tumbleweed-Non-Oss (20210215) repo not found

    Quote Originally Posted by arvidjaar View Post
    [...]

    You froze your system on specific snapshot.[...]
    I'm not sure how I did that. Clearly not by intent. Thank you.

    Quote Originally Posted by susejunky View Post
    Please use
    Code:
    # LANG=C COMMAND
    so that the output which you want to show here is in English.[...]
    Thank you for reminding me the correct syntax for LANG.


    Zypper dup already running!

    Thank you!!!
    Joy, frustration, excitement, madness, aha's, headaches ... codito ergo sum!
    My software never has bugs. It just develops random features.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •