Results 1 to 6 of 6

Thread: Why would installed s/w not appear in the YAST2 frewall service list?

  1. #1

    Default Why would installed s/w not appear in the YAST2 frewall service list?

    Hi,

    I wanted to add Plex to the firewall as a trusted service to see if it fixes my remote connection problems.

    (port forwarding configured on router, and 32400 port added to openSUSE firewall).

    Rather than get into Plex, I was wondering - why would installed software not appear in the firewall services list - so I can trust it?

    Thanks

    Lee

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,065
    Blog Entries
    15

    Default Re: Why would installed s/w not appear in the YAST2 frewall service list?

    Quote Originally Posted by leejenson View Post
    Hi,

    I wanted to add Plex to the firewall as a trusted service to see if it fixes my remote connection problems.

    (port forwarding configured on router, and 32400 port added to openSUSE firewall).

    Rather than get into Plex, I was wondering - why would installed software not appear in the firewall services list - so I can trust it?

    Thanks

    Lee
    Hi
    The package would need to install the appropriate firewalld file for that to occur...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Why would installed s/w not appear in the YAST2 frewall service list?

    Quote Originally Posted by malcolmlewis View Post
    Hi
    The package would need to install the appropriate firewalld file for that to occur...
    Thanks Malcolm, I'll pop over to the Plex forum and do some more research.

    Lee

  4. #4
    Join Date
    Apr 2016
    Location
    Cambridge, UK
    Posts
    143

    Default Re: Why would installed s/w not appear in the YAST2 frewall service list?

    The subject line is "Why would installed s/w not appear in the YAST2 frewall service list"

    (port forwarding configured on router, and 32400 port added to openSUSE firewall).
    This is all looking at the YaST2 firewall and times have changed and most systems now use firewalld and so need to use "firewall-config" as it's not a YaST module. I think leejenson is looking in the wrong place to configure this.



  5. #5

    Default Re: Why would installed s/w not appear in the YAST2 frewall service list?

    Quote Originally Posted by JulinaB View Post
    The subject line is "Why would installed s/w not appear in the YAST2 frewall service list"



    This is all looking at the YaST2 firewall and times have changed and most systems now use firewalld and so need to use "firewall-config" as it's not a YaST module. I think leejenson is looking in the wrong place to configure this.


    Thanks JulinaB,

    Who do I add Plex with firewall-config?

    Thanks

    Lee

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,857
    Blog Entries
    1

    Default Re: Why would installed s/w not appear in the YAST2 frewall service list?

    Quote Originally Posted by leejenson View Post
    Thanks JulinaB,

    Who do I add Plex with firewall-config?

    Thanks

    Lee
    Manual configuration (via firewall-config) can be done by adding appropriate ports as listed here...

    https://support.plex.tv/articles/201...h-my-firewall/

    In particular it is mentioned...
    The most important port to make sure your firewall allows is the main TCP port the Plex Media Server uses for communication:

    • TCP: 32400 (access to the Plex Media Server) [required]

    The following additional ports are also used within the local network for different services:

    • UDP: 1900 (access to the Plex DLNA Server)
    • UDP: 5353 (older Bonjour/Avahi network discovery)
    • TCP: 8324 (controlling Plex for Roku via Plex Companion)
    • UDP: 32410, 32412, 32413, 32414 (current GDM network discovery)
    • TCP: 32469 (access to the Plex DLNA Server)
    Additionally, I note that port 3005 TCP is mentioned elsewhere for Plex Companion (however I'm not familiar with using that).

    Anyway, you could create a custom service "plex-server.xml" in /etc/firewalld/services/ with an editor (as root) containing...
    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <service>
      <short>Plex Media Server</short>
      <description>Firewall ports required by the Plex Media Server</description>
      <port protocol="udp" port="1900"></port>
      <port protocol="tcp" port="3005"></port>
      <port protocol="udp" port="5353"></port>
      <port protocol="tcp" port="8324"></port>
      <port protocol="tcp" port="32400"></port>
      <port protocol="udp" port="32410"></port>
      <port protocol="udp" port="32412"></port>
      <port protocol="udp" port="32413"></port>
      <port protocol="udp" port="32414"></port>
      <port protocol="tcp" port="32469"></port>
      </service>
    Once that's done, retstart firewalld
    Code:
    sudo systemctl restart firewalld
    and you should then be able to find "plex-server" in the firewall service list to enable it. Check that it works as expected. To make it permanent navigate to "Options" > "Runtime To Permanent"

    More info
    https://firewalld.org/documentation/...a-service.html
    openSUSE Leap 15.2; KDE Plasma 5

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •