I have the game 0ad installed from the official openSUSE-Tumbleweed-Games repository. As of recent, it seems to have been broken by two package related issues. Thought I'd make a thread to raise awareness.

The first is a bad libicu version: The game is packaged for libicu67 which no longer exists, now having been replaced with libicu68. Trying to run the engine without the deprecated lib installed will crash with the error:

Code:
/usr/bin/pyrogenesis: error while loading shared libraries: libicui18n.so.67: cannot open shared object file: No such file or directory
The second issue is that although the engine remains at version 0.0.23b, the data was just updated to version 0.0.24b. The two are incompatible; I had to downgrade the data package from another repository to fix. Can both be bumped to 0.0.24b please?

Looking at the build page I noticed a few compilation failures yesterday for Tumbleweed. Maybe that explains the inconsistencies? I hope it will be back to normal soon, it's a fun game I enjoy playing every once in a while!