Page 1 of 7 123 ... LastLast
Results 1 to 10 of 67

Thread: How do I fix my firewall to enable minimwatch on laptop to talk to NAS

  1. #1
    Join Date
    Nov 2008
    Posts
    1,788
    Blog Entries
    1

    Default How do I fix my firewall to enable minimwatch on laptop to talk to NAS

    I have never been able to sort this out. I have NAS on the same subnet but am accessing through a laptop, also on the subnet but I cannot, nor have I ever been able to enable minimwatch on the laptop to talk to mimimserver on the NAS wit the firewall running. The only way I can get functioning minimwatch is if I turn off the firewall.

    Minimwatch directions say allow UDP traffic on port 1900 and I have done this in every conceivable way in the firewall window but no luck. Only turning off firewall works.
    How can I sort this out please?
    Budge.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,848
    Blog Entries
    1

    Default Re: How do I fix my firewall to enable minimwatch on laptop to talk to NAS

    Quote Originally Posted by Budgie2 View Post
    I have never been able to sort this out. I have NAS on the same subnet but am accessing through a laptop, also on the subnet but I cannot, nor have I ever been able to enable minimwatch on the laptop to talk to mimimserver on the NAS wit the firewall running. The only way I can get functioning minimwatch is if I turn off the firewall.

    Minimwatch directions say allow UDP traffic on port 1900 and I have done this in every conceivable way in the firewall window but no luck. Only turning off firewall works.
    How can I sort this out please?
    Budge.
    Can you show us the current firewall configuration to start with please?
    Code:
    firewall-cmd --list-all
    openSUSE Leap 15.2; KDE Plasma 5

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,848
    Blog Entries
    1

    Default Re: How do I fix my firewall to enable minimwatch on laptop to talk to NAS

    BTW, a quick search online turned up this

    https://forum.minimserver.com/archiv...read-2761.html

    The following ports must be open on any firewall to access MinimServer:
    - Port 1900/udp (UPNP)
    - Port 9790/tcp
    - Port 9791/tcp

    Thank you.
    openSUSE Leap 15.2; KDE Plasma 5

  4. #4
    Join Date
    Nov 2008
    Posts
    1,788
    Blog Entries
    1

    Default Re: How do I fix my firewall to enable minimwatch on laptop to talk to NAS

    Hi Deano,
    Many thanks,
    No luck so far but working on it.
    How do I add he two port numbers, do I use a comma delimiter or space.

    Spoiled for choice on zones too. How on earth do I discriminate between home, internal and trusted, work and external etc.
    Will keep reading!

  5. #5
    Join Date
    Nov 2008
    Posts
    1,788
    Blog Entries
    1

    Default Re: How do I fix my firewall to enable minimwatch on laptop to talk to NAS

    No luck so far. I have enabled 1900/UDP, 9790/TCP, 9791/TCP on all interfaces and added upnp-client on all too.
    I am having to try hit and miss here. Surely there is a means to sniff out which packets are being dropped so that the FW can be edited to allow the required traffic.
    Will keep trying.
    Budge

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,848
    Blog Entries
    1

    Default Re: How do I fix my firewall to enable minimwatch on laptop to talk to NAS

    Quote Originally Posted by Budgie2 View Post
    Hi Deano,
    Many thanks,
    No luck so far but working on it.
    How do I add he two port numbers, do I use a comma delimiter or space.
    Add them separately.

    There is also the graphical 'firewall-config' utility that can simplify firewall configuration if desired...
    https://doc.opensuse.org/documentati...wall-firewalld

    Spoiled for choice on zones too. How on earth do I discriminate between home, internal and trusted, work and external etc.
    Will keep reading!
    Firewalld is well documented...
    https://firewalld.org/documentation/

    An 'openSUSE How To' to give you the basic ideas...
    https://www.cyberciti.biz/faq/set-up...pensuse-linux/

    If you post the output from the command I posted already, someone can advise you more specifically, otherwise we're left to speculate.
    openSUSE Leap 15.2; KDE Plasma 5

  7. #7
    Join Date
    Sep 2012
    Posts
    6,315

    Default Re: How do I fix my firewall to enable minimwatch on laptop to talk to NAS

    Quote Originally Posted by Budgie2 View Post
    Surely there is a means to sniff out which packets are being dropped
    Code:
    firewall-cmd --set-log-denied=all

  8. #8
    Join Date
    Nov 2008
    Posts
    1,788
    Blog Entries
    1

    Default Re: How do I fix my firewall to enable minimwatch on laptop to talk to NAS

    Quote Originally Posted by arvidjaar View Post
    Code:
    firewall-cmd --set-log-denied=all
    Many thanks. I have it running now.
    One question, what is correct way to stop this please?
    Regards,

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    28,291

    Default Re: How do I fix my firewall to enable minimwatch on laptop to talk to NAS

    Ctrl-C (also written as ^C in texts)?
    Henk van Velden

  10. #10
    Join Date
    Nov 2008
    Posts
    1,788
    Blog Entries
    1

    Default Re: How do I fix my firewall to enable minimwatch on laptop to talk to NAS

    Quote Originally Posted by Budgie2 View Post
    Many thanks. I have it running now.
    One question, what is correct way to stop this please?
    Regards,
    I have it now and have been trying to sort out what I have found. I have a candidate trying to connect to this machine (on which I am typing at present) from the relevant server:-


    Code:
    [ 7191.951239] FINAL_REJECT: IN=wlp3s0 OUT= MAC=3c:a9:f4:56:ee:8c:00:08:9b:c7:ec:72:08:00 SRC
    =192.168.169.130 DST=192.168.169.226 LEN=382 TOS=0x00 PREC=0x00 TTL=64 ID=0 DF PROTO=UDP SPT=
    59510 DPT=57221 LEN=362
    
    So many questions but which port is the right one here? Also if these ports are set dynamically how can they be filtered? More reading by me is required I think but meanwhile what should I try next please?

Page 1 of 7 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •