openSUSE Security Update: Security update for MozillaFirefox______________________________________________________________________________Announcement ID: openSUSE-SU-2021:0373-1Rating: importantReferences: #1182357 #1182614 Cross-References: CVE-2021-23968 CVE-2021-23969 CVE-2021-23973 CVE-2021-23978CVSS scores: CVE-2021-23968 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVE-2021-23969 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVE-2021-23973 (SUSE): 3.1 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N CVE-2021-23978 (SUSE): 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HAffected Products: openSUSE Leap 15.2______________________________________________________________________________ An update that fixes four vulnerabilities is now available.Description: This update for MozillaFirefox fixes the following issues: - Firefox Extended Support Release 78.8.0 ESR * Fixed: Various stability, functionality, and security fixes MFSA 2021-08 (bsc#1182614) * CVE-2021-23969: Content Security Policy violation report could have contained the destination of a redirect * CVE-2021-23968: Content Security Policy violation report could have contained the destination of a redirect * CVE-2021-23973: MediaError message property could have leaked information about cross-origin resources * CVE-2021-23978: Memory safety bugs fixed in Firefox 86 and Firefox ESR 78.8 This update was imported from the SUSE:SLE-15-SP2:Update update project.Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.2: zypper in -t patch openSUSE-2021-373=1Package List: - openSUSE Leap 15.2 (x86_64): MozillaFirefox-78.8.0-lp152.2.49.1 MozillaFirefox-branding-upstream-78.8.0-lp152.2.49.1 MozillaFirefox-buildsymbols-78.8.0-lp152.2.49.1 MozillaFirefox-debuginfo-78.8.0-lp152.2.49.1 MozillaFirefox-debugsource-78.8.0-lp152.2.49.1 MozillaFirefox-devel-78.8.0-lp152.2.49.1 MozillaFirefox-translations-common-78.8.0-lp152.2.49.1 MozillaFirefox-translations-other-78.8.0-lp152.2.49.1References: https://www.suse.com/security/cve/CVE-2021-23968.html https://www.suse.com/security/cve/CVE-2021-23969.html https://www.suse.com/security/cve/CVE-2021-23973.html https://www.suse.com/security/cve/CVE-2021-23978.html https://bugzilla.suse.com/1182357 https://bugzilla.suse.com/1182614

More...