Results 1 to 9 of 9

Thread: Error updating Tumbleweed

  1. #1
    Join Date
    Dec 2020
    Location
    Sweden
    Posts
    7

    Default Error updating Tumbleweed

    Hi I get an error when trying to update. The
    is not Pacman.


    Code:
    patrick@localhost:~> LANG=C sudo zypper up
    [sudo] password for root: 
    Retrieving repository 'openSUSE:Tumbleweed' metadata ............................[error]
    Repository 'openSUSE:Tumbleweed' is invalid.
    [https-download.opensuse.org-3820ebc5|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod/] Valid metadata not found at specified URL
    History:
     - [https-download.opensuse.org-3820ebc5|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod/] Repository type can't be determined.
    
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Warning: Skipping repository 'openSUSE:Tumbleweed' because of the above error.
    Retrieving repository 'openSUSE:Tumbleweed' metadata ............................[error]
    Repository 'openSUSE:Tumbleweed' is invalid.
    [https-download.opensuse.org-8e8c6de5|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod_debug/] Valid metadata not found at specified URL
    History:
     - [https-download.opensuse.org-8e8c6de5|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod_debug/] Repository type can't be determined.
    
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Warning: Skipping repository 'openSUSE:Tumbleweed' because of the above error.
    Retrieving repository 'openSUSE:Tumbleweed' metadata ............................[error]
    Repository 'openSUSE:Tumbleweed' is invalid.
    [https-download.opensuse.org-b7c15ee9|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod/] Valid metadata not found at specified URL
    History:
     - [https-download.opensuse.org-b7c15ee9|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod/] Repository type can't be determined.
    
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Warning: Skipping repository 'openSUSE:Tumbleweed' because of the above error.
    Retrieving repository 'openSUSE:Tumbleweed' metadata ............................[error]
    Repository 'openSUSE:Tumbleweed' is invalid.
    [https-download.opensuse.org-c8d6fe22|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod/] Valid metadata not found at specified URL
    History:
     - [https-download.opensuse.org-c8d6fe22|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod/] Repository type can't be determined.
    
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Warning: Skipping repository 'openSUSE:Tumbleweed' because of the above error.
    Some of the repositories have not been refreshed because of an error.
    Loading repository data...
    Reading installed packages...
    
    The following 41 package updates will NOT be installed:
      libpoppler-cpp0 libpoppler-glib8 libpoppler-qt5-1 libpoppler107 libsensors4
      poppler-tools python38-PySocks python38-appdirs python38-asn1crypto python38-brotlipy
      python38-certifi python38-cffi python38-chardet python38-cmdln python38-configobj
      python38-cryptography python38-decorator python38-idna python38-linux-procfs
      python38-mysqlclient python38-notify2 python38-ordered-set python38-packaging
      python38-pip python38-ply python38-psutil python38-pyOpenSSL python38-pyasn1
      python38-pycparser python38-pycups python38-pycurl python38-pyparsing python38-pyudev
      python38-requests python38-setuptools python38-six python38-slip python38-slip-dbus
      python38-urllib3 sensors xdg-utils
    Nothing to do.

    Mvh Pata

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    28,661

    Default Re: Error updating Tumbleweed

    There are about five or more threads about this.

    Also, at the top of every page there is an announcement (repeated below):
    Sunday February 28th 2021 - Update issue with packman inode mirror

    There are issues with the inode mirror, please configure an alternative mirror. See http://packman.links2linux.org/mirrors
    Henk van Velden

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,852

    Default AW: Error updating Tumbleweed

    You can also delete the Repos with dod in the Url.

    Code:
    zypper up
    on Tumbleweed will not update safely, only
    Code:
    zypper dup
    will do it on Tumbleweed.
    Last edited by Sauerland; 02-Mar-2021 at 06:19.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,912
    Blog Entries
    14

    Default Re: Error updating Tumbleweed

    AFAIK I helped this user on Discord/Matrix/Telegram. A matter of wrongly setup repos, indeed.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: Error updating Tumbleweed

    Quote Originally Posted by hcvv View Post
    There are about five or more threads about this.

    Also, at the top of every page there is an announcement (repeated below):
    Then I better not open a new thread, but I have the same problem on Tumbleweed and did not find a solution.

    Code:
    OpenSuse:/var/tmp # zypper dup 
    Retrieving repository 'openSUSE:Tumbleweed' metadata ................................................................................................................[error] 
    Repository 'openSUSE:Tumbleweed' is invalid.
    [https-download.opensuse.org-137321ab|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod_debug/] Valid metadata not found at specified URL                 
    History:                                                                                                                                                                    
     - [https-download.opensuse.org-137321ab|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod_debug/] Repository type can't be determined.                   
    
    Please check if the URIs defined for this repository are pointing to a valid repository. 
    Warning: Skipping repository 'openSUSE:Tumbleweed' because of the above error. 
    Retrieving repository 'openSUSE:Tumbleweed' metadata ................................................................................................................[error] 
    Repository 'openSUSE:Tumbleweed' is invalid.
    [https-download.opensuse.org-6fdf5dca|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod/] Valid metadata not found at specified URL                       
    History:                                                                                                                                                                    
     - [https-download.opensuse.org-6fdf5dca|https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod/] Repository type can't be determined.                         
    
    Please check if the URIs defined for this repository are pointing to a valid repository. 
    Warning: Skipping repository 'openSUSE:Tumbleweed' because of the above error. 
    Some of the repositories have not been refreshed because of an error.
    What do I need to do to fix this?

    TIA

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,852

    Default AW: Error updating Tumbleweed

    What do I need to do to fix this?
    See this one:
    Quote Originally Posted by Sauerland View Post
    You can also delete the Repos with dod in the Url.

    Code:
    zypper up
    on Tumbleweed will not update safely, only
    Code:
    zypper dup
    will do it on Tumbleweed.

  7. #7

    Default Re: AW: Error updating Tumbleweed

    Quote Originally Posted by Sauerland View Post
    See this one:
    Thanks for fast help. zypper dup is exactly what I do and then the problem occurs (see my code snippet above).
    Any other ideas?

    TIA

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,852

    Default AW: Error updating Tumbleweed

    See my bold quote......

  9. #9

    Default Re: AW: Error updating Tumbleweed

    Quote Originally Posted by Sauerland View Post
    See my bold quote......
    Sorry, thought you meant the other part.

    zypper rr https://download.opensuse.org/reposi...umbleweed/dod/

    worked
    (same for the other repo)

    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •