Results 1 to 9 of 9

Thread: MailServer.pm

  1. #1

    Default MailServer.pm

    Where is the MailServer.pm and the User and Group management?
    This link
    Yast2 modules will not load in SLES | Support | SUSE
    does not help.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    28,268

    Default Re: MailServer.pm

    A good problem description has basically three components: what did you do, what did happen, what did you expect to happen.

    Of course you do that is a step by step description on what you do, best proven by copy/paste (between CODE tags) or screen shots uploaded to https://susepaste.org/

    You only provide a link to something SUSE, but this is openSUSE.

    So please explain what you try to do, based on what and what you are missing then in openSUSE 15.2.
    Henk van Velden

  3. #3

    Default Re: MailServer.pm

    Quote Originally Posted by hcvv View Post
    A good problem description has basically three components: what did you do, what did happen, what did you expect to happen.

    Of course you do that is a step by step description on what you do, best proven by copy/paste (between CODE tags) or screen shots uploaded to https://susepaste.org/

    You only provide a link to something SUSE, but this is openSUSE.

    So please explain what you try to do, based on what and what you are missing then in openSUSE 15.2.
    The main problem is that you did not read the link.

    This PRECISELY describes what I did, what happened after, what is the problem an how could I fix it. I have 15.2, an old system.
    Briefly: I deleted the .Xauthority file (during a heavy ransomware attack) and then the User and Group Management disappeared from the Yast.

    The problem is: a piece of the Yast (Mailserver.pm) is missing now and I cannot download from anywhere.
    Thank for your help.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    28,268

    Default Re: MailServer.pm

    Quote Originally Posted by venemberke View Post
    The main problem is that you did not read the link.
    No, I didn't. It is about quite old versions of SLES/SLED. As am not (and never was) as SLES/SLED user, I did not think this page to be worth much attention.

    Quote Originally Posted by venemberke View Post
    Briefly: I deleted the .Xauthority file (during a heavy ransomware attack) and then the User and Group Management disappearei from the Yast.
    As .Xauthority as a relative path, you probably should define better which .Xauthority and where. AFAIK, this file is found in the home directory of users that use X. I do not see any connection of a user deleting .Xauthority from his/her home directory and YaST modules being removed.
    And as I said above, please show. Thus when you say the User and Group Management disappeared from YaST, you illustrate that with e.g. (as root)
    Code:
    yast users
    Quote Originally Posted by venemberke View Post
    The problem is: a piece of the Yast (Mailserver.pm) is missing now and I cannot download from anywhere.
    I have no idea what that Mailserver.pm is. Never heard of it and I can also see no connection with YaST or any of it's modules.
    Quote Originally Posted by venemberke View Post
    Thank for your help.
    Until now I only tried to help you to formulate your problem. Not much progress in about 24 hours.
    Henk van Velden

  5. #5

    Default Re: MailServer.pm

    Quote Originally Posted by hcvv View Post
    No, I didn't. It is about quite old versions of SLES/SLED. As am not (and never was) as SLES/SLED user, I did not think this page to be worth much attention.


    As .Xauthority as a relative path, you probably should define better which .Xauthority and where. AFAIK, this file is found in the home directory of users that use X. I do not see any connection of a user deleting .Xauthority from his/her home directory and YaST modules being removed.
    And as I said above, please show. Thus when you say the User and Group Management disappeared from YaST, you illustrate that with e.g. (as root)
    Code:
    yast users
    I have no idea what that Mailserver.pm is. Never heard of it and I can also see no connection with YaST or any of it's modules.

    Until now I only tried to help you to formulate your problem. Not much progress in about 24 hours.
    My dear friend, Henk, I wrote 15.2 onto the top of the topic starter message.
    My dear friend, Henk, as the linked topic said that was no error message, the User and group Management program quits without any error message. If I can't see anything I can send only nothing to you.
    My dear friend, Henk I deleted the .Xauthority file by my hand from the root directory. It happened appr. four months ago. I am repairing the demolished server from that till now.
    Btw the error message in the y2log file:
    ... Perl ...
    ... Interpreter] modules/UserPlugins.pm:69 Perl wanted to die: Can't locate YaPI/MailServer.pm in @INC (you may need to install...)
    BEGIN faiiled--compilation aborted at /usr/share/YaST2/modules/UsersPluginMail.pm line 21.
    Compilation failed in require at........ YCP.pm. line 425.
    BEGIN failed--compilation aborted.

    And, my dear friend, Henk, if you are not an expert, please send here one. If yes, please fix the problem, if necessary and send me a link to download the installable file. I think, it would solve the problem.
    Thanks for your help.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    30,847
    Blog Entries
    15

    Default Re: MailServer.pm

    Quote Originally Posted by venemberke View Post
    My dear friend, Henk, I wrote 15.2 onto the top of the topic starter message.
    My dear friend, Henk, as the linked topic said that was no error message, the User and group Management program quits without any error message. If I can't see anything I can send only nothing to you.
    My dear friend, Henk I deleted the .Xauthority file by my hand from the root directory. It happened appr. four months ago. I am repairing the demolished server from that till now.
    Btw the error message in the y2log file:
    ... Perl ...
    ... Interpreter] modules/UserPlugins.pm:69 Perl wanted to die: Can't locate YaPI/MailServer.pm in @INC (you may need to install...)
    BEGIN faiiled--compilation aborted at /usr/share/YaST2/modules/UsersPluginMail.pm line 21.
    Compilation failed in require at........ YCP.pm. line 425.
    BEGIN failed--compilation aborted.

    And, my dear friend, Henk, if you are not an expert, please send here one. If yes, please fix the problem, if necessary and send me a link to download the installable file. I think, it would solve the problem.
    Thanks for your help.
    Hi
    Your not running Leap 15.2 if it's asking for MailServer.pm (YasT-Mail circa 13.1), YaST moved to ruby on rails.... please confirm via;

    Code:
    cat /etc/os-release
    If it is, has this system been on upgrades for awhile?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,797
    Blog Entries
    1

    Default Re: MailServer.pm

    Quote Originally Posted by venemberke View Post
    Where is the MailServer.pm and the User and Group management?
    This link
    Yast2 modules will not load in SLES | Support | SUSE
    does not help.
    Your opening post makes little sense. Please confirm openSUSE version as per Malcolm's post.

    For reference I get....
    Code:
    # zypper se -s yast2-mail
    
    Loading repository data...
    Reading installed packages...
    
    S  | Name       | Type       | Version           | Arch   | Repository
    ---+------------+------------+-------------------+--------+--------------------------
    i+ | yast2-mail | package    | 4.2.3-lp152.2.3.1 | noarch | openSUSE:Leap:15.2:Update
    i+ | yast2-mail | package    | 4.2.3-lp152.2.3.1 | noarch | openSUSE:Leap:15.2:Update
    i+ | yast2-mail | package    | 4.2.3-lp152.2.3.1 | noarch | openSUSE-Leap-15.2-Update
    v  | yast2-mail | package    | 4.2.2-lp152.1.2   | noarch | openSUSE-Leap-15.2-Oss
       | yast2-mail | srcpackage | 4.2.3-lp152.2.3.1 | noarch | openSUSE:Leap:15.2:Update
       | yast2-mail | srcpackage | 4.2.3-lp152.2.3.1 | noarch | openSUSE:Leap:15.2:Update
       | yast2-mail | srcpackage | 4.2.3-lp152.2.3.1 | noarch | openSUSE-Leap-15.2-Update
       | yast2-mail | srcpackage | 4.2.2-lp152.1.2   | noarch | openSUSE-Leap-15.2-Source
    openSUSE Leap 15.2; KDE Plasma 5

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,797
    Blog Entries
    1

    Default Re: MailServer.pm

    Also note...
    Code:
     # rpm -q --requires yast2-mail
    /bin/sh
    /usr/bin/perl
    coreutils
    diffutils
    fillup
    grep
    rpmlib(CompressedFileNames) <= 3.0.4-1
    rpmlib(FileDigests) <= 4.6.0-1
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(PayloadIsXz) <= 5.2-1
    yast2 >= 4.0.39
    yast2-ldap
    yast2-ruby-bindings >= 1.0.0
    yast2-users
    openSUSE Leap 15.2; KDE Plasma 5

  9. #9

    Default Re: MailServer.pm

    Quote Originally Posted by deano_ferrari View Post
    Also note...
    Code:
     # rpm -q --requires yast2-mail
    /bin/sh
    /usr/bin/perl
    coreutils
    diffutils
    fillup
    grep
    rpmlib(CompressedFileNames) <= 3.0.4-1
    rpmlib(FileDigests) <= 4.6.0-1
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(PayloadIsXz) <= 5.2-1
    yast2 >= 4.0.39
    yast2-ldap
    yast2-ruby-bindings >= 1.0.0
    yast2-users

    My dear friends I have no enough time to share the detailed 4 month long work after a fuxsocy ransomware attack (without money). Don't you try it.
    I could reconstruct almost my whole working system, from more than one SuSE release. It was/is more than 10 years old.
    I am not a liar, you are very impolite.
    What I asked it was JUST only one ********** link to download an also ********** MISSING file from anybody, but, It think it was too big problem for you.
    Thanks for your fruitful enormous helping till now but I could solve the problem alone. Sorry for disturbing you.

    PS: Dear ferrari, the linked topic gave a precise, detailed description about my problem, it was totally the same. I could not have sent a better description about it. It contained that what had happened, what was the problem, how can we resolve it just the needed file was missed for me from at the end of the topic. And the system is 15.2, obviously.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •