Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: How do I request a package be built?

Hybrid View

  1. #1
    Join Date
    Jan 2016
    Location
    UK
    Posts
    758

    Default How do I request a package be built?

    I have a situation where a current package has a bug and has been fixed by the appropriate devs and an update released but as yet this has not been made available in openSUSE. The package is libgd3 and the update I believe was made some months ago. The issue is that the bug which exists in the current package prevents JPGraphs php scripts from working and this is an issue not just for me but for anyone who uses JPGraphs, so compiling it fixes it for me but not for potentially many ( perhaps 100's) of other users out there.

    So how do I ask for this package to be updated to add this fix?

    Stuart

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,700
    Blog Entries
    15

    Default Re: How do I request a package be built?

    Quote Originally Posted by broadstairs View Post
    I have a situation where a current package has a bug and has been fixed by the appropriate devs and an update released but as yet this has not been made available in openSUSE. The package is libgd3 and the update I believe was made some months ago. The issue is that the bug which exists in the current package prevents JPGraphs php scripts from working and this is an issue not just for me but for anyone who uses JPGraphs, so compiling it fixes it for me but not for potentially many ( perhaps 100's) of other users out there.

    So how do I ask for this package to be updated to add this fix?

    Stuart
    Hi
    Normally via braching and updating for Tumbleweed, for Leap backporting the fix into the current release as a maintenance update...

    Else raise a bug report for the Maintainers... openSUSE:Submitting bug reports - openSUSE
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: How do I request a package be built?

    Hello,

    I don't know libgd3 or jpgraph, but newest upstream release of libgd3 is version 2.31.
    You can find libgd3 2.31 here: https://build.opensuse.org/package/show/graphics/gd

    Have a lot of fun,
    Carsten

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: How do I request a package be built?

    Quote Originally Posted by Kieltux View Post
    Hello,

    I don't know libgd3 or jpgraph, but newest upstream release of libgd3 is version 2.31.
    You can find libgd3 2.31 here: https://build.opensuse.org/package/show/graphics/gd

    Have a lot of fun,
    Carsten
    Instead of pointing ordinary Users to an openSUSE build project,
    It's probably more useful to point them to where they can get the package using common User tools...

    From the software search site, you can install the package from the graphics repository (recommended over the private repos)

    https://software.opensuse.org/package/libgd3

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,700
    Blog Entries
    15

    Default Re: How do I request a package be built?

    Quote Originally Posted by tsu2 View Post
    Instead of pointing ordinary Users to an openSUSE build project,
    It's probably more useful to point them to where they can get the package using common User tools...

    From the software search site, you can install the package from the graphics repository (recommended over the private repos)

    https://software.opensuse.org/package/libgd3

    TSU
    Hi
    That is just a stop gap measure, like I indicated, branch and fix/update/maintenance release etc, else if unable to do this a bug report is the correct route to take.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: How do I request a package be built?

    Quote Originally Posted by malcolmlewis View Post
    Hi
    That is just a stop gap measure, like I indicated, branch and fix/update/maintenance release etc, else if unable to do this a bug report is the correct route to take.
    Are you suggesting that adding the graphics repository is not a permanent User solution?

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,700
    Blog Entries
    15

    Default Re: How do I request a package be built?

    Quote Originally Posted by tsu2 View Post
    Are you suggesting that adding the graphics repository is not a permanent User solution?

    TSU
    Hi
    Yes, because any fix will not get propagated to the Leap releases... That can only be done via a maintenance release (backporting fixes).
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: How do I request a package be built?

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Yes, because any fix will not get propagated to the Leap releases... That can only be done via a maintenance release (backporting fixes).
    My understanding is that packages from repositories supported by communities (which SUSE/openSUSE confusingly choose to call "Experimental" instead of Community) are well supported by established developers and maintainers, we are not talking about private repos.

    I don't know that this is an issue of whether LEAP maintainers choose to make a package part of the core distribution, I don't know how LEAP decides what is accepted into the OSS but I consider those decisions completely separate and according to separate and different criteria typically not related to a User's immediate need.
    This is whether packages from established communities can be considered reliable with a fairly high assurance they will work.
    Is this any different than using the Packman repository, any of the various coding language repositories or server application repositories?
    I consider all of those acceptable and permanent sources for essential apps, and none should be avoided as less trustworthy or less recommended than OSS for Users.

    IMO but open for clarification and willing to change my mind,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,700
    Blog Entries
    15

    Default Re: How do I request a package be built?

    Quote Originally Posted by tsu2 View Post
    My understanding is that packages from repositories supported by communities (which SUSE/openSUSE confusingly choose to call "Experimental" instead of Community) are well supported by established developers and maintainers, we are not talking about private repos.

    I don't know that this is an issue of whether LEAP maintainers choose to make a package part of the core distribution, I don't know how LEAP decides what is accepted into the OSS but I consider those decisions completely separate and according to separate and different criteria typically not related to a User's immediate need.
    This is whether packages from established communities can be considered reliable with a fairly high assurance they will work.
    Is this any different than using the Packman repository, any of the various coding language repositories or server application repositories?
    I consider all of those acceptable and permanent sources for essential apps, and none should be avoided as less trustworthy or less recommended than OSS for Users.

    IMO but open for clarification and willing to change my mind,
    TSU
    Hi
    Because some changes that wind up in development repositories are not backwards compatible.... or you have to hunt around for dependencies (and add more repos). Take for example gscan2pdf I'm still waiting for a dependency to arrive in Tumbleweed (since it's a leaf perl package) to push the update into Tumbleweed, missed the cut for Leap 15.3, so it will remain at the old release for ever and a day for <=leap 15.3.... So a user adds devel:languageserl to their repos to add the later gscan2pdf and starts pulling in later updates/releases of perl packages if they are not careful, which may/may not work with their system packages.....

    I don't use the Packman repository, far too invasive, have my own multimedia solution that has all the good bits to get things working.

    Unless maintainers are made aware via a bug report, nothing will happen, users will continue to struggle and potentially break there system with having non-standard repositories present.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #10

    Question Re: How do I request a package be built?

    Hi!

    I don't know I am writing in right place, but I need newest version of spacenav, numbered as 0.8. It was rewritten and supports Magellan serial 6DOF joystick natively.
    Newest version found in repos is only 0.7.1, which is unfortunately useless for me. Also, I can't make it work in Tumbleweed, when compiled from source - looks like I can't start this in proper way - maybe since there is not a standard /etc/init.d directory (source packages of spacenav contains some scripts to make installation easier).

    Are here any people, that are responsible for building packages and can help me?

    Spacenav homepage ---> http://spacenav.sourceforge.net/

    Thank you very much!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •