Results 1 to 4 of 4

Thread: KDE/Plasma: "fix" screen resolution

  1. #1

    Default KDE/Plasma: "fix" screen resolution

    Hi all,

    on my father's new pc, with a newly installed Leap 15.2, KDE/Plasma frequently "forgets" the last set screen resolution. Got the hint from #kde irc channel to set in kde system settings "Desktop session" - "always start with new/empty session". Helps a little, but not always, ~ 1 out of 10 sessions starts with 640*480 instead of FullHD.

    New PC, but at least 10+ years old monitor, so my idea is that maybe this monitor might "report" it's settings/capabilities wrong. Or "forget" to report in time, so KDE uses 640*480 as fallback. Usually not a big issue to re-set the resolution, but somewhat hard in 640*480 mode. And, most important, my father is now 82 years old ..... too much for him, as a Linux newbie

    So my question is: Is there any way to tell KDE/Plasma and/or the underlying X server that it should/must/has to use FullHD, only FullHD and nothing but FullHD, always?

    Thanks,
    Michael

  2. #2
    Join Date
    Jul 2018
    Location
    Loma Linda, Mo
    Posts
    472

    Default Re: KDE/Plasma: "fix" screen resolution

    try setting this to start on boot - it only works on X11 and not on wayland
    Code:
    llrainey@LLR1:~> cat video.sh
    # get the video name and stick it in D
    D=`xrandr --verbose | head -2 | tail -1 | awk '{print $1}'`
    # tell the Display program about the 1920 FHD settings
    /usr/bin/xrandr --newmode "1920x1080"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync 
    /usr/bin/xrandr --addmode $D 1920x1080 
    # now change the display to FHD
    /usr/bin/xrandr -s --mode 1920x1080
    # turn off screen blank
    xset -dpms s off
    llrainey@LLR1:~>
    you will have to "chmod 755 video.sh" for it to run.
    OpenSUSE 15.2 with VirtualBox VM's (XP, 10, Ubuntu MATE 20.04, OpenSUSE 15.2)
    Pi4 with Ubuntu MATE 20.04
    Unix since 1974 (pdp-11, Interdata, AT&T, Tandy, Convergent, Sun, IBM, NCR, and HP)
    Linux since 1995 (Mandrake, Redhat, Fedora, CentOS, OpenSUSE)

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,848
    Blog Entries
    1

    Default Re: KDE/Plasma: "fix" screen resolution

    First, check what display modes are offered via KDE System Settings > Display and Monitor. It should be possible to set there. Alternatively, run 'xrandr' from a terminal to see available display modes reported. If expected display modes are missing, it may be possible to add as larryr already mentioned. However, there may be a driver issue to sort. The requisite info can be got using

    Code:
    inxi -Gxx
    openSUSE Leap 15.2; KDE Plasma 5

  4. #4

    Default Re: KDE/Plasma: "fix" screen resolution

    @deano_ferrari and @larryr. Thank you very much, SOLVED


    We're getting an error for the script, and

    Code:
    /usr/bin/xrandr -s --mode 1920x1080
    results in
    Code:
    usr/bin/xrandr: failed to parse '--mode' as a number
    BUT
    Code:
    /usr/bin/xrandr -s 1920x1080
    does the job, perfectly!

    There's no need in our case to add the mode before, as it's always there - no idea why Plasma just often "forgets" the last selected mode.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •