Results 1 to 7 of 7

Thread: kmozillahelper throwing kf.kio.kdirmodel error! Can't figure out how to fix!

  1. #1

    Question kmozillahelper throwing kf.kio.kdirmodel error! Can't figure out how to fix!

    Greetings,

    In my journal entries, kmozillahelper is logging the following message over and over:

    Code:
    kf.kio.widgets.kdirmodel: No node found for item that was just removed: QUrl("file:///location/to/a/file/here")
    Was hoping I could get advice on how to remove this node and solve the error. Thanks!

  2. #2

    Default Re: kmozillahelper throwing kf.kio.kdirmodel error! Can't figure out how to fix!

    Posting permissions say I am allowed to edit my posts but I don't see any edit buttons...

    Apparently this may be a KDE thing?

    Looking at Kdirmodel specifically here https://api.kde.org/frameworks/kio/h...pp_source.html we can see where the message is thrown, #588, but this doesn't tell me a lot in how to resolve this so I no longer have it appearing in my logs, or why it even appeared in the first place.

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,011
    Blog Entries
    3

    Default Re: kmozillahelper throwing kf.kio.kdirmodel error! Can't figure out how to fix!

    I'm not seeing that message. But then I'm on Leap 15.2.

    Is it causing any problems, other than noise in the logs? If there aren't any other problems, I would just ignore it.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  4. #4

    Default Re: kmozillahelper throwing kf.kio.kdirmodel error! Can't figure out how to fix!

    Quote Originally Posted by nrickert View Post
    I'm not seeing that message. But then I'm on Leap 15.2.

    Is it causing any problems, other than noise in the logs? If there aren't any other problems, I would just ignore it.
    It is just noise in the logs, but it's on average being reported 5+ times per min... I really would prefer not to bloat my logs when something I really need to diagnose comes up. It's also the same file listed every time.

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,011
    Blog Entries
    3

    Default Re: kmozillahelper throwing kf.kio.kdirmodel error! Can't figure out how to fix!

    Once upon a time, these messages used to go to ".xsession-errors" in the user home directory. And we would never bother to look at that file, unless we were investigating a particular problem.

    So now someone has come up with the brilliant idea of actually writing these to logs. I preferred the old way of handling it.

    If you switch to using "lightdm" as your display manager (to handle login), then some of those kinds of messages will go to ".xsession-errors" (unless they have recently changed that). But some of the change to put these in logs is due to the Plasma software itself, rather than to how the Xsession is initiated. I can't guess which applies in the case of the message you are seeing.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  6. #6

    Default Re: kmozillahelper throwing kf.kio.kdirmodel error! Can't figure out how to fix!

    There is a "kmozillahelper-debuginfo" package I could install, but I can't find any information on how to use it.

    For now, my temporary solution is to just remove the kmozillahelper package. I mean, it's probably not doing too much that I would consider "essential" to my experience with Firefox and KDE combined.


  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,011
    Blog Entries
    3

    Default Re: kmozillahelper throwing kf.kio.kdirmodel error! Can't figure out how to fix!

    That sounds reasonable.

    When I last looked at the description of "kmozillahelper" it did not seem to be doing anything that mattered to me.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •