Hi
The hypre-devel package is for the serial version of Hypre, I'm assuming this is not your requirement.... you need to use the other repective version and development packages....