Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Plasma Mouse wheel scrolling speed?​

  1. #1

    Default Plasma Mouse wheel scrolling speed?​

    Where can i set this?
    "System settings -> Input -> Mouse" is not helpful.

    Anyone?

    thanks!

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,114

    Default Re: Plasma Mouse wheel scrolling speed?​

    It appears that this option was dropped in 15.2. In 15.1 you could find it in System settings -> Input -> Mouse -> Advanced tab -> Mouse will Scrolls -> [number of lines].

    This changes file ~/.config/kdeglobals entry WheelScrollLines value under [KDE].

    *But* this line is still there in 15.2, set to 3. So perhaps if you edit this file?

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,997
    Blog Entries
    1

    Default Re: Plasma Mouse wheel scrolling speed?​

    Quote Originally Posted by brunomcl View Post
    It appears that this option was dropped in 15.2. In 15.1 you could find it in System settings -> Input -> Mouse -> Advanced tab -> Mouse will Scrolls -> [number of lines].

    This changes file ~/.config/kdeglobals entry WheelScrollLines value under [KDE].

    *But* this line is still there in 15.2, set to 3. So perhaps if you edit this file?
    I don't have such an entry. Are you sure that you just don't have a "legacy" config?
    openSUSE Leap 15.2; KDE Plasma 5

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,997
    Blog Entries
    1

    Default Re: Plasma Mouse wheel scrolling speed?​

    Just in case this KDE thread is of interest...
    https://forum.kde.org/viewtopic.php?f=309&t=160416

    This reddit thread may also be of interest...
    https://www.reddit.com/r/kde/comment..._scroll_speed/
    Perhaps using the synaptics Xorg driver is an acceptable workaround in this situation?
    openSUSE Leap 15.2; KDE Plasma 5

  5. #5
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,114

    Default Re: Plasma Mouse wheel scrolling speed?​

    Quote Originally Posted by deano_ferrari View Post
    I don't have such an entry. Are you sure that you just don't have a "legacy" config?
    Maybe. This was an upgrade from 15.1 to 15.2.

    This is the KDE section:

    Code:
    [KDE] 
    AnimationDurationFactor=0.500000 
    ColorScheme=Breeze 
    DoubleClickInterval=400 
    ShowDeleteCommand=false 
    ShowIconsInMenuItems=true 
    ShowIconsOnPushButtons=true 
    SingleClick=true 
    StartDragDist=4 
    StartDragTime=500 
    WheelScrollLines=3 
    contrast=4 
    widgetStyle=fusion
    Oh, and if I change that 3 to 6 and restart the session, scrolling in kate goes twice as fast. So I suppose it works...

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,997
    Blog Entries
    1

    Default Re: Plasma Mouse wheel scrolling speed?​

    Quote Originally Posted by brunomcl View Post
    Maybe. This was an upgrade from 15.1 to 15.2.

    This is the KDE section:

    Code:
    [KDE] 
    AnimationDurationFactor=0.500000 
    ColorScheme=Breeze 
    DoubleClickInterval=400 
    ShowDeleteCommand=false 
    ShowIconsInMenuItems=true 
    ShowIconsOnPushButtons=true 
    SingleClick=true 
    StartDragDist=4 
    StartDragTime=500 
    WheelScrollLines=3 
    contrast=4 
    widgetStyle=fusion
    Oh, and if I change that 3 to 6 and restart the session, scrolling in kate goes twice as fast. So I suppose it works...
    Ok, good to know. FWIW, I'm using the KDE repos, so I have
    Code:
    Operating System: openSUSE Leap 15.2
    KDE Plasma Version: 5.20.90
    KDE Frameworks Version: 5.79.0
    Qt Version: 5.15.2
    openSUSE Leap 15.2; KDE Plasma 5

  7. #7

    Default Re: Plasma Mouse wheel scrolling speed?​

    Thanks so far.

    This does not work on my side. I have Leap 15.2 stock KDE.
    Adding WheelScrollLines=6 is not helpful.

    But
    As this quoted KDE bug below mentions, libinput is the culprit.
    Commenting out the first section (MatchIsPointer "on") in /etc/X11/xorg.conf.d/40-libinput.conf disabled libinput support for the mouse and then automatically "evdev" is used.

    The Mouse settings in KDE are now more featureful.


    Quote Originally Posted by brunomcl View Post
    Maybe. This was an upgrade from 15.1 to 15.2.

    This is the KDE section:

    Code:
    [KDE] 
    AnimationDurationFactor=0.500000 
    ColorScheme=Breeze 
    DoubleClickInterval=400 
    ShowDeleteCommand=false 
    ShowIconsInMenuItems=true 
    ShowIconsOnPushButtons=true 
    SingleClick=true 
    StartDragDist=4 
    StartDragTime=500 
    WheelScrollLines=3 
    contrast=4 
    widgetStyle=fusion
    Oh, and if I change that 3 to 6 and restart the session, scrolling in kate goes twice as fast. So I suppose it works...

  8. #8

    Default Re: Plasma Mouse wheel scrolling speed?​

    Another one is the sloooooowwwww scrolling speed in Firefox....
    Even after increasing the KDE mouse wheel scroll lines to 12 (maximum) Firefox scroll speed is terribly slow.

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,997
    Blog Entries
    1

    Default Re: Plasma Mouse wheel scrolling speed?​

    Quote Originally Posted by thalunil View Post
    Another one is the sloooooowwwww scrolling speed in Firefox....
    Even after increasing the KDE mouse wheel scroll lines to 12 (maximum) Firefox scroll speed is terribly slow.
    For Firefox: Open a tab and type "about:config", then search for "mousewheel.min_line_scroll_amount", change the numerical value to suit.
    openSUSE Leap 15.2; KDE Plasma 5

  10. #10

    Default Re: Plasma Mouse wheel scrolling speed?​

    Quote Originally Posted by deano_ferrari View Post
    For Firefox: Open a tab and type "about:config", then search for "mousewheel.min_line_scroll_amount", change the numerical value to suit.
    thanks - this improved it alot!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •