Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Switch system packages to Packman doesn't help

  1. #1

    Default Switch system packages to Packman doesn't help

    Hi,
    my video files doesn't play with dragon, gwenview etc. I add Packman repo, switch system packages to Packman's but no success.
    Code:
     tom@DuoCore:~> LANG=C zypper lr -d#  | Alias                                      | Name                                       | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                      | Service
    ---+--------------------------------------------+--------------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------+--------
     1 | packman.inode.at-openSUSE_Leap_$releasever | Packman Repository                         | Yes     | (r ) Yes  | Yes     |   98     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.2/                         | 
     2 | repo-debug                                 | Debug Repository                           | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.2/repo/oss/      | 
     3 | repo-debug-non-oss                         | Debug Repository (Non-OSS)                 | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.2/repo/non-oss/  | 
     4 | repo-debug-update                          | Update Repository (Debug)                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.2/oss/                 | 
     5 | repo-debug-update-non-oss                  | Update Repository (Debug, Non-OSS)         | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.2/non-oss/             | 
     6 | repo-non-oss                               | Non-OSS repozitář                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/non-oss/        | 
     7 | repo-oss                                   | Hlavní repozitář                           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/oss/            | 
     8 | repo-source                                | Source Repository                          | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.2/repo/oss/     | 
     9 | repo-source-non-oss                        | Source Repository (Non-OSS)                | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.2/repo/non-oss/ | 
    10 | repo-update                                | Hlavní aktualizační repozitář              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.2/oss                        | 
    11 | repo-update-non-oss                        | Aktualizační repozitář (uzavřený software) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.2/non-oss/                   | 
    12 | teamviewer                                 | TeamViewer - x86_64                        | Yes     | (r ) Yes  | No      |   99     | rpm-md | https://linux.teamviewer.com/yum/stable/main/binary-x86_64/              |
    At first I used graphical Yast, later I tried Konsole with command I found on forum.
    Code:
     sudo zypper dup --from "Packman Repository" --allow-vendor-change
    What did I do wrong? Can you give me some advice, please?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    28,285

    Default Re: Switch system packages to Packman doesn't help

    I do not think you did anything wrong. Did the switch install packages or not?
    Henk van Velden

  3. #3
    Join Date
    Jul 2018
    Location
    Loma Linda, Mo
    Posts
    472

    Default Re: Switch system packages to Packman doesn't help

    packman he point to is not same as mine
    Code:
    VM1:~ # zypper lr  -d
    #  | Alias                | Name                              | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                              | Service
    ---+----------------------+-----------------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------------------------+--------
     1 | Packman              | Packman 15.2 Repository           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.2                | 
    
    Lines Delete
    
    VM1:/etc/zypp/repos.d # cat packman.repo
    [Packman]
    name=Packman $releasever Repository
    enabled=1
    autorefresh=1
    baseurl=http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_$releasever
    type=rpm-md
    keeppackages=0
    VM1:/etc/zypp/repos.d #
    OpenSUSE 15.2 with VirtualBox VM's (XP, 10, Ubuntu MATE 20.04, OpenSUSE 15.2)
    Pi4 with Ubuntu MATE 20.04
    Unix since 1974 (pdp-11, Interdata, AT&T, Tandy, Convergent, Sun, IBM, NCR, and HP)
    Linux since 1995 (Mandrake, Redhat, Fedora, CentOS, OpenSUSE)

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,997
    Blog Entries
    3

    Default Re: Switch system packages to Packman doesn't help

    Quote Originally Posted by larryr View Post
    packman he point to is not same as mine
    It shouldn't matter. There are several packman mirrors. You are just using a different mirror. You should be seeing the same packages.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  5. #5

    Default Re: Switch system packages to Packman doesn't help

    Quote Originally Posted by hcvv View Post
    I do not think you did anything wrong. Did the switch install packages or not?
    Yes, some. I can't remember exactly.

    IMHO, may be I caused problem with Game repos I added before. Now I both game repositories erased, but video does't work. One more strange things exist. When I look to Yast, It looks like I didn't switch package to packman version, no change there.

    http://pepa254.sweb.cz/obrazky/index.html


  6. #6
    Join Date
    Mar 2020
    Location
    São Leopoldo, RS, Brazil
    Posts
    290

    Default Re: Switch system packages to Packman doesn't help

    Some people prefer to use "opi" to install codecs:

    Code:
    zypper in opi
    opi codecs
    Or else, install these media players in flatpak format.
    openSUSE Tumbleweed

  7. #7

    Default Re: Switch system packages to Packman doesn't help

    Quote Originally Posted by nrickert View Post
    It shouldn't matter. There are several packman mirrors. You are just using a different mirror. You should be seeing the same packages.
    You are right, I tried removed my Packman repo, make update and added new one that larryr has. Than I switch again. Problem remains

    Packages which were added: http://pepa254.sweb.cz/obrazky/index.html

  8. #8

    Default Re: Switch system packages to Packman doesn't help

    Quote Originally Posted by awerlang View Post
    Some people prefer to use "opi" to install codecs:

    Code:
    zypper in opi
    opi codecs
    Or else, install these media players in flatpak format.
    Well, it works! Idon't know what I actually did, but it works. I used "opi", 32 packages was installed. It is all.
    Thank you all!

  9. #9

    Default Re: Switch system packages to Packman doesn't help

    Quote Originally Posted by makradenk View Post
    Well, it works! Idon't know what I actually did, but it works. I used "opi", 32 packages was installed. It is all.
    Thank you all!
    I quite wonder, why usual way of switching and using codecs from Packman repo didn't work. What actually is "opi" and what it does another way that all codecs was installed than.

    Packages installed with opi, img_3:
    http://pepa254.sweb.cz/obrazky/index.html

  10. #10
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,558

    Default AW: Switch system packages to Packman doesn't help

    I quite wonder, why usual way of switching and using codecs from Packman repo didn't work. What actually is "opi" and what it does another way that all codecs was installed than.
    Only installed packages will do an vendor change.

    If you need a codec with licences (h264 f.e) you have to install this codec expilizt because openSUSE does not have it in their repos:
    Code:
    zypper se -s h264
    Loading repository data...
    Reading installed packages...
    
    S  | Name                    | Type       | Version          | Arch   | Repository
    ---+-------------------------+------------+------------------+--------+-----------
       | h264enc                 | package    | 10.4.7-pm152.3.3 | noarch | packman
       | h264enc                 | package    | 10.4.7-pm152.3.1 | noarch | packman
       | h264enc                 | srcpackage | 10.4.7-pm152.3.3 | noarch | packman
       | h264enc                 | srcpackage | 10.4.7-pm152.3.1 | noarch | packman
    i+ | libopenh264-6           | package    | 2.1.1-pm152.1.2  | x86_64 | packman
       | libopenh264-6-debuginfo | package    | 2.1.1-pm152.1.2  | x86_64 | packman
       | openh264                | srcpackage | 2.1.1-pm152.1.2  | noarch | packman
       | openh264                | srcpackage | 2.1.1-pm152.1.1  | noarch | packman
       | openh264-debugsource    | package    | 2.1.1-pm152.1.2  | x86_64 | packman
       | openh264-devel          | package    | 2.1.1-pm152.1.2  | x86_64 | packman

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •