Results 1 to 3 of 3

Thread: Nvidia Proprietary Drivers(460.39) Causing the System to Hang on Log Out?

  1. #1

    Post Nvidia Proprietary Drivers(460.39) Causing the System to Hang on Log Out?

    Hello everyone, I've recently installed openSUSE Leap 15.2 with GNOME and I'm really liking it, I got all my IDES, drivers and software set up nicely.
    But there is an issue I've noticed when logging out of GNOME. If i log out(not shutdown, lock, or restart) of GNOME my system's screen goes black
    and is generally unusable from there(CTRL+ALT+F1 does not give me a bash prompt).
    It doesn't bother me much as I'm the only user on the PC and I never really need to logout, but has anyone had this issue with Nvidia's proprietary drivers? I'm guessing that's where the issue lies.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,479
    Blog Entries
    15

    Default Re: Nvidia Proprietary Drivers(460.39) Causing the System to Hang on Log Out?

    Quote Originally Posted by markmental666 View Post
    Hello everyone, I've recently installed openSUSE Leap 15.2 with GNOME and I'm really liking it, I got all my IDES, drivers and software set up nicely.
    But there is an issue I've noticed when logging out of GNOME. If i log out(not shutdown, lock, or restart) of GNOME my system's screen goes black
    and is generally unusable from there(CTRL+ALT+F1 does not give me a bash prompt).
    It doesn't bother me much as I'm the only user on the PC and I never really need to logout, but has anyone had this issue with Nvidia's proprietary drivers? I'm guessing that's where the issue lies.
    Hi and welcome to the Forum
    Are you running Wayland or Xorg? Likely need to configure /etc/gdm/custom.conf, there is a line to un-rem to ensure GDM uses Xorg....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Nvidia Proprietary Drivers(460.39) Causing the System to Hang on Log Out?

    Quote Originally Posted by malcolmlewis View Post
    Hi and welcome to the Forum
    Are you running Wayland or Xorg? Likely need to configure /etc/gdm/custom.conf, there is a line to un-rem to ensure GDM uses Xorg....
    Thanks for the warm welcome (: I'm running Xorg. After editing the /etc/gdm/custom.conf file to uncomment the line "WaylandEnable=false",
    logging out works without a hitch. Thanks for the help!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •