Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Zoom dependent on libstvideo-1.0.so which isn't found

Hybrid View

  1. #1
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    342

    Default Zoom dependent on libstvideo-1.0.so which isn't found

    Zoom didn't work yesterday after on-line updates since 27 Jan 2021 (last date I used Zoom). Re-installed Zoom, but Zoom now fails to load (it seems to start, with additional icons appearing in panel, but then they vanish).
    Checked dependency requirements (per Zoom web site) and found almost all files installed, but not libstvideo-1.0.so which isn't showing up in Yast search. I'm looking in all categories, not just "name" and "RPM supplies."
    Oddly, libstvideo appeared briefly after my first search, but not any more. Also looked at list of all files in Main, non-OSS, and Packman repos and didn't see libstvideo.
    Found the libstvideo file at pkgs.org, with one version specifically for openSuse 15.2, but have never used that site. Is it safe? Why is this file not found on openSuse repos?
    Thanks in advance for hints and suggestions.
    Leap/KDE and a film-based photographer

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,486

    Default AW: Zoom dependent on libstvideo-1.0.so which isn't found

    Can you share the zoom-side, where the requirements are listet?

  3. #3
    Join Date
    Sep 2012
    Posts
    6,836

    Default Re: Zoom dependent on libstvideo-1.0.so which isn't found

    Quote Originally Posted by konsultor View Post
    libstvideo
    Are you sure? In the requirements list on Zoom site I see libgstvideo which is part of gstreamer-plugins-base, although support article lists ancient version 0.10 while openSUSE comes with version 1.0.

    It would be more productive if you posted link to requirements on Zoom site that you are using.

  4. #4
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    342

    Default Re: Zoom dependent on libstvideo-1.0.so which isn't found

    The page on Zoom where I found the list is
    https://support.zoom.us/hc/en-us/articles/201362003
    There is a HELP tab (lower right). It opens to a list of top topics. The first entry when I found it was Installing or updating Zoom on Linux.
    Scroll down to the list of dependencies specifically for openSuse:

    64-bit
    ld-linux-x86-64.so.2()(64bit)
    libc.so.6()(64bit)
    libX11.so.6()(64bit)
    libXfixes.so.3()(64bit)
    libglib-2.0.so.0()(64bit)
    libGL.so.1()(64bit)
    libsqlite3.so.0()(64bit)
    libXrender.so.1()(64bit)
    libXcomposite.so.1()(64bit)
    libQt3Support.so.4()(64bit)
    libxslt.so.1()(64bit)
    libgstvideo-0.10.so.0()(64bit)
    libasound.so.2()(64bit)
    libpulse.so.0()(64bit)
    libgthread-2.0.so.0()(64bit)
    libxcb-shape.so.0()(64bit)
    libxcb-shm.so.0()(64bit)
    libxcb-randr.so.0()(64bit)
    libxcb-image.so.0()(64bit)
    libxcb-xtest.so.0()(64bit)
    libxcb-keysyms.so.1()(64bit)
    libudev.so.1
    libgobject-2_0-0
    libgstapp-0_10-0
    libgstinterfaces-0_10-0
    libXi6
    libSM6
    libdbus-1-3
    libasound2
    Leap/KDE and a film-based photographer

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,486

    Default AW: Zoom dependent on libstvideo-1.0.so which isn't found

    libstvideo-1.0.so
    Is not in the list as posted by arvidjaar

    Downloaded, installed and opened it and it works without problems.

    Do you install the last version of zoom?

    Run it as user in an terminal/konsole:
    Code:
    zoom
    Post your Repolist:
    Code:
    zypper lr -d
    Please use Code-Tags:
    https://forums.opensuse.org/showthre...und-Your-Paste
    Last edited by Sauerland; 01-Feb-2021 at 12:20.

  6. #6
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    342

    Default Re: AW: Zoom dependent on libstvideo-1.0.so which isn't found

    Quote Originally Posted by Sauerland View Post
    Is not in the list as posted by arvidjaar
    My error; cut and pasted wrong file name. Zoom lists libstvideo-0.1, not libstvideo-1.0
    Leap/KDE and a film-based photographer

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,486

    Default AW: Re: AW: Zoom dependent on libstvideo-1.0.so which isn't found

    Quote Originally Posted by konsultor View Post
    My error; cut and pasted wrong file name. Zoom lists libstvideo-0.1, not libstvideo-1.0
    64-bit
    ld-linux-x86-64.so.2()(64bit)
    libc.so.6()(64bit)
    libX11.so.6()(64bit)
    libXfixes.so.3()(64bit)
    libglib-2.0.so.0()(64bit)
    libGL.so.1()(64bit)
    libsqlite3.so.0()(64bit)
    libXrender.so.1()(64bit)
    libXcomposite.so.1()(64bit)
    libQt3Support.so.4()(64bit)
    libxslt.so.1()(64bit)
    libgstvideo-0.10.so.0()(64bit)
    libasound.so.2()(64bit)
    libpulse.so.0()(64bit)
    libgthread-2.0.so.0()(64bit)
    libxcb-shape.so.0()(64bit)
    libxcb-shm.so.0()(64bit)
    libxcb-randr.so.0()(64bit)
    libxcb-image.so.0()(64bit)
    libxcb-xtest.so.0()(64bit)
    libxcb-keysyms.so.1()(64bit)
    libudev.so.1
    libgobject-2_0-0
    libgstapp-0_10-0
    libgstinterfaces-0_10-0
    libXi6
    libSM6
    libdbus-1-3
    libasound2
    I do not see any of the libs you mentioned....

    Do you download the last zoom Version and install it?

  8. #8
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    342

    Default Re: Zoom dependent on libstvideo-1.0.so which isn't found

    Apologies.
    If only I could type accurately, or read better... I left out the g in the file name: libgstvideo so of course I couldn't find it again until I corrected my error (which persists in the title of this post). The -1.0 version of the file is installed.
    However, Zoom still doesn't load, from the icon in the panel or from the CLI. The problem is something other than a missing libgstvideo. Any ideas? Is the version of this file the problem?
    Thanks again.
    Leap/KDE and a film-based photographer

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,486

    Default AW: Re: Zoom dependent on libstvideo-1.0.so which isn't found

    Quote Originally Posted by konsultor View Post
    Apologies.
    If only I could type accurately, or read better... I left out the g in the file name: libgstvideo so of course I couldn't find it again until I corrected my error (which persists in the title of this post). The -1.0 version of the file is installed.
    However, Zoom still doesn't load, from the icon in the panel or from the CLI. The problem is something other than a missing libgstvideo. Any ideas? Is the version of this file the problem?
    Thanks again.
    As I said, I have downloaded the 64 bit rpm for openSUSE and installed it, I get:



    So have you all dependencies installed?
    Do you install the latest version of zoom?

  10. #10
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,486

    Default AW: Zoom dependent on libstvideo-1.0.so which isn't found

    Please post
    Code:
    ldd /opt/zoom/zoom

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •