Results 1 to 8 of 8

Thread: How to upgrade glibc-2.26 to glibc-2.27

  1. #1

    Default How to upgrade glibc-2.26 to glibc-2.27

    I have several glibc packages installed from "Main Repo" but I need glibc-2.27 for 'memfd_create' function; which is available in glibc-2.27.

    Code:
    [Fri Jan 29 03:58:21 root@suse /home/flux/.local/src] 
    # zypper se -s glibc | grep ^i
    i+ | glibc                    | package    | 2.26-lp152.26.3.1 | x86_64 | openSUSE:Leap:15.2:Update
    i+ | glibc                    | package    | 2.26-lp152.26.3.1 | x86_64 | Main Update Repository
    i+ | glibc-32bit              | package    | 2.26-lp152.26.3.1 | x86_64 | openSUSE:Leap:15.2:Update
    i+ | glibc-32bit              | package    | 2.26-lp152.26.3.1 | x86_64 | Main Update Repository
    i+ | glibc-devel              | package    | 2.26-lp152.26.3.1 | x86_64 | openSUSE:Leap:15.2:Update
    i+ | glibc-devel              | package    | 2.26-lp152.26.3.1 | x86_64 | Main Update Repository
    i+ | glibc-devel-32bit        | package    | 2.26-lp152.26.3.1 | x86_64 | openSUSE:Leap:15.2:Update
    i+ | glibc-devel-32bit        | package    | 2.26-lp152.26.3.1 | x86_64 | Main Update Repository
    i+ | glibc-extra              | package    | 2.26-lp152.26.3.1 | x86_64 | openSUSE:Leap:15.2:Update
    i+ | glibc-extra              | package    | 2.26-lp152.26.3.1 | x86_64 | Main Update Repository
    i+ | glibc-info               | package    | 2.26-lp152.26.3.1 | noarch | openSUSE:Leap:15.2:Update
    i+ | glibc-info               | package    | 2.26-lp152.26.3.1 | noarch | Main Update Repository
    i+ | glibc-locale             | package    | 2.26-lp152.26.3.1 | x86_64 | openSUSE:Leap:15.2:Update
    i+ | glibc-locale             | package    | 2.26-lp152.26.3.1 | x86_64 | Main Update Repository
    i+ | glibc-locale-base        | package    | 2.26-lp152.26.3.1 | x86_64 | openSUSE:Leap:15.2:Update
    i+ | glibc-locale-base        | package    | 2.26-lp152.26.3.1 | x86_64 | Main Update Repository
    i+ | glibc-locale-base-32bit  | package    | 2.26-lp152.26.3.1 | x86_64 | openSUSE:Leap:15.2:Update
    i+ | glibc-locale-base-32bit  | package    | 2.26-lp152.26.3.1 | x86_64 | Main Update Repository
    i+ | linux-glibc-devel        | package    | 5.3-lp152.1.1     | x86_64 | Main Repository
    I can compile and install glibc and use `patchelf --set-interpreter` but I will prefer a reliable solution if any. The package is available from a different repo, tried installing it but it will break the system. I wish the openSUSE devel upgrade systemd* to at least 240+ and glibc to 2.32 in future releases. Tumbleweed is not an option for me (I've it on my laptop but I don't want to keep updating my workstation frequently and reboot it often).

  2. #2
    Join Date
    Sep 2012
    Posts
    6,950

    Default Re: How to upgrade glibc-2.26 to glibc-2.27

    Quote Originally Posted by coldboot View Post
    I wish the openSUSE devel upgrade systemd* to at least 240+ and glibc to 2.32 in future releases.
    Leap 15.3 comes with systemd 246 and gblic 2.31.

  3. #3

    Default Re: How to upgrade glibc-2.26 to glibc-2.27

    Quote Originally Posted by arvidjaar View Post
    Leap 15.3 comes with systemd 246 and gblic 2.31.
    Thank you.

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,625

    Default AW: How to upgrade glibc-2.26 to glibc-2.27

    https://bugzilla.opensuse.org/show_bug.cgi?id=1173734

    openSUSE will stay on the versions shipped when an openSUSE Version is published

  5. #5

    Default Re: AW: How to upgrade glibc-2.26 to glibc-2.27

    Quote Originally Posted by Sauerland View Post
    https://bugzilla.opensuse.org/show_bug.cgi?id=1173734

    openSUSE will stay on the versions shipped when an openSUSE Version is published
    Figured.. I will use LD_LIBRARY_PATH for now.

  6. #6

    Default Re: AW: How to upgrade glibc-2.26 to glibc-2.27

    Quote Originally Posted by coldboot View Post
    Figured.. I will use LD_LIBRARY_PATH for now.
    LD_LIBRARY_PATH or LD_PRELOAD?
    https://bugzilla.opensuse.org/show_bug.cgi?id=1163301

  7. #7

    Default Re: How to upgrade glibc-2.26 to glibc-2.27

    `LD_PRELOAD` points to particular libraries and it has the highest priority during runtime library loading.

  8. #8
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: How to upgrade glibc-2.26 to glibc-2.27

    glibc 2.27 is available for LEAP 15.2, provided by a private repo

    https://software.opensuse.org/package/glibc

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •