Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: USB wifi not recognized

  1. #1
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,541

    Default USB wifi not recognized

    Bought another USB wifi device. When I invoke
    Code:
    sudo lsusb
    the device a tp-link WN8200ND(UN) v2.20 does not show. Running Ubuntu it is identified as
    Code:
    Bus 005 Device 003: ID 2357:0126 TP-Link 802.11n NIC
    and works normally. Where do I start to diagnose the problem?

  2. #2
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,541

    Default Re: USB wifi not recognized

    Correction. It shows as follows;-
    Code:
    Bus 005 Device 003: ID 2357:0126
    ...with no further information.

  3. #3
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,541

    Default Re: USB wifi not recognized

    More information. I read somewhere that the driver rtl8192eu applied to it. This was already in place from the previous device used. But I think that is the problem. My wired connection via cable is not available so I can´t download anything.

    Code:
    sudo hwinfo --wlan
    
    
    Hardware Class: network
      Model: "TP-Link 802.11n NIC"
      Hotplug: USB
      Vendor: usb 0x2357 "TP-Link"
      Device: usb 0x0126 "802.11n NIC"
      Revision: "2.00"
      Serial ID: "D03745C1A08B"
      Driver: "rtl8192eu"
      Driver Modules: "8192eu"
      Device File: wlan1
      Features: WLAN
      Speed: 480 Mbps
      HW Address: d0:37:45:c1:a0:8b
      Permanent HW Address: d0:37:45:c1:a0:8b
      Link detected: yes

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,617
    Blog Entries
    1

    Default Re: USB wifi not recognized

    Quote Originally Posted by ionmich View Post
    More information. I read somewhere that the driver rtl8192eu applied to it. This was already in place from the previous device used. But I think that is the problem. My wired connection via cable is not available so I can´t download anything.

    Code:
    sudo hwinfo --wlan
    
    
    Hardware Class: network
      Model: "TP-Link 802.11n NIC"
      Hotplug: USB
      Vendor: usb 0x2357 "TP-Link"
      Device: usb 0x0126 "802.11n NIC"
      Revision: "2.00"
      Serial ID: "D03745C1A08B"
      Driver: "rtl8192eu"
      Driver Modules: "8192eu"
      Device File: wlan1
      Features: WLAN
      Speed: 480 Mbps
      HW Address: d0:37:45:c1:a0:8b
      Permanent HW Address: d0:37:45:c1:a0:8b
      Link detected: yes
    So what is the issue here? The output you've shared shows that driver is loaded and device node "wlan1" exists.
    openSUSE Leap 15.2; KDE Plasma 5

  5. #5
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,541

    Default Re: USB wifi not recognized

    Quote Originally Posted by deano_ferrari View Post
    So what is the issue here? The output you've shared shows that driver is loaded and device node "wlan1" exists.
    It connects to my destination, then disconnects after a very short time, under two minutes, and will not reconnect. When I reboot it repeats. Yet if I boot Ubuntu, it stays connected to the same destination.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,617
    Blog Entries
    1

    Default Re: USB wifi not recognized

    Quote Originally Posted by ionmich View Post
    It connects to my destination, then disconnects after a very short time, under two minutes, and will not reconnect. When I reboot it repeats. Yet if I boot Ubuntu, it stays connected to the same destination.
    Ok, this detail was missing in your opening post.

    If using NetworkManager, you could observe the logging in real-time using
    Code:
    sudo journalctl -fu NetworkManager
    then you could come back with output at the time the wifi disconnects for example.

    USB power management issue perhaps? You could try inhibiting (globally) by adding 'usbcore.autosuspend=-1' to the grub kernel parameters and see whether that helpls (assuming that is the issue being encountered of course).

    http://www.boomerangsworld.de/cms/bl...019-01-02.html
    Last edited by deano_ferrari; 23-Jan-2021 at 21:12.
    openSUSE Leap 15.2; KDE Plasma 5

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,319

    Default AW: USB wifi not recognized

    Please post:
    Code:
    zypper se -si rtl8192 kernel
    Code:
    uname -a
    Does it work if you start with an older kernel?

  8. #8
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,541

    Default Re: AW: USB wifi not recognized

    Quote Originally Posted by Sauerland View Post
    Please post:
    Code:
    zypper se -si rtl8192 kernel
    Code:
    uname -a
    Does it work if you start with an older kernel?
    Code:
     ~> sudo zypper se -si rtl8192 kernel
    Loading repository data...
    Reading installed packages...
    
    S  | Name                         | Type    | Version                                      | Arch   | Repository
    ---+------------------------------+---------+----------------------------------------------+--------+-----------------------
    i+ | kernel-default               | package | 5.3.18-lp152.57.1                            | x86_64 | Main Update Repository
    i+ | kernel-default               | package | 5.3.18-lp152.50.1                            | x86_64 | Main Update Repository
    i+ | kernel-firmware              | package | 20200107-lp152.2.3.1                         | noarch | Main Update Repository
    i+ | purge-kernels-service        | package | 0-lp152.4.1                                  | noarch | openSUSE-Leap-15.2-1
    i+ | purge-kernels-service        | package | 0-lp152.4.1                                  | noarch | Main Repository
    i+ | rtl8192eu-blacklist-rtl8xxxu | package | 5.6.4.git20201218-lp152.3.1                  | x86_64 | (System Packages)
    i+ | rtl8192eu-kmp-default        | package | 5.6.4_k5.3.18_lp152.47-lp152.27.1            | x86_64 | (System Packages)
    i+ | rtl8192eu-kmp-default        | package | 5.6.4_k5.3.18_lp152.44-lp152.23.3            | x86_64 | (System Packages)
    i+ | rtl8192eu-kmp-default        | package | 5.6.4_k5.3.18_lp152.41-lp152.21.7            | x86_64 | (System Packages)
    i+ | rtl8192eu-kmp-default        | package | 5.6.4_k5.3.18_lp152.36-lp152.21.4            | x86_64 | (System Packages)
    i+ | rtl8192eu-kmp-default        | package | 5.6.4.git20201218_k5.3.18_lp152.57-lp152.3.1 | x86_64 | (System Packages)
    i+ | rtl8192eu-kmp-default        | package | 5.6.4.git20201218_k5.3.18_lp152.19-lp152.3.1 | x86_64 | (System Packages)
    i+ | rtl8192eu-kmp-default        | package | 5.6.4.git20201115_k5.3.18_lp152.50-lp152.2.2 | x86_64 | (System Packages)
    ion@localhost:~>
    What does this output actually tell me? YaST tells me rtl8192eu-blacklist-rtl8xxxu | package | 5.6.4.git20201218-lp152.3.1 and rtl8192eu-kmp-default| package | 5.6.4_k5.3.18_lp152.47-lp152.27.1 are the ones installed.

    Code:
     :~> uname -a
    Linux localhost.localdomain 5.3.18-lp152.57-default #1 SMP Fri Dec 4 07:27:58 UTC 2020 (7be5551) x86_64 x86_64 x86_64 GNU/Linux
    ion@localhost:~>
    I haven't tried an older kernel...yet. It's my last resort as I have had problems with other applications at times. I might be more inclined to using Ubuntu, which works with it, when my wired connection stops working. This is a somewhat frequent interruption in my part of Mexico. It's not the end of the world if I can't get it to work. I would just like to understand why.

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,319

    Default AW: USB wifi not recognized

    Please post:
    Code:
    zypper lr -d
    and as root:
    Code:
    journalctl -b | grep -Ei 'wifi|wlan|8192|rtl|realtek'
    Last edited by Sauerland; 24-Jan-2021 at 10:51.

  10. #10
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,541

    Default Re: AW: USB wifi not recognized

    Quote Originally Posted by Sauerland View Post
    Please post:
    Code:
    zypper lr -d
    and as root:
    Code:
    journalctl -b | grep -Ei 'wifi|wlan|8192|rtl|realtek'
    Code:
     # zypper lr -d#  | Alias                | Name                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                             | Service
    ---+----------------------+-----------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------------------------------+--------
     1 | Sauerland-update     | Sauerland-update            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/home:/Sauerland:/hardware/openSUSE_Leap_15.2_Update/ | 
     2 | brave-browser        | brave-browser               | Yes     | (r ) Yes  | No      |   99     | rpm-md | https://brave-browser-rpm-release.s3.brave.com/x86_64/                                          | 
     3 | dvd                  | dvd                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.2/                                              | 
     4 | openSUSE-Leap-15.2-1 | openSUSE-Leap-15.2-1        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/oss/                                   | 
     5 | packman              | packman                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.2/                                                | 
     6 | repo-non-oss         | Non-OSS Repository          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/non-oss/                               | 
     7 | repo-oss             | Main Repository             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/oss/                                  | 
     8 | repo-update          | Main Update Repository      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.2/oss                                               | 
     9 | repo-update-non-oss  | Update Repository (Non-Oss) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.2/non-oss/                                          | 
    10 | skype-stable         | skype (stable)              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://repo.skype.com/rpm/stable/                                                              | 
    11 | vivaldi              | vivaldi                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://repo.vivaldi.com/archive/rpm/x86_64                                                     | 
    localhost:/home/ion #
    The output from the second command was too long so I split it into a second post.

    Code:
     localhost:/home/ion # journalctl -b | grep -Ei 'wifi|wlan|8192|rtl|realtek'Jan 24 15:43:11 localhost kernel: percpu: Embedded 57 pages/cpu s196608 r8192 d28672 u524288
    Jan 24 15:43:11 localhost kernel: pcpu-alloc: s196608 r8192 d28672 u524288 alloc=1*2097152
    Jan 24 15:43:12 localhost kernel: r8168  Copyright (C) 2020  Realtek NIC software team <nicfae@realtek.com> 
    Jan 24 15:43:12 localhost kernel: usb 4-2: Manufacturer: Realtek
    Jan 24 15:43:13 localhost kernel: usbcore: registered new interface driver rtl8192eu
    Jan 24 15:43:13 localhost kernel: rtl8192eu 4-2:1.0 wlan1: renamed from wlan0
    Jan 24 15:43:21 localhost kernel: snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC887-VD: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
    Jan 24 15:43:21 localhost kernel: snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
    Jan 24 15:43:21 localhost kernel: snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
    Jan 24 15:43:21 localhost kernel: snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
    Jan 24 15:43:21 localhost kernel: snd_hda_codec_realtek hdaudioC1D0:    dig-out=0x11/0x0
    Jan 24 15:43:21 localhost kernel: snd_hda_codec_realtek hdaudioC1D0:    inputs:
    Jan 24 15:43:21 localhost kernel: snd_hda_codec_realtek hdaudioC1D0:      Rear Mic=0x18
    Jan 24 15:43:21 localhost kernel: snd_hda_codec_realtek hdaudioC1D0:      Front Mic=0x19
    Jan 24 15:43:21 localhost kernel: snd_hda_codec_realtek hdaudioC1D0:      Line=0x1a
    Jan 24 15:43:21 localhost kernel: snd_hda_codec_realtek hdaudioC1D0:      CD=0x1c
    Jan 24 15:43:29 localhost NetworkManager[1018]: <info>  [1611524609.2680] rfkill0: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:10.0/usb4/4-2/4-2:1.0/ieee80211/phy0/rfkill0) (driver rtl8192eu)
    Jan 24 15:43:29 localhost NetworkManager[1018]: <info>  [1611524609.3841] Loaded device plugin: NMWifiFactory (/usr/lib64/NetworkManager/1.22.10/libnm-device-plugin-wifi.so)
    Jan 24 15:43:29 localhost NetworkManager[1018]: <info>  [1611524609.6721] device (wlan1): driver supports Access Point (AP) mode
    Jan 24 15:43:29 localhost NetworkManager[1018]: <info>  [1611524609.6739] manager: (wlan1): new 802.11 Wi-Fi device (/org/freedesktop/NetworkManager/Devices/3)
    Jan 24 15:43:29 localhost NetworkManager[1018]: <info>  [1611524609.6786] device (wlan1): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
    Jan 24 15:43:31 localhost NetworkManager[1018]: <info>  [1611524611.6813] device (wlan1): set-hw-addr: set MAC address to 2A:C9:2A:45:D2:13 (scanning)
    Jan 24 15:43:31 localhost NetworkManager[1018]: <info>  [1611524611.9987] device (wlan1): supplicant interface state: init -> starting
    Jan 24 15:43:32 localhost NetworkManager[1018]: <info>  [1611524612.0603] sup-iface[0x55c6117fa930,wlan1]: supports 5 scan SSIDs
    Jan 24 15:43:32 localhost NetworkManager[1018]: <info>  [1611524612.0640] device (wlan1): supplicant interface state: starting -> ready
    Jan 24 15:43:32 localhost NetworkManager[1018]: <info>  [1611524612.0643] Wi-Fi P2P device controlled by interface wlan1 created
    Jan 24 15:43:32 localhost NetworkManager[1018]: <info>  [1611524612.0652] manager: (p2p-dev-wlan1): new 802.11 Wi-Fi P2P device (/org/freedesktop/NetworkManager/Devices/4)
    Jan 24 15:43:32 localhost NetworkManager[1018]: <info>  [1611524612.0662] device (p2p-dev-wlan1): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
    Jan 24 15:43:32 localhost NetworkManager[1018]: <info>  [1611524612.0685] device (p2p-dev-wlan1): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'managed')
    Jan 24 15:43:32 localhost NetworkManager[1018]: <info>  [1611524612.0695] device (wlan1): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
    Jan 24 15:43:46 localhost.localdomain NetworkManager[1018]: <info>  [1611524626.7436] device (wlan1): Activation: starting connection 'INFINITUM7B5A' (371e60eb-fd63-4535-99d4-48092887f45a)
    Jan 24 15:43:46 localhost.localdomain NetworkManager[1018]: <info>  [1611524626.7442] device (wlan1): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
    Jan 24 15:43:46 localhost.localdomain NetworkManager[1018]: <info>  [1611524626.7497] device (wlan1): set-hw-addr: reset MAC address to D0:37:45:C1:A0:8B (preserve)
    Jan 24 15:43:46 localhost.localdomain NetworkManager[1018]: <info>  [1611524626.7503] device (wlan1): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
    Jan 24 15:43:46 localhost.localdomain NetworkManager[1018]: <info>  [1611524626.7516] device (wlan1): Activation: (wifi) access point 'INFINITUM7B5A' has security, but secrets are required.
    Jan 24 15:43:46 localhost.localdomain NetworkManager[1018]: <info>  [1611524626.7516] device (wlan1): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
    Jan 24 15:43:46 localhost.localdomain NetworkManager[1018]: <info>  [1611524626.7524] sup-iface[0x55c6117fa930,wlan1]: wps: type pbc start...
    Jan 24 15:43:46 localhost.localdomain NetworkManager[1018]: <info>  [1611524626.7793] device (wlan1): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
    Jan 24 15:43:46 localhost.localdomain NetworkManager[1018]: <info>  [1611524626.7807] device (wlan1): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
    Jan 24 15:43:46 localhost.localdomain NetworkManager[1018]: <info>  [1611524626.7819] device (wlan1): Activation: (wifi) connection 'INFINITUM7B5A' has security, and secrets exist.  No new secrets needed.
    Jan 24 15:43:46 localhost.localdomain NetworkManager[1018]: <info>  [1611524626.7983] device (wlan1): supplicant interface state: ready -> disconnected
    Jan 24 15:43:46 localhost.localdomain NetworkManager[1018]: <info>  [1611524626.7984] device (p2p-dev-wlan1): supplicant management interface state: ready -> disconnected
    Jan 24 15:43:46 localhost.localdomain NetworkManager[1018]: <info>  [1611524626.8199] device (wlan1): supplicant interface state: disconnected -> inactive
    Jan 24 15:43:46 localhost.localdomain NetworkManager[1018]: <info>  [1611524626.8200] device (p2p-dev-wlan1): supplicant management interface state: disconnected -> inactive
    Jan 24 15:43:48 localhost.localdomain NetworkManager[1018]: <info>  [1611524628.9501] device (wlan1): supplicant interface state: inactive -> scanning
    Jan 24 15:43:48 localhost.localdomain NetworkManager[1018]: <info>  [1611524628.9502] device (p2p-dev-wlan1): supplicant management interface state: inactive -> scanning
    Jan 24 15:43:53 localhost.localdomain NetworkManager[1018]: <info>  [1611524633.2843] device (wlan1): supplicant interface state: scanning -> associating
    Jan 24 15:43:53 localhost.localdomain NetworkManager[1018]: <info>  [1611524633.2844] device (p2p-dev-wlan1): supplicant management interface state: scanning -> associating
    Jan 24 15:43:53 localhost.localdomain NetworkManager[1018]: <info>  [1611524633.9831] device (wlan1): supplicant interface state: associating -> associated
    Jan 24 15:43:53 localhost.localdomain NetworkManager[1018]: <info>  [1611524633.9831] device (p2p-dev-wlan1): supplicant management interface state: associating -> associated
    Jan 24 15:43:53 localhost.localdomain NetworkManager[1018]: <info>  [1611524633.9883] device (wlan1): supplicant interface state: associated -> 4-way handshake
    Jan 24 15:43:53 localhost.localdomain NetworkManager[1018]: <info>  [1611524633.9884] device (p2p-dev-wlan1): supplicant management interface state: associated -> 4-way handshake

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •