Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Eolie browser doesn't remember passwords

  1. #1
    Join Date
    Apr 2018
    Location
    New Mexico
    Posts
    168

    Default Eolie browser doesn't remember passwords

    I just discovered Gnome's nice Eolie web browser and would like to use it as my daily browser but one glitch is preventing that: Eolie doesn't store web passwords. In Eolie's preferences I select "remember passwords" but the setting always reverts to the default off position.
    I suspect not many people are using this browser so I may not receive an answer...but thanks in advance anyway.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,843
    Blog Entries
    3

    Default Re: Eolie browser doesn't remember passwords

    I did not even know that browser existed.

    So, okay, I installed it. And then I tried. When I turn on to remember passwords, it does not actually save that setting. But there's a possibility that you have to turn on firefox sync for that to work. I can't test that, because I have deliberately chosen to not use firefox sync.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  3. #3
    Join Date
    Apr 2018
    Location
    New Mexico
    Posts
    168

    Default Re: Eolie browser doesn't remember passwords

    Quote Originally Posted by nrickert View Post
    I did not even know that browser existed.

    So, okay, I installed it. And then I tried. When I turn on to remember passwords, it does not actually save that setting. But there's a possibility that you have to turn on firefox sync for that to work. I can't test that, because I have deliberately chosen to not use firefox sync.
    Thanks for your reply. I'm reluctant to try firefox sync. When I tried it with Epiphany the browser became unusable and I'm afraid the same thing would happen with Eolie. But maybe I'll give it a shot...

  4. #4
    Join Date
    Apr 2018
    Location
    New Mexico
    Posts
    168

    Default Re: Eolie browser doesn't remember passwords

    An update: I successfully synced passwords with Firefox. Oddly, though, the "remember passwords" option is still in the off position. But when I visit sites my login credentials are automatically entered, just as they would be in Firefox. So I'll stick with Eolie for a while as my main browser and see how it goes. Like Epiphany, it does seem to have problems playing videos on some sites but for the most part I really like it--it's very elegant, and I like the innovative side tabs with the option to see thumbnails of all open tabs. And it also shares another nice Epiphany feature--to go forward or backward in your browsing history you can swipe left or right with two fingers on your touchpad.

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,843
    Blog Entries
    3

    Default Re: Eolie browser doesn't remember passwords

    Thanks for that update.

    Perhaps this is worth a bug report.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  6. #6
    Join Date
    Apr 2018
    Location
    New Mexico
    Posts
    168

    Default Re: Eolie browser doesn't remember passwords

    I submitted a bug report. I hope the developer is still working on this project!

  7. #7
    Join Date
    Apr 2018
    Location
    New Mexico
    Posts
    168

    Default Re: Eolie browser doesn't remember passwords

    When I open Eolie from the command line I get this error message:

    Code:
    > eolie 
    [INFO] 2021-01-24 17:06:36 You need to set MOZ_PLUGIN_PATH to use plugins
    I'm not sure how fix this--how would I set "MOZ_PLUGIN_PATH" to use plugins in Eolie?

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,843
    Blog Entries
    3

    Default Re: Eolie browser doesn't remember passwords

    Presumably you would set it to "/usr/lib64/browser-plugins" or "/usr/lib/browser-plugins".

    Now that "flash" is dead and uninstalled here, those directories are empty anyway.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  9. #9
    Join Date
    Apr 2018
    Location
    New Mexico
    Posts
    168

    Default Re: Eolie browser doesn't remember passwords

    Presumably you would set it to "/usr/lib64/browser-plugins" or "/usr/lib/browser-plugins".
    Thanks for your reply. How do I go about setting that? Is there a config file I need to edit?

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,843
    Blog Entries
    3

    Default Re: Eolie browser doesn't remember passwords

    If "eolie" is a shell script, you could modify that. Or you could put your own shell script somewhere. I set $HOME/bin to be first in my PATH, and put scripts there.

    Another option would be to set it in your shell startup file. But then it affects all browser (or all programs that look for the particular environment variable).
    Code:
    export MOZ_PLUGIN_PATH=/usr/lib64/browser-plugins
    If that plugin directory is empty, then don't bother. The error message is flagged as just informational, so "eolie" knows that it can ignore the missing setting.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •