Results 1 to 10 of 10

Thread: Kernel Update - Versioning Error Causes VMWare Workstation to fail

  1. #1

    Exclamation Kernel Update - Versioning Error Causes VMWare Workstation to fail

    This morning I installed the latest Kernel Update. I am no longer able to start VMWare Workstation as a result. VMWare Workstation requires the kernel headers to compile two modules (vmmon and vmnet?). The latest kernel-source and kernel packages in YaST report version 5.3.18-lp152.60.1 but the kernel installed reports version 5.3.18-lp152.60 so the path to the kernel headers is not found. Is the 5.3.18-lp152.60 kernel the same, could I put in a symlink, or was the wrong kernel packaged in the RPM?

    In the meantime I intervened during bootup and went back to the .57 version so I could work...

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,115

    Default AW: Kernel Update - Versioning Error Causes VMWare Workstation to fail

    Please post:
    Code:
    zypper se -si kernel

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,272
    Blog Entries
    3

    Default Re: Kernel Update - Versioning Error Causes VMWare Workstation to fail

    Quote Originally Posted by rrawson View Post
    The latest kernel-source and kernel packages in YaST report version 5.3.18-lp152.60.1 but the kernel installed reports version 5.3.18-lp152.60 so the path to the kernel headers is not found.
    It looks okay from here. Looking at the file list in Yast software management, the paths to headers are all using "5.3.18-lp152.60" in the path (no trailing ".1"). I am not seeing an obvious problem.

    Yes, the kernel package is "5.3.18-lp152.60.1" but the ".1" is just a number that is incremented for each recompile. The correct kernel version number should be "5.3.18-lp152.60". And all header paths seem consistent with that.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  4. #4

    Default Re: AW: Kernel Update - Versioning Error Causes VMWare Workstation to fail

    Quote Originally Posted by Sauerland View Post
    Please post:
    Code:
    zypper se -si kernel
    Non booting system w/ 5.3.18-lp152.60.1 also on my non-VMWare machine.
    From that:

    # zypper se -si kernel
    Loading repository data...
    Reading installed packages...

    S | Name | Type | Version | Arch | Repository
    ---+-----------------------+---------+----------------------+--------+--------------------------------
    i+ | kernel-default | package | 5.3.18-lp152.60.1 | x86_64 | openSUSE:Leap:15.2:Update
    i+ | kernel-default | package | 5.3.18-lp152.60.1 | x86_64 | Hauptaktualisierungs-Repository
    i+ | kernel-default | package | 5.3.18-lp152.57.1 | x86_64 | openSUSE:Leap:15.2:Update
    i+ | kernel-default | package | 5.3.18-lp152.57.1 | x86_64 | Hauptaktualisierungs-Repository
    i+ | kernel-docs | package | 5.3.18-lp152.60.1 | noarch | openSUSE:Leap:15.2:Update
    i+ | kernel-docs | package | 5.3.18-lp152.60.1 | noarch | Hauptaktualisierungs-Repository
    i+ | kernel-firmware | package | 20200107-lp152.2.3.1 | noarch | openSUSE:Leap:15.2:Update
    i+ | kernel-firmware | package | 20200107-lp152.2.3.1 | noarch | Hauptaktualisierungs-Repository
    i+ | nfs-kernel-server | package | 2.1.1-lp152.9.6.1 | x86_64 | openSUSE:Leap:15.2:Update
    i+ | nfs-kernel-server | package | 2.1.1-lp152.9.6.1 | x86_64 | Hauptaktualisierungs-Repository
    i+ | purge-kernels-service | package | 0-lp152.4.1 | noarch | Haupt-Repository

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,115

    Default AW: Kernel Update - Versioning Error Causes VMWare Workstation to fail

    Non booting system w/ 5.3.18-lp152.60.1 also on my non-VMWare machine.
    From that:
    I think, your vmware is not building, so we need the right system..........

    PS
    you can start the above system with the old kernel in grub.

  6. #6

    Default Re: AW: Kernel Update - Versioning Error Causes VMWare Workstation to fail

    Quote Originally Posted by Sauerland View Post
    I think, your vmware is not building, so we need the right system..........

    PS
    you can start the above system with the old kernel in grub.

    Thanks and sorry - just found that the machine is suffering from a Radeon GPU kernel driver problem as posted in:
    https://www.opensuse-forum.de/thread...mehr/?pageNo=3
    and looks like a reincarnation of:
    Bug 1177384 - Black screen after updating to kernel 5.3.18-lp152.44-default

    The workaround for the time being is to use the former kernel driver from 5.3.18-lp152.57.

  7. #7

    Default Re: Kernel Update - Versioning Error Causes VMWare Workstation to fail



    localhost:/home/rrawson #
    zypper se -si kernel
    Loading repository data...
    Reading installed packages...

    S | Name | Type | Version | Arch | Repository
    ---+-----------------------+---------+----------------------+--------+-----------------------
    i+ | kernel-default | package | 5.3.18-lp152.60.1 | x86_64 | Main Update Repository
    i+ | kernel-default | package | 5.3.18-lp152.57.1 | x86_64 | Main Update Repository
    i+ | kernel-default-devel | package | 5.3.18-lp152.57.1 | x86_64 | Main Update Repository
    i+ | kernel-devel | package | 5.3.18-lp152.60.1 | noarch | Main Update Repository
    i+ | kernel-devel | package | 5.3.18-lp152.57.1 | noarch | Main Update Repository
    i+ | kernel-firmware | package | 20200107-lp152.2.3.1 | noarch | Main Update Repository
    i+ | kernel-macros | package | 5.3.18-lp152.60.1 | noarch | Main Update Repository
    i+ | kernel-source | package | 5.3.18-lp152.60.1 | noarch | Main Update Repository
    i+ | kernel-source | package | 5.3.18-lp152.57.1 | noarch | Main Update Repository
    i+ | purge-kernels-service | package | 0-lp152.4.1 | noarch | Main Repository
    localhost:/home/rrawson # uname -a
    Linux localhost.localdomain 5.3.18-lp152.60-default #1 SMP Tue Jan 12 23:10:31 UTC 2021 (9898712) x86_64 x86_64 x86_64 GNU/Linux
    localhost:/home/rrawson #


  8. #8

    Default Re: Kernel Update - Versioning Error Causes VMWare Workstation to fail


  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,115

    Default AW: Kernel Update - Versioning Error Causes VMWare Workstation to fail

    default-devel is missing for your kernel, install it:
    Code:
    zypper in -f kernel-default-devel

  10. #10

    Thumbs up Re: Kernel Update - Versioning Error Causes VMWare Workstation to fail

    SOLVED! Thank you.

    Root cause was that I did a complete rebuild of my laptop after GUI stopped started and missed that repo. It worked immediately after on the same kernel as before but failed once zypper updated the kernel package.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •