Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: wake on lan and sysconfig

  1. #11

    Default Re: wake on lan and sysconfig

    Quote Originally Posted by hcvv View Post
    Yes, that is the place. Please, please, undo all the things you did in /usr/lib/systemd/.
    ok, done and working

    Code:
    andromeda:~ # systemctl daemon-reload                                       
    andromeda:~ # systemctl status setwol.service 
    ● setwol.service - Enable WOL before the system stops 
       Loaded: loaded (/etc/systemd/system/setwol.service; enabled; vendor preset: disabled) 
       Active: inactive (dead) since Mon 2020-12-14 12:10:23 CET; 3h 14min ago 
        Tasks: 0 
       CGroup: /system.slice/setwol.service 
    
    Dec 14 12:10:22 andromeda systemd[1]: Starting Enable WOL before the system stops... 
    Dec 14 12:10:23 andromeda systemd[1]: Started Enable WOL before the system stops. 
    andromeda:~ # systemctl stop setwol.service   
    andromeda:~ # systemctl disable setwol.service 
    Removed /etc/systemd/system/multi-user.target.wants/setwol.service. 
    andromeda:~ # systemctl status setwol.service    
    ● setwol.service - Enable WOL before the system stops 
       Loaded: loaded (/etc/systemd/system/setwol.service; disabled; vendor preset: disabled) 
       Active: inactive (dead) 
    
    Dec 14 12:10:22 andromeda systemd[1]: Starting Enable WOL before the system stops... 
    Dec 14 12:10:23 andromeda systemd[1]: Started Enable WOL before the system stops. 
    andromeda:~ # systemctl enable setwol.service    
    Created symlink /etc/systemd/system/multi-user.target.wants/setwol.service → /etc/systemd/system/setwol.service. 
    andromeda:~ # systemctl start setwol.service  
    andromeda:~ #
    

  2. #12
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    28,734

    Default Re: wake on lan and sysconfig

    Many people post their problems as something "not working". That expression does not provide much information.

    The same is true when you say "working".
    I see that you can enable/disable/start/stop it, but the goal was to have a system that boots on WO, also after a reboot. Is that now doing as you want it?
    Henk van Velden

  3. #13

    Default Re: wake on lan and sysconfig

    Quote Originally Posted by hcvv View Post
    Many people post their problems as something "not working". That expression does not provide much information.

    The same is true when you say "working".
    I see that you can enable/disable/start/stop it, but the goal was to have a system that boots on WO, also after a reboot. Is that now doing as you want it?

    Sorry. Working for me means taht it works like expected.
    I halted the computer and sent the magic packet and the computer woke up, then I waited until grub apeared and I switched off the computer with the power button, then I sent the magic packet again and again it booted. Then I let opensuse boot completely, and then halted it, sent the magic packet again and it booted again. So it works.


    best regards

  4. #14
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    28,734

    Default Re: wake on lan and sysconfig

    Success! Nice you got it working. WOL is always a bit of a trick. Not all systems support it.
    Henk van Velden

  5. #15

    Default Re: wake on lan and sysconfig

    I'm using another possibility.

    In the LAN module of YaST you can find a field ethtool-options in the hardware settings of your network card. Here you are able to set '-s eth0 wol g'.

    Ethtool will set WOL with ifup. If someone changes the settings before shutdown, you can't use WOL.

    I never had problems with WOL since the update to openSUSE 15.2 on two computers. Two other computers, with new installations, don't need any extra settings. No matter why.

    Best regards

  6. #16
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    28,734

    Default Re: wake on lan and sysconfig

    Hello and welcome here.

    One of the reasons people prefer showing things in the CLI rather then in the GUI is that it is rather difficult to explain what to do and see in a GUI application. A good chance that one looses one's audience somewhere halfway.

    As I am unaware of a YaST "Lan Module", I tried to find out what you mean.

    I assume you mean YaST > System > Network Settings; then select the network card and click Edit below; then choose the Hardware tab where you indeed find Ethtool Options.

    Does this not depend on the use of Wicked or Network Manager or Systemd-network? Setting it as shown in the thread is in any case independent of that.

    BTW I tried to gather the information from this thread and others in an unreviewed HowTo: https://forums.opensuse.org/showthre...a-working-case
    Last edited by hcvv; 08-May-2021 at 02:56.
    Henk van Velden

  7. #17

    Default Re: wake on lan and sysconfig

    Quote Originally Posted by oparierer View Post
    In the LAN module of YaST you can find a field ethtool-options in the hardware settings of your network card. Here you are able to set '-s eth0 wol g'.

    Ethtool will set WOL with ifup. If someone changes the settings before shutdown, you can't use WOL.
    Not available with NetworkManager service, only with Wicked.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •