Since Leap 15.2 (so quite some time ago) sometimes booting takes much longer than normal. When examining the journal, I see the following things:

Code:
Nov 30 18:06:08 gepard display-manager[1744]: KEYMAP: de-latin1-nodeadkeys
Nov 30 18:06:08 gepard display-manager[1744]: Command: localectl set-keymap de-latin1-nodeadkeys
Nov 30 18:06:08 gepard systemd[1]: Reloading.
Nov 30 18:06:08 gepard display-manager[1744]: I: Using systemd /usr/share/systemd/kbd-model-map mapping
Nov 30 18:06:08 gepard dbus-daemon[1001]: [system] Activating via systemd: service name='org.freedesktop.locale1' unit='dbus-org.freedesktop.locale1.service' requested by ':1.20' (uid=0 pid=1781 comm="localectl set-keymap de-latin1-nodeadkeys ")
...
Nov 30 18:06:35 gepard dbus-daemon[1001]: [system] Failed to activate service 'org.freedesktop.locale1': timed out (service_start_timeout=25000ms)
Nov 30 18:06:35 gepard display-manager[1744]: Failed to set keymap: Die Wartezeit für die Verbindung ist abgelaufen
...
Nov 30 18:06:36 gepard sddm-helper[1973]: [PAM] Starting...
Nov 30 18:06:36 gepard sddm-helper[1973]: [PAM] Authenticating...
Nov 30 18:06:36 gepard sddm-helper[1973]: [PAM] returning.
Nov 30 18:06:36 gepard sddm[1944]: Authenticated successfully
Nov 30 18:07:01 gepard sddm-helper[1973]: pam_systemd(sddm-autologin:session): Failed to create session: Die Wartezeit für die Verbindung ist abgelaufen
Nov 30 18:07:01 gepard systemd-logind[1143]: Failed to start user service 'user@1000.service', ignoring: Connection timed out
This happens in about 1 of 20 boots, so not very often.

The top lines of output from systemd-analyze blame are as follows:

Code:
gepard:~ # systemd-analyze blame
    1min 29.699s fstrim.service
    1min 10.187s btrfsmaintenance-refresh.service
     1min 3.872s smb.service
     1min 3.278s libvirtd.service
     1min 3.184s backup-sysconfig.service
     1min 3.183s mandb.service
     1min 3.183s backup-rpmdb.service
     1min 3.128s display-manager.service
          4.145s wicked.service
          2.514s smartd.service
          1.185s systemd-udev-settle.service
          1.005s udisks2.service
          1.000s apparmor.service
My system:

Code:
Operating System: openSUSE Leap 15.2
KDE Plasma Version: 5.18.5
KDE Frameworks Version: 5.71.0
Qt Version: 5.12.7
Kernel Version: 5.3.18-lp152.50-default
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-2500K CPU @ 3.30GHz
Memory: 7,7 GiB
Has somebody any idea what could cause this delay? What could I do to analyze the issue further?