Results 1 to 7 of 7

Thread: Can't add official repo

  1. #1

    Default Can't add official repo

    Hi! I'm using YaST2 to add the repository https://download.opensuse.org/reposi...E:Factory.repo, but it keeps failing with the error:

    Unable to create repository from URL https://download.opensuse.org/reposi...E:Factory.repo. Does anyone know why this is happening? This URL is from the official documentation.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    27,698

    Default Re: Can't add official repo

    When I click on that URL, it does not exist.

    Maybe you better explain what you need, so people can help you with that. Remember: http://www.catb.org/~esr/faqs/smart-questions.html#goal
    Last edited by hcvv; 30-Nov-2020 at 09:37.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,125
    Blog Entries
    2

    Default Re: Can't add official repo

    A repo URL can always be explored using a web browser,
    It appears that this URL contains repos and downloadable ISOs to install various Factory packages.

    This part of the URL works... Open it in a web browser and explore...

    https://download.opensuse.org/reposi...SUSE:/Factory/

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  4. #4

    Default Re: Can't add official repo

    I got this URL from https://software.opensuse.org/downlo...SUSE%3AFactory

    I'm trying to install Tilix.

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    30,220
    Blog Entries
    15

    Default Re: Can't add official repo

    Quote Originally Posted by mrbear View Post
    Hi! I'm using YaST2 to add the repository https://download.opensuse.org/reposi...E:Factory.repo, but it keeps failing with the error:

    Unable to create repository from URL https://download.opensuse.org/reposi...E:Factory.repo. Does anyone know why this is happening? This URL is from the official documentation.
    Hi
    Factory is NOT Tumbleweed....?

    The version of tilix in Tumbleweed is 1.9.3 at present... if you have the standard Tumblweed repositories then just `zypper in tilix`
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: Can't add official repo

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Factory is NOT Tumbleweed....?

    The version of tilix in Tumbleweed is 1.9.3 at present... if you have the standard Tumblweed repositories then just `zypper in tilix`
    Can you elabore on "Factory is not Tumbleweed"?

    I understand that I'm using the rolling release version of Open SUSE - does that mean I can't add Leap repos?

    That's the output of `zypper lr`:

    1 | openSUSE-20201125-0 | openSUSE-20201125-0 | No | ---- | ----
    2 | repo-debug | openSUSE-Tumbleweed-Debug | No | ---- | ----
    3 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Yes | (r ) Yes | Yes
    4 | repo-oss | openSUSE-Tumbleweed-Oss | Yes | (r ) Yes | Yes
    5 | repo-source | openSUSE-Tumbleweed-Source | No | ---- | ----
    6 | repo-update | openSUSE-Tumbleweed-Update | Yes | (r ) Yes | Yes

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    30,220
    Blog Entries
    15

    Default Re: Can't add official repo

    Quote Originally Posted by mrbear View Post
    Can you elabore on "Factory is not Tumbleweed"?

    I understand that I'm using the rolling release version of Open SUSE - does that mean I can't add Leap repos?

    That's the output of `zypper lr`:

    1 | openSUSE-20201125-0 | openSUSE-20201125-0 | No | ---- | ----
    2 | repo-debug | openSUSE-Tumbleweed-Debug | No | ---- | ----
    3 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Yes | (r ) Yes | Yes
    4 | repo-oss | openSUSE-Tumbleweed-Oss | Yes | (r ) Yes | Yes
    5 | repo-source | openSUSE-Tumbleweed-Source | No | ---- | ----
    6 | repo-update | openSUSE-Tumbleweed-Update | Yes | (r ) Yes | Yes
    Hi
    You number 4 repository is the correct one for tilix.

    No, Tumbleweed only, no Leap repositories at all... just the ones you have (and packman Tumbleweed if want codecs).
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •