Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Darstellungsprobleme nach Upgrade auf oS 15.2

  1. #1

    Default Darstellungsprobleme nach Upgrade auf oS 15.2

    Guten Abend,

    ich habe heute mein Laptop auf oS 15.2 mit "zypper dup" aktualisiert.
    Soweit lief alles gut durch und prinzipiell funzt auch alles.
    Nur mein Desktop selbst gefällt mir grad gar nicht.
    Da "zappelt" alles
    Heißt:
    - die Kontrollleiste ist mal nur schwarz oder nur Teile sind erkennbar => sobald ich mit der Maus drüber fahre, ist alles wieder zu sehen.
    - die Arbeitsfläche zieht schwarze Striche oder Dreiecke über den Bildschirm - Miniprogramme sind nicht oder nur teilweise erkennbar.
    Ich hab es mal in einem Screenshot verewigt:
    https://paste.opensuse.org/images/45832700.jpg

    Installiert ist KDE-Plasma 5.18.5
    Code:
    laptop:~ # /sbin/lspci -nnk | grep -EiA3 'display|3d|vga'
    00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 09)
            Subsystem: Acer Incorporated [ALI] Device [1025:082a]
            Kernel driver in use: i915
            Kernel modules: i915
    Aufgefallen in Xorg.0.log ist mir diese Zeile:
    Code:
    (EE) intel(0): Failed to submit rendering commands (Operation not permitted), disabling acceleration.
    Kann es mit meinem Problem etwas zu tun haben? Und wenn ja, wie kann ich es beheben?

    Vielen Dank vorab.
    Reni


  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,301

    Default AW: Darstellungsprobleme nach Upgrade auf oS 15.2

    Systemeinstellungen------Hardware------Anzeige und Monitor-----Compositor----Ausgabemodul---openGL einstellen

  3. #3

    Default AW: Darstellungsprobleme nach Upgrade auf oS 15.2

    openGL 3.1 war eingestellt, aber es stand auch eine Meldung, dass es wegen Abstürzen in der Vergangebheit deaktiviert ist.
    Ich hab es wieder aktiviert und nun muss ich schaun, ob es das war.
    Danke dir

    Viele Grüße.

    EDIT: Hilft leider nicht. Ich habe als Hintergrund wieder meine Dia-Show eingerichtet und schon fängt es wieder an.
    Mit Umstellung auf openGL 2.0 versucht - dann haben geöffnete Anwendungen (Bsp. Vivaldi) nur noch einen Rand ohne Inhalt.

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,301

    Default AW: Darstellungsprobleme nach Upgrade auf oS 15.2

    Poste mal:
    Code:
    zypper se -si kernel firmware
    Benutze Code-Tags:
    https://forums.opensuse.org/showthre...und-Your-Paste

  5. #5

    Default AW: Darstellungsprobleme nach Upgrade auf oS 15.2

    Code:
    S  | Name                  | Typ   | Version              | Arch   | Repository
    ---+-----------------------+-------+----------------------+--------+--------------------
    i+ | bluez-firmware        | Paket | 1.2-lp152.3.2        | x86_64 | openSUSE-Oss
    i+ | kernel-default        | Paket | 5.3.18-lp152.54.1    | x86_64 | openSUSE-Update-Oss
    i+ | kernel-default-devel  | Paket | 5.3.18-lp152.54.1    | x86_64 | openSUSE-Update-Oss
    i+ | kernel-devel          | Paket | 5.3.18-lp152.54.1    | noarch | openSUSE-Update-Oss
    i+ | kernel-firmware       | Paket | 20200107-lp152.2.3.1 | noarch | openSUSE-Update-Oss
    i+ | kernel-macros         | Paket | 5.3.18-lp152.54.1    | noarch | openSUSE-Update-Oss
    i+ | kernel-source         | Paket | 5.3.18-lp152.54.1    | noarch | openSUSE-Update-Oss
    i  | purge-kernels-service | Paket | 0-lp152.4.1          | noarch | openSUSE-Oss
    

  6. #6

    Default AW: Darstellungsprobleme nach Upgrade auf oS 15.2

    Das Ausgabemodul steht jetzt auf open GL 3.1 und mein Desktop scheint momentan stabil zu Laufen.
    Jetzt hat nur Vivaldi das oben schon geschilderte Problem.
    Der Browser öffnet sich und sieht gut aus. Wenn ich ihn allerdings nach dem Minimieren wieder anklicke, sehe ich nur Rahmen.
    Erst wenn ich die Größe ändere kommt wieder Inhalt.

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,301

    Default AW: Darstellungsprobleme nach Upgrade auf oS 15.2


  8. #8

    Default AW: Darstellungsprobleme nach Upgrade auf oS 15.2

    Quote Originally Posted by Sauerland View Post
    Oh sorry, damit kann ich gerade nicht viel anfangen also ich meine, was für mich von Interesse wäre.

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,301

    Default AW: Darstellungsprobleme nach Upgrade auf oS 15.2

    Tja, das kann ich dir auch nicht sagen, poste mal:
    Code:
    cat /var/log/Xorg.0.log
    Kannst du auf paste.opensuse.org posten und hier dann verlinken, bitte stell aber "delete after" auf "never" um.
    Last edited by Sauerland; 06-Dec-2020 at 15:47.

  10. #10

    Default AW: Darstellungsprobleme nach Upgrade auf oS 15.2

    Guten Morgen,

    hier das Xorg-Log-File:
    https://paste.opensuse.org/43462341

    Stand heute Morgen ist, dass diese Grafikfehler weg sind, nach dem OpenGL jetzt auf 2.0 steht, aber eben das Problem mit einigen Anwendungen besteht.
    Speziell Vivaldi macht Sorgen. Immer wenn man es auf die Kontrollleiste legt und wieder anklickt, gibt es keinen Inhalt - nur Rahmen.
    Ändere ich die Größe des Fensters, ist alles wieder da.

    Zur Zeit habe ich auch mein Firmen-Laptop zu Hause und da arbeitet auch ein Intel-Chip - nicht der Gleiche, aber es werden die gleichen Treiber verwendet (i915).
    Auch hier steht OpenGL auf 2.0 und alles funzt wunderbar.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •