Results 1 to 8 of 8

Thread: Support for AMD RX 6800 series cards - Missing amdgpu firmware

  1. #1

    Default Support for AMD RX 6800 series cards - Missing amdgpu firmware

    Good evening.

    This is my first time posting in this forum so pardon me if I am making any mistake in here.

    I was lucky enough to get hands on AMD RX 6800 GPU but as title might hint you I get black screen after kernel initialization. The issue is most likely missing firmwares as linux-firmware 2020118 adds support for latest AMD RX 6800-series GPUs (20201023 in Opensuse Tumbleweed).

    So I was wondering if there are anything I can do, should I just wait for the proper Tumbleweed version update?

    Sincerely
    Atte

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    30,152
    Blog Entries
    15

    Default Re: Support for AMD RX 6800 series cards - Missing amdgpu firmware

    Quote Originally Posted by addei View Post
    Good evening.

    This is my first time posting in this forum so pardon me if I am making any mistake in here.

    I was lucky enough to get hands on AMD RX 6800 GPU but as title might hint you I get black screen after kernel initialization. The issue is most likely missing firmwares as linux-firmware 2020118 adds support for latest AMD RX 6800-series GPUs (20201023 in Opensuse Tumbleweed).

    So I was wondering if there are anything I can do, should I just wait for the proper Tumbleweed version update?

    Sincerely
    Atte
    Hi and welcome to the Forum
    Your better off to raise a bug report against the kernel for this, hopefully they can either add the sienna support or give an update as to when it will appear;
    openSUSE:Submitting bug reports - openSUSE
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Support for AMD RX 6800 series cards - Missing amdgpu firmware

    Quote Originally Posted by malcolmlewis View Post
    Hi and welcome to the Forum
    Your better off to raise a bug report against the kernel for this, hopefully they can either add the sienna support or give an update as to when it will appear;
    openSUSE:Submitting bug reports - openSUSE
    Hi malcolmlewis and thank you! I'll proceed to follow your given instructions.

  4. #4

    Default Re: Support for AMD RX 6800 series cards - Missing amdgpu firmware

    You may get needed files from https://git.kernel.org/pub/scm/linux...it/tree/amdgpu or extract them from Linux drivers: https://www.amd.com/ru/support/graph...radeon-rx-6800 .
    For Ubuntu drivers: amdgpu-pro-20.45-1164792-ubuntu-20.04.tar.xz -> amdgpu-dkms_5.6.20.906300-1164792_all.deb -> /usr/src/amdgpu-5.6*/firmware/amdgpu

    Then copy them to your root at /lib/firmware/amdgpu/ .

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    30,152
    Blog Entries
    15

    Default Re: Support for AMD RX 6800 series cards - Missing amdgpu firmware

    Quote Originally Posted by Svyatko View Post
    You may get needed files from https://git.kernel.org/pub/scm/linux...it/tree/amdgpu or extract them from Linux drivers: https://www.amd.com/ru/support/graph...radeon-rx-6800 .
    For Ubuntu drivers: amdgpu-pro-20.45-1164792-ubuntu-20.04.tar.xz -> amdgpu-dkms_5.6.20.906300-1164792_all.deb -> /usr/src/amdgpu-5.6*/firmware/amdgpu

    Then copy them to your root at /lib/firmware/amdgpu/ .
    Hi
    That solution may not work, there maybe other tweaks to the OSS amdgpu driver that is needed, hence the bug report request.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: Support for AMD RX 6800 series cards - Missing amdgpu firmware

    Quote Originally Posted by malcolmlewis View Post
    Hi
    That solution may not work, there maybe other tweaks to the OSS amdgpu driver that is needed, hence the bug report request.
    Yup. I got the firmware files for the card and I was able to proceed with the boot process but then other errors occurred regarding amdgpu.

  7. #7

    Default Re: Support for AMD RX 6800 series cards - Missing amdgpu firmware

    Another new RX 6800 owner checking in:

    I grabbed a newer version of linux-firmware (updated kernel-firmware to use Kernel:HEAD) and that allows the PC to actually boot properly with the RX 6800, but only up to the text login prompt. A few error messages from amdgpu get spit out mentioning write failures to some registers before the screen goes black and my TV completely loses the signal. With the nomodeset kernel parameter I can get into KDE fine (aside from the issues caused by nomodeset).

    I've noticed that using the kernel-default 5.10.rc4 Kernel:HEAD version works much better (I can get into KDE without nomodeset), but KDE doesn't completely load properly and things are slow.

    Has an bug report been opened yet? I can probably help out by providing my logs and info as well.

  8. #8

    Default Re: Support for AMD RX 6800 series cards - Missing amdgpu firmware

    Quote Originally Posted by NGnius View Post
    Another new RX 6800 owner checking in:

    I grabbed a newer version of linux-firmware (updated kernel-firmware to use Kernel:HEAD) and that allows the PC to actually boot properly with the RX 6800, but only up to the text login prompt. A few error messages from amdgpu get spit out mentioning write failures to some registers before the screen goes black and my TV completely loses the signal. With the nomodeset kernel parameter I can get into KDE fine (aside from the issues caused by nomodeset).

    I've noticed that using the kernel-default 5.10.rc4 Kernel:HEAD version works much better (I can get into KDE without nomodeset), but KDE doesn't completely load properly and things are slow.

    Has an bug report been opened yet? I can probably help out by providing my logs and info as well.
    Sorry for taking too long to answer. Unfortunately not yet. Only for those missing firmware files that you already used. I didn't have time to look at the issues that arose after linux-firmware as I was too busy with my school assignments so the new bug report needs to be opened.

    I also used those Kernel:HEAD linux-firmware files and the outcome was sounds same as you. Text login prompt, few error messages from amdgpu and then total black screen.
    I have plan to try that kernel-default 5.10.rc4 with mesa 21 tomorrow as well as fill the new bug report. If something comes up, I'll let you know.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •