Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Laptop 64 EFI - ‘Failed to Get Secrets’ - limited connectivity WiFi

  1. #1
    Join Date
    Apr 2018
    Location
    In S.E. Iowa, on the Mississippi River
    Posts
    740

    Default Laptop 64 EFI - ‘Failed to Get Secrets’ - limited connectivity WiFi

    This started today, and I have done every thing I can to resolve it on my own.
    NM hasn’t changed that I can tell.
    Once when I tried to open NM, it opened a browser web page that said ‘you’ve succeeded your monthly limit, CLOSE this page’. I thought it was going to open my router page, but there was nothing in the URL box.
    That only happened once, subsequently NM panel opened up along with a root PWD pop up. But as I said above NM settings appear to be as they were 2 days ago.

    At a loss AGAIN. Any help and/or suggestions?
    TIA
    Bill_L
    HP Compaq desktop Leap15.2, Win10, Win7
    Toshiba laptops Leap15.2 & Win10, HP AiO Leap 15.2.
    I can now print with openSuSe Leap! Can Scan now, could be better!!
    I can backup my iPod and iPad with Windows, can't with Linux.(Will get there someday!)

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,464
    Blog Entries
    1

    Default Re: Laptop 64 EFI - ‘Failed to Get Secrets’ - limited connectivity WiFi

    Strange. Have you tried restarting your router?
    openSUSE Leap 15.2; KDE Plasma 5

  3. #3
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,712

    Default Re: Laptop 64 EFI - ‘Failed to Get Secrets’ - limited connectivity WiFi

    I very occasionally see the "Failed to Get Secrets" message on this laptop, never did find the cause. Always connects OK on second try: NetworkManager -> (choose connection) -> Connect. Very random, put it down to some race condition maybe.

    Don't know if this is related, but yesterday (18 Nov 2020) from around 14:00 UTC the entire openSUSE infrastructure appeared to be offline for a few hours. NetworkManager, unless you've disabled the feature, makes a "Connectivity Check" to http://conncheck.opensuse.org
    if that fails it assumes you are behind some sort of captive portal with limited connectivity.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20210106) KDE Plasma 5
    2x Leap 15.2 KDE Plasma 5

  4. #4
    Join Date
    Apr 2018
    Location
    In S.E. Iowa, on the Mississippi River
    Posts
    740

    Default Re: Laptop 64 EFI - ‘Failed to Get Secrets’ - limited connectivity WiFi

    Quote Originally Posted by tannington View Post
    I very occasionally see the "Failed to Get Secrets" message on this laptop, never did find the cause. Always connects OK on second try: NetworkManager -> (choose connection) -> Connect. Very random, put it down to some race condition maybe.

    Don't know if this is related, but yesterday (18 Nov 2020) from around 14:00 UTC the entire openSUSE infrastructure appeared to be offline for a few hours. NetworkManager, unless you've disabled the feature, makes a "Connectivity Check" to http://conncheck.opensuse.org
    if that fails it assumes you are behind some sort of captive portal with limited connectivity.
    yeah, I experienced opensuse infrastructure being not available, 8AM CST to about 5PM CST. I didn’t know about the conncheck NM tries to do on start up.

    Quote Originally Posted by deano_ferrari View Post
    Strange. Have you tried restarting your router?
    Reboot router got me a ‘solid’ connection.
    Oddly both laptops had/have this problem. None of the small devices exhibited connectivity problems.

    However, both laptops are still getting the ‘failed to get secrets’ message, but a connection is made and that seems to come up after the WiFi connection has completed.

    The thing about NM open a browser window with the message ‘ you have exceeded your monthly data usage CLOSE THIS WINDOW’ came up on one of the laptops again this morning.
    I check my usage every couple of days with my provider, and I am no where near my limit.

    perplexed I am!
    HP Compaq desktop Leap15.2, Win10, Win7
    Toshiba laptops Leap15.2 & Win10, HP AiO Leap 15.2.
    I can now print with openSuSe Leap! Can Scan now, could be better!!
    I can backup my iPod and iPad with Windows, can't with Linux.(Will get there someday!)

  5. #5
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    2,214
    Blog Entries
    1

    Default Re: Laptop 64 EFI - ‘Failed to Get Secrets’ - limited connectivity WiFi

    Quote Originally Posted by Bill_L View Post
    yeah, I experienced opensuse infrastructure being not available, 8AM CST to about 5PM CST. I didn’t know about the conncheck NM tries to do on start up.


    Reboot router got me a ‘solid’ connection.
    Oddly both laptops had/have this problem. None of the small devices exhibited connectivity problems.

    However, both laptops are still getting the ‘failed to get secrets’ message, but a connection is made and that seems to come up after the WiFi connection has completed.

    The thing about NM open a browser window with the message ‘ you have exceeded your monthly data usage CLOSE THIS WINDOW’ came up on one of the laptops again this morning.
    I check my usage every couple of days with my provider, and I am no where near my limit.

    perplexed I am!
    Routers store some information in nonvolatile memory. This information will survive reboot. Disable the services in preferences and enable them again.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  6. #6
    Join Date
    Apr 2018
    Location
    In S.E. Iowa, on the Mississippi River
    Posts
    740

    Default Re: Laptop 64 EFI - ‘Failed to Get Secrets’ - limited connectivity WiFi

    This is a screenshot of what happens on every PC we have, desktop, and laptops after a popup telling up We NEED to login in to Network Management.
    When we click the 'login' button that comes up in the NM area, it brings up this browser window.
    https://susepaste.org/22150223

    I have rebooted the router a couple of times, yet this keeps happening!
    AND I know I am nowhere near my providers monthly limit!
    https://susepaste.org/82018721

    Odd thing is, this comes AFTER the connections are made, and they work very well!

    So? is there a problem with latest kernel on kernel firmware updates that have happened in the past few days?
    Or is there another route I need to take to stop this from happening?

    Edit>> The desktop is connected to the router with Ethernet cable. The laptops are both WIFi
    HP Compaq desktop Leap15.2, Win10, Win7
    Toshiba laptops Leap15.2 & Win10, HP AiO Leap 15.2.
    I can now print with openSuSe Leap! Can Scan now, could be better!!
    I can backup my iPod and iPad with Windows, can't with Linux.(Will get there someday!)

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,464
    Blog Entries
    1

    Default Re: Laptop 64 EFI - ‘Failed to Get Secrets’ - limited connectivity WiFi

    Quote Originally Posted by Bill_L View Post
    This is a screenshot of what happens on every PC we have, desktop, and laptops after a popup telling up We NEED to login in to Network Management.
    When we click the 'login' button that comes up in the NM area, it brings up this browser window.
    https://susepaste.org/22150223

    I have rebooted the router a couple of times, yet this keeps happening!
    AND I know I am nowhere near my providers monthly limit!
    https://susepaste.org/82018721
    This is specific to your router somehow, and not NetworkManager related.

    Odd thing is, this comes AFTER the connections are made, and they work very well!
    This doesn't surprise me.
    openSUSE Leap 15.2; KDE Plasma 5

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,464
    Blog Entries
    1

    Default Re: Laptop 64 EFI - ‘Failed to Get Secrets’ - limited connectivity WiFi

    Perhaps check the Netgear Community website. For example...

    https://community.netgear.com/t5/Gen...e/td-p/1054455
    openSUSE Leap 15.2; KDE Plasma 5

  9. #9
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    2,214
    Blog Entries
    1

    Default Re: Laptop 64 EFI - ‘Failed to Get Secrets’ - limited connectivity WiFi

    Quote Originally Posted by Bill_L View Post
    This is a screenshot of what happens on every PC we have, desktop, and laptops after a popup telling up We NEED to login in to Network Management.
    When we click the 'login' button that comes up in the NM area, it brings up this browser window.
    https://susepaste.org/22150223

    I have rebooted the router a couple of times, yet this keeps happening!
    AND I know I am nowhere near my providers monthly limit!
    https://susepaste.org/82018721

    Odd thing is, this comes AFTER the connections are made, and they work very well!

    So? is there a problem with latest kernel on kernel firmware updates that have happened in the past few days?
    Or is there another route I need to take to stop this from happening?

    Edit>> The desktop is connected to the router with Ethernet cable. The laptops are both WIFi
    There is no issue with openSUSE. Contact your provider. They are different. Mine is very terse and sends no messages for months once the connection has been set up:

    Code:
    08.11.20	07:58:46	IPv6-Präfix wurde erfolgreich aktualisiert. Neues Präfix: 2001.................
    08.11.20	07:28:46	Internetverbindung wurde erfolgreich hergestellt. IPv4 wird über DS-Lite genutzt. AFTR-Gateway: (aftr.prod.m-online.net), IPv4-MTU: (1492).
    08.11.20	07:28:46	IPv6-Präfix wurde erfolgreich bezogen. Neues Präfix: 2001...........................
    08.11.20	07:28:46	Internetverbindung IPv6 wurde erfolgreich hergestellt. IP-Adresse: 2001...............
    08.11.20	07:28:35	DSL ist verfügbar (DSL-Synchronisierung besteht mit 27496/5493 kbit/s).
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  10. #10
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,712

    Default Re: Laptop 64 EFI - ‘Failed to Get Secrets’ - limited connectivity WiFi

    Quote Originally Posted by deano_ferrari View Post
    Perhaps check the Netgear Community website. For example...
    I think this might be what @Bill_L is after:

    https://kb.netgear.com/24225/How-do-...ghthawk-router
    Last edited by tannington; 20-Nov-2020 at 02:55. Reason: fix quote tag. doh.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20210106) KDE Plasma 5
    2x Leap 15.2 KDE Plasma 5

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •