Page 1 of 5 123 ... LastLast
Results 1 to 10 of 44

Thread: Uanble to connect to local Samba server

  1. #1

    Default Uanble to connect to local Samba server

    Dear all,

    After many years of using other distro's, this evening I've finally installed Tumbleweed (after being tempted for quite a while). Installation was a breeze!

    What hasn't been so easy is connecting to my local samba server... Via nautilus I get the following error:
    "Failed to retrieve share list from server: No such file or directory"

    And when I try the connection in CLI I get this:
    "smbclient -L 192.168.1.72 -N
    do_connect: Connection to 192.168.1.72 failed (Error NT_STATUS_IO_TIMEOUT)"

    As per your instructions, my samba config is:
    Code:
    [global] 
      workgroup = WORKGROUP 
      netbios name = openSUSE-Desktop 
      server string = "" 
      name resolve order = bcast host lmhosts wins 
      local master = yes 
      preferred master = yes 
      os level = 65 
      passdb backend = tdbsam 
      printing = cups 
      printcap name = cups 
      printcap cache time = 750 
      cups options = raw 
      map to guest = Bad User 
      usershare allow guests = Yes
    The question is: what am I missing?

    Thank you in advance!

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,269
    Blog Entries
    1

    Default Re: Uanble to connect to local Samba server

    Are you sure that the samba server can be reached via that IP address?

    Try pinging that host
    Code:
    ping 192.168.1.72
    If that gets successful responses and you have nmap installed, do
    Code:
    nmap 192.168.1.72
    Report back with the results.
    openSUSE Leap 15.2; KDE Plasma 5

  3. #3

    Default Re: Uanble to connect to local Samba server

    First of all thanks for taking the time to help me!

    This is interesting: doing a ping test (with ping and nmap) would make you believe that the host is down - no connection can be established. However! I am perfectly able to ssh into the address, and my kodi-box is connecting fine with it over samba as well.

    Could the host be blocked? I've added it to the /etc/hosts list as such:
    Code:
    192.168.1.72    samba

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,269
    Blog Entries
    1

    Default Re: Uanble to connect to local Samba server

    Quote Originally Posted by JanDeAlleman View Post
    First of all thanks for taking the time to help me!
    Well that is what this forum is about...all good.

    This is interesting: doing a ping test (with ping and nmap) would make you believe that the host is down - no connection can be established.
    Always best to show commands and output if possible. With the 'nmap' command, I would have expected port 445 tcp (and perhaps port 139 tcp) to be reported as open.

    However! I am perfectly able to ssh into the address, and my kodi-box is connecting fine with it over samba as well.

    Could the host be blocked? I've added it to the /etc/hosts list as such:
    Code:
    192.168.1.72    samba
    Perhaps. Is the samba server in the form of a Linux host? Firewall blocking services?
    openSUSE Leap 15.2; KDE Plasma 5

  5. #5

    Default Re: Uanble to connect to local Samba server

    Hm, it seems I am able to connect when entering the hosts address manually (with ctrl+L), but still unable via 'WORKGROUP' in Nautilus.

    Nmap gives me the following:
    Code:
    map 192.168.178.72 
    Starting Nmap 7.80 ( https://nmap.org ) at 2020-10-29 10:12 CET 
    Nmap scan report for 192.168.178.72 
    Host is up (0.0011s latency). 
    Not shown: 997 closed ports 
    PORT     STATE SERVICE 
    139/tcp  open  netbios-ssn 
    445/tcp  open  microsoft-ds 
    8080/tcp open  http-proxy 
     
    Nmap done: 1 IP address (1 host up) scanned in 0.07 seconds
    Additionally, I have added the samba server(s) to my FSTAB to mount them automatically on boot. The command 'umount -a' gives me no errors, but trying to navigate to the files via nautilus (again) gives me the following error:
    Code:
    The program is not installed setuid root - "user" CIFS mounts not supported.

  6. #6

    Default Re: Uanble to connect to local Samba server

    I should probably give you the FSTAB-entries:

    Code:
    # samba servers 
    //192.168.178.72/server/Server/Music /media/music cifs x-systemd.automount,noauto,rw,iocharset=utf8,guest,uid=jan,gid=jan,file_mode=0770,dir_mode=0770 0 0 
     
    //192.168.178.72/server/Server/Videos/Films /media/movies cifs x-systemd.automount,noauto,rw,iocharset=utf8,guest,uid=jan,gid=jan,file_mode=0770,dir_mode=0770 0 0 
     
    //192.168.178.72/server/Server/Videos/Series /media/series cifs x-systemd.automount,noauto,rw,iocharset=utf8,guest,uid=jan,gid=jan,file_mode=0770,dir_mode=0770 0 0
    The reading/writings rights for /media are set accordingly, btw.

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,269
    Blog Entries
    1

    Default Re: Uanble to connect to local Samba server

    Quote Originally Posted by JanDeAlleman View Post
    Hm, it seems I am able to connect when entering the hosts address manually (with ctrl+L), but still unable via 'WORKGROUP' in Nautilus.
    That’s as expected if SMB2 (or SMB3) is in use. Samba browsing via NetBIOS relied on the deprecated SMB1 protocol (now disabled by default).

    The nmap output is as expected.
    openSUSE Leap 15.2; KDE Plasma 5

  8. #8

    Default Re: Uanble to connect to local Samba server

    Quote Originally Posted by deano_ferrari View Post
    That’s as expected if SMB2 (or SMB3) is in use. Samba browsing via NetBIOS relied on the deprecated SMB1 protocol (now disabled by default).

    The nmap output is as expected.
    I see - better to leave it disabled then?

    Any idea how I can fix the mount via FSTAB?

  9. #9

    Default Re: Uanble to connect to local Samba server

    I have changed the 'uid' and 'gid' in /etc/fstab to '1000', now I get the following error message:
    Code:
    mount.cifs: permission denied
    Would this mean I am closer or further away from a solution?

  10. #10
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,015

    Default AW: Uanble to connect to local Samba server

    uid = User id, get it with
    Code:
    id
    , normally beginns this with 1000 in openSUSE

    gid = group id of users get it also with
    Code:
    id
    normally this is 100 in openSUSE

Page 1 of 5 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •