Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: VirtualBox Cannot start a virtual machine

  1. #1

    Default VirtualBox Cannot start a virtual machine

    Greetings All,

    I am unable to start any virtual machine using VirtualBox.

    The message is:

    The virtual machine 'MyWin7-64' has terminated unexpectedly during startup with exit code 1 (0x1).

    Result Code: NS_ERROR_FAILURE (0x80004005)
    Component: MachineWrap
    Interface: IMachine {85632c68-b5bb-4316-a900-5eb28d3413df}



    This happens on existing or new Virtual Machines.

    I have tried re-installing VirtualBox, but the error persists.


    Using SUSE 15.2 on an AMD Rhyzen CPU.

    Thanx.

    Richard Rosa

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,010

    Default AW: VirtualBox Cannot start a virtual machine

    Post:
    Code:
    zypper se -si virtualbox kernel
    Code:
    uname -a

  3. #3

    Default Re: AW: VirtualBox Cannot start a virtual machine

    Quote Originally Posted by Sauerland View Post
    Post:
    Code:
    zypper se -si virtualbox kernel
    Code:
    uname -a

    Code:
    zypper se -si virtualbox kernel
    Loading repository data...
    Reading installed packages...
    
    S  | Name                             | Type    | Version                             | Arch   | Repository
    ---+----------------------------------+---------+-------------------------------------+--------+--------------------------
    i+ | devel_kernel                     | pattern | 20170319-lp152.6.3                  | x86_64 | Main Repository
    i+ | devel_kernel                     | pattern | 20170319-lp152.6.3                  | x86_64 | Main Repository
    i+ | kernel-default                   | package | 5.3.18-lp152.47.2                   | x86_64 | openSUSE:Leap:15.2:Update
    i+ | kernel-default                   | package | 5.3.18-lp152.47.2                   | x86_64 | Main Update Repository
    i+ | kernel-default                   | package | 5.3.18-lp152.44.1                   | x86_64 | openSUSE:Leap:15.2:Update
    i+ | kernel-default                   | package | 5.3.18-lp152.44.1                   | x86_64 | Main Update Repository
    i  | kernel-default-devel             | package | 5.3.18-lp152.47.2                   | x86_64 | openSUSE:Leap:15.2:Update
    i  | kernel-default-devel             | package | 5.3.18-lp152.47.2                   | x86_64 | Main Update Repository
    i  | kernel-default-devel             | package | 5.3.18-lp152.44.1                   | x86_64 | openSUSE:Leap:15.2:Update
    i  | kernel-default-devel             | package | 5.3.18-lp152.44.1                   | x86_64 | Main Update Repository
    i  | kernel-devel                     | package | 5.3.18-lp152.47.2                   | noarch | openSUSE:Leap:15.2:Update
    i  | kernel-devel                     | package | 5.3.18-lp152.47.2                   | noarch | Main Update Repository
    i  | kernel-devel                     | package | 5.3.18-lp152.44.1                   | noarch | openSUSE:Leap:15.2:Update
    i  | kernel-devel                     | package | 5.3.18-lp152.44.1                   | noarch | Main Update Repository
    i  | kernel-firmware                  | package | 20200107-lp152.1.1                  | noarch | Main Repository
    i  | kernel-firmware                  | package | 20200107-lp152.1.1                  | noarch | Main Repository
    i  | kernel-macros                    | package | 5.3.18-lp152.47.2                   | noarch | openSUSE:Leap:15.2:Update
    i  | kernel-macros                    | package | 5.3.18-lp152.47.2                   | noarch | Main Update Repository
    i  | kernel-preempt                   | package | 5.3.18-lp152.47.2                   | x86_64 | openSUSE:Leap:15.2:Update
    i  | kernel-preempt                   | package | 5.3.18-lp152.47.2                   | x86_64 | Main Update Repository
    i  | kernel-preempt-devel             | package | 5.3.18-lp152.47.2                   | x86_64 | openSUSE:Leap:15.2:Update
    i  | kernel-preempt-devel             | package | 5.3.18-lp152.47.2                   | x86_64 | Main Update Repository
    i  | kernel-preempt-devel             | package | 5.3.18-lp152.44.1                   | x86_64 | openSUSE:Leap:15.2:Update
    i  | kernel-preempt-devel             | package | 5.3.18-lp152.44.1                   | x86_64 | Main Update Repository
    i  | kernel-source                    | package | 5.3.18-lp152.47.2                   | noarch | openSUSE:Leap:15.2:Update
    i  | kernel-source                    | package | 5.3.18-lp152.47.2                   | noarch | Main Update Repository
    i  | kernel-source                    | package | 5.3.18-lp152.44.1                   | noarch | openSUSE:Leap:15.2:Update
    i  | kernel-source                    | package | 5.3.18-lp152.44.1                   | noarch | Main Update Repository
    i  | kernel-syms                      | package | 5.3.18-lp152.47.1                   | x86_64 | openSUSE:Leap:15.2:Update
    i  | kernel-syms                      | package | 5.3.18-lp152.47.1                   | x86_64 | Main Update Repository
    i  | kernel-syms                      | package | 5.3.18-lp152.44.1                   | x86_64 | openSUSE:Leap:15.2:Update
    i  | kernel-syms                      | package | 5.3.18-lp152.44.1                   | x86_64 | Main Update Repository
    i  | nfs-kernel-server                | package | 2.1.1-lp152.9.6.1                   | x86_64 | openSUSE:Leap:15.2:Update
    i  | nfs-kernel-server                | package | 2.1.1-lp152.9.6.1                   | x86_64 | Main Update Repository
    i+ | patterns-devel-base-devel_kernel | package | 20170319-lp152.6.3                  | x86_64 | Main Repository
    i+ | patterns-devel-base-devel_kernel | package | 20170319-lp152.6.3                  | x86_64 | Main Repository
    i  | purge-kernels-service            | package | 0-lp152.4.1                         | noarch | Main Repository
    i  | purge-kernels-service            | package | 0-lp152.4.1                         | noarch | Main Repository
    i  | texlive-l3kernel                 | package | 2017.133.svn44483-lp152.7.2         | noarch | Main Repository
    i  | texlive-l3kernel                 | package | 2017.133.svn44483-lp152.7.2         | noarch | Main Repository
    i  | texlive-l3kernel-doc             | package | 2017.133.svn44483-lp152.7.2         | noarch | Main Repository
    i  | texlive-l3kernel-doc             | package | 2017.133.svn44483-lp152.7.2         | noarch | Main Repository
    i+ | virtualbox                       | package | 6.1.14-lp152.2.5.1                  | x86_64 | openSUSE:Leap:15.2:Update
    i+ | virtualbox                       | package | 6.1.14-lp152.2.5.1                  | x86_64 | Main Update Repository
    i+ | virtualbox-host-source           | package | 6.1.14-lp152.2.5.1                  | noarch | openSUSE:Leap:15.2:Update
    i+ | virtualbox-host-source           | package | 6.1.14-lp152.2.5.1                  | noarch | Main Update Repository
    i  | virtualbox-kmp-default           | package | 6.1.14_k5.3.18_lp152.41-lp152.2.5.1 | x86_64 | openSUSE:Leap:15.2:Update
    i  | virtualbox-kmp-default           | package | 6.1.14_k5.3.18_lp152.41-lp152.2.5.1 | x86_64 | Main Update Repository
    i  | virtualbox-kmp-preempt           | package | 6.1.14_k5.3.18_lp152.41-lp152.2.5.1 | x86_64 | openSUSE:Leap:15.2:Update
    i  | virtualbox-kmp-preempt           | package | 6.1.14_k5.3.18_lp152.41-lp152.2.5.1 | x86_64 | Main Update Repository
    i  | virtualbox-qt                    | package | 6.1.14-lp152.2.5.1                  | x86_64 | openSUSE:Leap:15.2:Update
    i  | virtualbox-qt                    | package | 6.1.14-lp152.2.5.1                  | x86_64 | Main Update Repository
    i  | virtualbox-websrv                | package | 6.1.14-lp152.2.5.1                  | x86_64 | openSUSE:Leap:15.2:Update
    i  | virtualbox-websrv                | package | 6.1.14-lp152.2.5.1                  | x86_64 | Main Update Repository
    
    uname -a
    Linux rubberducky.rbm 5.3.18-lp152.47-preempt #1 SMP PREEMPT Thu Oct 15 16:05:25 UTC 2020 (41f7396) x86_64 x86_64 x86_64 GNU/Linux

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,010

    Default AW: VirtualBox Cannot start a virtual machine

    Install once more and restart:
    Code:
    zypper in -f virtualbox-kmp-preempt

  5. #5

    Default Re: AW: VirtualBox Cannot start a virtual machine

    Quote Originally Posted by Sauerland View Post
    Install once more and restart:
    Code:
    zypper in -f virtualbox-kmp-preempt
    Thanx, but still no joy.

    Here is what I did:

    Code:
      Removed Virtualbox. (Using YAST GUI)
      Reinstalled VirtualBox (Using YAST Gui)
    
     (commands as root)
      zypper in -f virtualbox-kmp-preempt
          (zypper reported already installed)
      chmod 4750 /usr/lib/virtualbox/VirtualBoxVM
      zypper install virtualbox-host-source kernel-devel kernel-default-devel
      /sbin/vboxconfig
    Same error.

    VirtualBox WAS working back in June when I installed 15.2. This is the first time since then that I have tried to use it.
    Something new has been added since then....

    Richard Rosa

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,010

    Default AW: VirtualBox Cannot start a virtual machine

    Closed for the Moment.

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,010

    Default AW: VirtualBox Cannot start a virtual machine

    Reopened and moved to Virtualization.

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,010

    Default AW: VirtualBox Cannot start a virtual machine

    chmod 4750 /usr/lib/virtualbox/VirtualBoxVM
    zypper install virtualbox-host-source kernel-devel kernel-default-devel
    /sbin/vboxconfig
    Why do you do that?

  9. #9

    Default Re: AW: VirtualBox Cannot start a virtual machine

    Quote Originally Posted by Sauerland View Post
    Why do you do that?
    Because VirtualBox would not start without these actions.

    Pop-Up when starting indicated that permissions were wrong.
    After permission change, pop-indicated that /sbin/vboxconfig was needed.
    That in turn needed the install of the devel libraries.

    Richard Rosa

  10. #10
    Join Date
    Jul 2018
    Location
    Loma Linda, Mo
    Posts
    366

    Default Re: VirtualBox Cannot start a virtual machine

    Just open a terminal and type - I have no idea what you are attempting to start - this is how I start it from a terminal.

    Code:
    nohup VirtualBox &
    Opensuse 15.2 with VirtualBox VM's (XP, 10 & OpenSUSE 15.0)
    Pi4 with Ubuntu MATE 20.04
    Unix since 1974 (pdp-11 in "B" , Interdata 7/32 in "C") (AT&T, Tandy, Convergent, IBM, NCR, HP flavors)
    Linux since 1995 (mandrake, redhat, fedora, centos, now OpenSUSE)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •