Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Wireless Keyboard - Input Lagging

  1. #1

    Default Wireless Keyboard - Input Lagging

    Guys,

    I have a Combo Wireless Logitech Mouse + Keyboard - Logitech MK345

    The wireless mouse works fine, its the keyboard that's issue...

    From other articles on the net, I am informed that this could be due to the USB Power Saving
    feature and that I have to set autosuspend to -1 for this port ?

    My output of ;

    Code:
    # lsusb
    
    Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    
    
    Bus 005 Device 002: ID 046d:c534 Logitech, Inc. Unifying Receiver  <-- the receiver 
    
    
    Bus 005 Device 003: ID 1b3f:2019 Generalplus Technology Inc. 
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Pls advise.

    Thanks in advance.

  2. #2

    Default Re: Wireless Keyboard - Input Lagging

    Quote Originally Posted by MarcoMeswara View Post
    Guys,

    I have a Combo Wireless Logitech Mouse + Keyboard - Logitech MK345

    The wireless mouse works fine, its the keyboard that's issue...

    From other articles on the net, I am informed that this could be due to the USB Power Saving
    feature and that I have to set autosuspend to -1 for this port ?

    My output of ;

    Code:
    # lsusb
    
    
    Bus 005 Device 002: ID 046d:c534 Logitech, Inc. Unifying Receiver  <-- the receiver
    Pls advise.

    Thanks in advance.
    This is the right subforum ? Or 'Hardware' ?
    Last edited by hcvv; 25-Oct-2020 at 04:04. Reason: repaired QUOTE tag

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    27,340

    Default Re: Wireless Keyboard - Input Lagging

    Wireless here is Wifi.

    I will move it.
    Henk van Velden

  4. #4

    Default Re: Wireless Keyboard - Input Lagging

    Quote Originally Posted by hcvv View Post
    Wireless here is Wifi.

    I will move it.
    Thank you. Sorry for the mistake.

  5. #5

    Default Re: Wireless Keyboard - Input Lagging

    Guys,

    I have a Combo Wireless Logitech Mouse + Keyboard - Logitech MK345

    The wireless mouse works fine, its the keyboard that's issue...

    From other articles on the net, I am informed that this could be due to the USB Power Saving feature
    and that I have to set autosuspend to -1 for this port ?

    My output of ;


    Code:
    # lsusb
    
    Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    
    
    Bus 005 Device 002: ID 046d:c534 Logitech, Inc. Unifying Receiver  <-- the receiver 
    
    
    Bus 005 Device 003: ID 1b3f:2019 Generalplus Technology Inc. 
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

    Pls advise.
    Any of you with a similar problem ?
    How did you guys disable autosuspend for yr keyboard ?


    Thanks in advance.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,258
    Blog Entries
    1

    Default Re: Wireless Keyboard - Input Lagging

    Here's a page describing how to inhibit autosuspend for a given USB device...
    https://hamwaves.com/usb.autosuspend/en/

    Archwiki guide...
    https://wiki.archlinux.org/index.php...SB_autosuspend

    You can also inhibit USB autosuspend completely by adding "usbcore.autosuspend=-1" kernel boot option in grub.
    openSUSE Leap 15.2; KDE Plasma 5

  7. #7
    Join Date
    Jul 2018
    Location
    Loma Linda, Mo
    Posts
    367

    Default Re: Wireless Keyboard - Input Lagging

    I fix my wireless keyboard lag by adding a USB extension cable and putting the Logitech dongle in line of sight to the keyboard.
    The thickness of the laptop was enough to drop keystrokes.

    The wireless mouse never showed any issues.

    Logitech claims up to 30 feet - just 3 feet was enough to drop keystrokes.
    Opensuse 15.2 with VirtualBox VM's (XP, 10 & OpenSUSE 15.0)
    Pi4 with Ubuntu MATE 20.04
    Unix since 1974 (pdp-11 in "B" , Interdata 7/32 in "C") (AT&T, Tandy, Convergent, IBM, NCR, HP flavors)
    Linux since 1995 (mandrake, redhat, fedora, centos, now OpenSUSE)

  8. #8

    Default Re: Wireless Keyboard - Input Lagging

    Quote Originally Posted by larryr View Post
    I fix my wireless keyboard lag by adding a USB extension cable and putting the Logitech dongle in line of sight to the keyboard.
    The thickness of the laptop was enough to drop keystrokes.
    Hi .. How long was the usb extension cable ? 1m ?

    The wireless mouse never showed any issues.
    Yep... Thats the odd part ...

    Logitech claims up to 30 feet - just 3 feet was enough to drop keystrokes.
    In WinX, i have tried upto 10-12 feet... All good...

  9. #9

    Default Re: Wireless Keyboard - Input Lagging

    Quote Originally Posted by deano_ferrari View Post
    Here's a page describing how to inhibit autosuspend for a given USB device...
    https://hamwaves.com/usb.autosuspend/en/

    Archwiki guide...
    https://wiki.archlinux.org/index.php...SB_autosuspend

    You can also inhibit USB autosuspend completely by adding "usbcore.autosuspend=-1" kernel boot option in grub.
    Nice... I have gone with the modprobe.d suggestion .. Will test and revert ...

  10. #10
    Join Date
    Jul 2018
    Location
    Loma Linda, Mo
    Posts
    367

    Default Re: Wireless Keyboard - Input Lagging

    Quote Originally Posted by MarcoMeswara View Post
    Hi .. How long was the usb extension cable ? 1m ?
    Mine is a 6 foot rolled to about 1 foot - just enough to get in sight of the keyboard. FYI 3 foot is about 1 meter.
    Last edited by hcvv; 26-Oct-2020 at 06:34. Reason: Repaiterd Quote tag
    Opensuse 15.2 with VirtualBox VM's (XP, 10 & OpenSUSE 15.0)
    Pi4 with Ubuntu MATE 20.04
    Unix since 1974 (pdp-11 in "B" , Interdata 7/32 in "C") (AT&T, Tandy, Convergent, IBM, NCR, HP flavors)
    Linux since 1995 (mandrake, redhat, fedora, centos, now OpenSUSE)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •