Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 41

Thread: Does Plasma 5.20 really support Wayland and nvidia?

  1. #11
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    974

    Default Re: Does Plasma 5.20 really support Wayland and nvidia?

    Quote Originally Posted by hcvv View Post
    Maybe a bit off-topic, but there is no reason to make things in /etc/profile.d executable for anybody. Where have you read that that should be done?
    The first time I tried it without being executable, and when that didn't work, I tried it the other way.

  2. #12
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    27,328

    Default Re: Does Plasma 5.20 really support Wayland and nvidia?

    Quote Originally Posted by pilotgi View Post
    The first time I tried it without being executable, and when that didn't work, I tried it the other way.
    OK, I do not to want to interfere with your way of working, but do you understand why it is not needed (or maybe is needed) or are you just experimenting with try and error? Do you understand what the colloquial expression (making/being executable" stands for (as usual it does express very badly or not all all with what is really done)?
    No answers needed, this off-topic will only consume time and not help you with your problem I guess.
    Henk van Velden

  3. #13
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,821
    Blog Entries
    15

    Default Re: Does Plasma 5.20 really support Wayland and nvidia?

    Quote Originally Posted by pilotgi View Post
    If I add nvidia-drm.modeset=1 to the kernel parameters, the nvidia driver doesn't load. If I choose a Plasma/Wayland session, I get the llvmpipe Mesa graphics which runs my display at 4K and everything seems to work OK but scrolling is a little jerky in Firefox.

    I also created the file kwin.sh in /etc/profile.d and made it executable.

    When I tried the recommended command
    Code:
    cat /sys/module/nvidia_drm/parameters/modeset
    I'm supposed to get Y but I get N. Of course because the nvidia driver isn't loaded.

    I thought I had to use nomodeset in order to load the nvidia driver. The nvidia-drm.modeset=1 parameter isn't working for me.

    Edit: The cat /sys/module command returns N even with the nvidia 455.28 driver running, probably because of the default nomedeset kernel parameter but that's the only way I can get it to load.
    Hi
    No, nomodeset is to disable KMS, the loading of the nouveau (in your case), used at boot if the nvidia card has issues with the nouveau driver until you can install the proprietary one. The nouveau is blacklisted?

    Your installing the driver the hard way by the looks.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #14
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    974

    Default Re: Does Plasma 5.20 really support Wayland and nvidia?

    Quote Originally Posted by malcolmlewis View Post
    Hi
    No, nomodeset is to disable KMS, the loading of the nouveau (in your case), used at boot if the nvidia card has issues with the nouveau driver until you can install the proprietary one. The nouveau is blacklisted?

    Your installing the driver the hard way by the looks.
    Nouveau is blacklisted. If I remove nomodeset from the kernel parameters, the nvidia driver doesn't load. Yes, I install the driver the hard way.

  5. #15
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,821
    Blog Entries
    15

    Default Re: Does Plasma 5.20 really support Wayland and nvidia?

    Quote Originally Posted by pilotgi View Post
    Nouveau is blacklisted. If I remove nomodeset from the kernel parameters, the nvidia driver doesn't load. Yes, I install the driver the hard way.
    Hi
    So what model card?

    Code:
    /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #16
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    974

    Default Re: Does Plasma 5.20 really support Wayland and nvidia?

    GTX 1060 PCIe SSE2

    Edit: Using the recommended command, the output says kernel modules: nouveau, nvidia_drm, nvidia. Not sure where nouveau is coming from.

  7. #17
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,821
    Blog Entries
    15

    Default Re: Does Plasma 5.20 really support Wayland and nvidia?

    Quote Originally Posted by pilotgi View Post
    GTX 1060 PCIe SSE2
    Hi
    I need to see the output, want to see what it's using
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #18
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    974

    Default Re: Does Plasma 5.20 really support Wayland and nvidia?

    Code:
    09:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] [10de:1c03] (rev a1) 
            Subsystem: ASUSTeK Computer Inc. Device [1043:85ab] 
            Kernel driver in use: nvidia 
            Kernel modules: nouveau, nvidia_drm, nvidia
    

  9. #19
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,821
    Blog Entries
    15

    Default Re: Does Plasma 5.20 really support Wayland and nvidia?

    Quote Originally Posted by pilotgi View Post
    Code:
    09:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] [10de:1c03] (rev a1) 
            Subsystem: ASUSTeK Computer Inc. Device [1043:85ab] 
            Kernel driver in use: nvidia 
            Kernel modules: nouveau, nvidia_drm, nvidia
    
    Hi
    And you have the libnvidia-egl-wayland.so* files installed? And you removed the nomodeset?

    Code:
    cat /etc/default/grub | grep GRUB_CMDLINE_LINUX_DEFAULT
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #20
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    974

    Default Re: Does Plasma 5.20 really support Wayland and nvidia?

    I have the libwayland-egl1 package installed. Nomodeset was added by me to the kernel parameters. Without it, the nvidia driver doesn't load. The output I posted above is when booting with nomodeset.

Page 2 of 5 FirstFirst 1234 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •