Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Processor stuck at min frequency...

  1. #1

    Default Processor stuck at min frequency...

    Hi all,

    Since last Friday, I've been having a very weird issue with my computer. I woke it up from sleep and it began to behave completely erratically: the LED for "battery charging" was always on and it was extremely slow. I of course tried to reboot it, but the issues remained: slowness and (possibly unrelated?) it somehow thinks to be always charging, whether AC is plugged or not (funny thing: the LED correctly changes its colour when charged, from orange to green and then back to orange when it starts discharging, all still thinking AC is always on!!).

    I tried everything over the weekend to find the reason for these weird issues. I tested on a USB drive system, it was still a bit slow, but hard to tell whether it was because of being on USB or not, I reinstalled the system, disconnected/reconnected the battery, changed the SSD for another (and reinstalled again!), changed the RAM, flashed the BIOS, all of it to no avail. The laptop is still slow.

    But now, I have found, at least, the reason for it being slow: the CPU frequency is always at its "resting" minimal frequency (400Mhz). I tried to force it through software by changing the governor or directly the frequency (using cpupower frequency-set), but of course, it didn't do anything. I looked at the temperature, it's not because the temperature sensor is broken (temperature is normal using "sensors").

    Any advice at this point? I believe it all points to this being purely a hardware problem (and thus that I'll have to buy another laptop...), but I you guys have an idea of something I could do to fix this mess, I'd very gladly read it!

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,859
    Blog Entries
    15

    Default Re: Processor stuck at min frequency...

    Quote Originally Posted by flyos View Post
    Hi all,

    Since last Friday, I've been having a very weird issue with my computer. I woke it up from sleep and it began to behave completely erratically: the LED for "battery charging" was always on and it was extremely slow. I of course tried to reboot it, but the issues remained: slowness and (possibly unrelated?) it somehow thinks to be always charging, whether AC is plugged or not (funny thing: the LED correctly changes its colour when charged, from orange to green and then back to orange when it starts discharging, all still thinking AC is always on!!).

    I tried everything over the weekend to find the reason for these weird issues. I tested on a USB drive system, it was still a bit slow, but hard to tell whether it was because of being on USB or not, I reinstalled the system, disconnected/reconnected the battery, changed the SSD for another (and reinstalled again!), changed the RAM, flashed the BIOS, all of it to no avail. The laptop is still slow.

    But now, I have found, at least, the reason for it being slow: the CPU frequency is always at its "resting" minimal frequency (400Mhz). I tried to force it through software by changing the governor or directly the frequency (using cpupower frequency-set), but of course, it didn't do anything. I looked at the temperature, it's not because the temperature sensor is broken (temperature is normal using "sensors").

    Any advice at this point? I believe it all points to this being purely a hardware problem (and thus that I'll have to buy another laptop...), but I you guys have an idea of something I could do to fix this mess, I'd very gladly read it!
    Hi
    Checked the BIOS settings? What model laptop and cpu?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Processor stuck at min frequency...

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Checked the BIOS settings? What model laptop and cpu?
    Yes, I checked the BIOS settings, nothing there to set the CPU frequency, a very basic BIOS. Sorry, I should have added the laptop spec: it's an Asus Transformer Flip TP301UA. Below the output of KInfoCenter:

    Operating System: openSUSE Tumbleweed 20201014
    KDE Plasma Version: 5.20.0
    KDE Frameworks Version: 5.75.0
    Qt Version: 5.15.1
    Kernel Version: 5.8.14-1-default
    OS Type: 64-bit
    Processors: 4 × Intel® Core™ i5-6200U CPU @ 2.30GHz
    Memory: 7.7 Gio of RAM
    Graphics Processor: Mesa DRI Intel® HD Graphics 520

    (The bug arose before the update to Plasma 5.20 by the way... I merely updated the system, in the off-chance it would automagically fix the system, you never know)

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,859
    Blog Entries
    15

    Default Re: Processor stuck at min frequency...

    Quote Originally Posted by flyos View Post
    Yes, I checked the BIOS settings, nothing there to set the CPU frequency, a very basic BIOS. Sorry, I should have added the laptop spec: it's an Asus Transformer Flip TP301UA. Below the output of KInfoCenter:

    Operating System: openSUSE Tumbleweed 20201014
    KDE Plasma Version: 5.20.0
    KDE Frameworks Version: 5.75.0
    Qt Version: 5.15.1
    Kernel Version: 5.8.14-1-default
    OS Type: 64-bit
    Processors: 4 × Intel® Core™ i5-6200U CPU @ 2.30GHz
    Memory: 7.7 Gio of RAM
    Graphics Processor: Mesa DRI Intel® HD Graphics 520

    (The bug arose before the update to Plasma 5.20 by the way... I merely updated the system, in the off-chance it would automagically fix the system, you never know)
    Hi
    You don't have any additional boot line commands like acpi ones?

    Code:
    cat /etc/default/grub | grep  GRUB_CMDLINE_LINUX_DEFAULT
    lsmod | grep intel
    If nothing acpi in the grub output, could try disabling intel_pstate to see if that changes it, append the following to the kernel optional parameters via YaST booloader;

    Code:
    intel_pstate=disable
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: Processor stuck at min frequency...

    Thanks for your advice! Here are the information you requested (nothing out of the ordinary, since I reinstalled the system):

    Code:
    cat /etc/default/grub | grep  GRUB_CMDLINE_LINUX_DEFAULT
    
    GRUB_CMDLINE_LINUX_DEFAULT="splash=silent quiet mitigations=auto"
    
    Code:
    lsmod | grep intel
    
    snd_soc_acpi_intel_match    45056  1 snd_soc_skl 
    snd_soc_acpi           16384  2 snd_soc_acpi_intel_match,snd_soc_skl 
    snd_hda_intel          57344  3 
    snd_intel_dspcfg       24576  2 snd_hda_intel,snd_soc_skl 
    snd_hda_codec         167936  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek,snd_soc_hdac_hda 
    btintel                32768  1 btusb 
    intel_powerclamp       20480  0 
    snd_hda_core          110592  8 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_soc_hdac_h
    da,snd_soc_skl 
    bluetooth             708608  43 btrtl,btintel,btbcm,bnep,btusb,rfcomm 
    intel_pmc_bxt          16384  1 iTCO_wdt 
    kvm_intel             331776  0 
    intel_rapl_msr         20480  0 
    kvm                   860160  1 kvm_intel
    snd_pcm               167936  8 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_compress,snd_soc_core,snd_soc_skl,snd_hda_core,snd_pcm_dmaengine 
    snd                   114688  20 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realt
    ek,snd_timer,snd_compress,snd_soc_core,snd_pcm 
    intel_lpss_pci         24576  0 
    intel_lpss             16384  1 intel_lpss_pci 
    intel_xhci_usb_role_switch    16384  0 
    roles                  16384  1 intel_xhci_usb_role_switch 
    intel_pch_thermal      16384  0 
    intel_rapl_common      32768  2 intel_rapl_msr,processor_thermal_device 
    intel_soc_dts_iosf     20480  1 processor_thermal_device 
    intel_ishtp_loader     24576  0 
    intel_ishtp_hid        28672  0 
    ghash_clmulni_intel    16384  0 
    aesni_intel           372736  8 
    glue_helper            16384  1 aesni_intel
    crypto_simd            16384  1 aesni_intel
    cryptd                 28672  3 crypto_simd,ghash_clmulni_intel
    intel_ish_ipc          28672  0 
    intel_ishtp            61440  4 cros_ec_ishtp,intel_ishtp_hid,intel_ish_ipc,intel_ishtp_loader 
    crc32c_intel           24576  5
    


    I'll try the following right now and report right away.
    Code:
    intel_pstate=disable

  6. #6

    Default Re: Processor stuck at min frequency...

    I'm sorry to report that disable intel pstate didn't change anything to the issue. The computer is still stuck at 400Mhz, even when the CPU is used:

    Code:
    cat/sys/devices/system/cpu/cpu*/cpufreq/scaling_cur_freq
    
    399999 
    400000 
    400000 
    399999

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,859
    Blog Entries
    15

    Default Re: Processor stuck at min frequency...

    Quote Originally Posted by flyos View Post
    I'm sorry to report that disable intel pstate didn't change anything to the issue. The computer is still stuck at 400Mhz, even when the CPU is used:

    Code:
    cat/sys/devices/system/cpu/cpu*/cpufreq/scaling_cur_freq
    
    399999 
    400000 
    400000 
    399999
    Hi
    OK, remove that setting, reboot into the older kernel from grub - 5.8.12 is it working? If it is then a bug report is needed.... openSUSE:Submitting bug reports - openSUSE
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,859
    Blog Entries
    15

    Default Re: Processor stuck at min frequency...

    Hi
    As a side note, if the earlier kernel does work, then you might want to look at updating the multi kernel version to keep that one as the next update pulls in kernel 5.8.15 which may or maynot work...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9

    Default Re: Processor stuck at min frequency...

    Quote Originally Posted by malcolmlewis View Post
    Hi
    OK, remove that setting, reboot into the older kernel from grub - 5.8.12 is it working? If it is then a bug report is needed.... openSUSE:Submitting bug reports - openSUSE
    I don't have the older kernel since I reinstalled the system since the issue. But if I get this right, you wanted to check this wasn't a kernel bug, is that it? To check that, I booted a newly downloaded USB live of Leap (so, different, more "robust" kernel), and my CPU is still stuck at 400Mhz (checked with the command in my previous message, while the CPU was busy, directly from the live USB). I guess this means it's coming from the hardware, right?

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,859
    Blog Entries
    15

    Default Re: Processor stuck at min frequency...

    Quote Originally Posted by flyos View Post
    I don't have the older kernel since I reinstalled the system since the issue. But if I get this right, you wanted to check this wasn't a kernel bug, is that it? To check that, I booted a newly downloaded USB live of Leap (so, different, more "robust" kernel), and my CPU is still stuck at 400Mhz (checked with the command in my previous message, while the CPU was busy, directly from the live USB). I guess this means it's coming from the hardware, right?
    Hi
    Sounds like it Does the system have a fan? Do you hear it running? If so, first thing I would look at is cleaning out the fan... likely dust bunnies and overheating (check temps via sensors command).
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •